1. thanospap97's Avatar
    Hi there,
    I am a new user of Htc 8x, I enjoyed my new device with a small annoying problem. The phone cannot fully charge when it's powered on. It only reaches 90% and as soon as that happens, the led starts flashing from red to green every 5 seconds. If I turn of the device, the led goes steady red until fully charge, when it goes steady green. And when I turn it on, it's ok, 100% (99% actually).
    I haven't tried a soft reset. Would that be a solution? Any answers are welcome.

    Thank you in advance
    02-04-2014 04:17 PM
  2. joe_easton's Avatar
    I've used a 8X for over a year; never heard of this. If its under warranty then have it swapped out.
    02-04-2014 04:52 PM
  3. rhadoo01's Avatar
    Hi. I have exactly the same problem with my 8x. I have it for about 3 months. When charging and reaches 90% or 85% the led turns green for some seconds and then back to red for few seconds, then red again and so on. If i restart the phone, the battery is something like 98-99% and charges just fine. This means that I have to restart the phone everytime I charge it. Veeeerrryyy annoying. Software or hardware problem? Thanks!
    03-20-2014 03:50 AM
  4. Judge_Daniel's Avatar
    When an 8X's LED flashes between red and green, it means it is overheating and will no longer charge (in order to keep the battery from exploding). If your phone isn't hot to the touch when this happens, then something is faulty and you should get it replaced.
    03-20-2014 06:25 PM
  5. fatclue_98's Avatar
    I have had this problem on many HTC devices going all the way back to my WM Imagio. I don't think it's limited to the 8X.
    04-10-2014 10:14 PM
  6. i106's Avatar
    I have the same problem... Somewhere around 80 something percent the led flashes green then when I wake up the phone it turns red again... And then it takes some time to get the battery full. Usually the led turns green on 99% and sometimes I actually see the illusive 100%. I did have this case scenario when the battery was 3% and after hours of charging it only get to 5% and when I restarted the battery it was 90 something... I have the phone for about one month. So I believe that not necessarily the battery is the problem. I read somewhere that people are having this issue with other phones as well. Maybe it is related to some of the GDR Updates. I do not know about that because my phone got all of the updates in a row so I did not know weather my phone was good prior or not. I also read that some people fix the problem with combination of restoring and completely discharging the battery. So I do plan to do the following next days.
    1. Restore the phone.
    2. Drain the battery till it starts no more.
    3. Fully charge the phone
    4. Maybe restore the phone again.

    Or maybe I will wait for Windows Phone 8.1 and see if that helps...
    04-12-2014 03:07 AM

Similar Threads

  1. Camera Grip Will Not Charge, 6 Flashes.
    By Gikero in forum Nokia Lumia 1020
    Replies: 5
    Last Post: 02-27-2014, 09:38 AM
  2. Rubber case that also fits wireless charging shell for Nokia 925
    By Gleb Budilovsky in forum Nokia Lumia 925
    Replies: 1
    Last Post: 02-04-2014, 05:39 PM
  3. Html5 games work in the browser but cannot be controlled
    By colinkiama in forum Windows Phone 8
    Replies: 1
    Last Post: 02-04-2014, 03:18 PM
  4. Camera-flash flashlight apps turn off for no reason!!!
    By ryan_linz in forum Nokia Lumia 920
    Replies: 1
    Last Post: 02-04-2014, 09:19 AM
  5. Cannot connect to 3G after updating to Lumia Black on 520
    By Dennet Menezes in forum Nokia Lumia 520
    Replies: 2
    Last Post: 02-03-2014, 08:33 AM
LINK TO POST COPIED TO CLIPBOARD