1. jschipmann's Avatar
    So my son got tired of his iPhone 4S and wanted to ditch it after seeing my nokia lumina icon. He has been using this iPhone on straighttalk now for about a month with an AT&T compatible sim card form straighttalk.

    I finally bit the bullet and bought him an HTC 8x, got it in, did a software reset on it (settings, about, reset), popped the sim card in, tested phone calls.. great ok worked. Internet however was a no go, so I figured like the iphone I had to enter in APN settings, found the area to put them in and after testing several different ones found these to be the only ones that even somewhat worked (thanks op! http://forums.windowscentral.com/htc...ight-talk.html)

    with those settings internet was really horribly spotty, sometimes it would get through after about a minute to a page, other times it would time out completely. I continued on and got MMS working so he could send pics through text, verified everything else worked and went back to the internet issue. I re-tried every APN I could find and none of them worked at all with the exception of the link above. But what makes this even more strange to me is I am connected via Wi-Fi in home to a 50/5 cable connection... it is as if the phone isn't even trying to use that connection and is erroring out through straighttalk. Coincidentally my daughter is on AT&T... so I took out the APN settings, popped her sim in and the phone works flawlessly, webpages load quickly, I can get to the store with no issues and so on.

    Figuring this might be another software issue I wiped the phone again, and retried everything... still no luck. Internet is painfully slow when it does work, I cant get through to the store most of the time, it took about a half hour of trying to log in to a microsoft account....

    I then read about the HTC connection setup app and after a half hour of trying I finally get the app installed only to have the app fail on me because it can not find a local database of some sort.

    At this point I think ok maybe it is some weird thing and I need to unlock the phone, I paid to unlock it (had a t-mobile sim nearby that wasn't active to pop in and then enter the unlock codes in.) ok great phone is now unlocked, try to enter in APNs and try the internet again.... still the same issue.

    I am about at wits end here trying to figure out what in the heck to try next. Has anyone else run in to this? I can get all the software info tonight when I am home again and I can pry the phone away from my son lol.

    I also signed up last night for a dev account and was going to attempt to Dev unlock the phone and possibly try different software revisions. I'm accustom to rooting, and jailbreaking and loading custom roms on other phones so I figure this wouldn't be too big of a deal, however I am new to windows phone so still have a lot to learn and research.

    Thanks for anyone who might help :)
    03-10-2014 11:22 AM
  2. hopmedic's Avatar
    03-10-2014 12:03 PM
  3. jschipmann's Avatar
    those are the same APN settings I am using (as in my link above with the exception of APN name which I assume is just the friendly name). I have deleted and readded everything to make sure no other APNs are on there, and rebooted each time.

    The MMS settings use a ip instead of URL in your link compared to my original find, but they are both the same as the DNS name for mms3.tracfone.com resolves to the 66.209.11.33 IP.
    03-10-2014 12:55 PM
  4. hopmedic's Avatar
    I wish I could point you in the right direction. If you read through the thread, you'll see that it took me a while to get it working on the 822 that I gave my step-daughter, but unfortunately, I wasn't able to nail it down to what I had done wrong before that. Keep trying. The information you need is in that thread - it's just a matter of getting it to work.
    03-10-2014 09:31 PM
  5. jschipmann's Avatar
    SUCCESS!!!

    my problem was two fold for some reason.

    I took my son and went to my fiancees house for dinner the other night. Before we went we tried the Access Point software method (which wouldn't load BTW) then removed all APNs rebooted put them back in and same issues. When we arrived at my fiancees house (and after dinner) I tried it all again... and it worked???? we then joined WiFi and it worked much better since we had limited signal.

    Finally the phone was working proper!

    But wait there is more...

    We got home and poof.... it stopped working again for internet and data... thinking this to be too odd I went to the wifi settings and seen the connection to our home wifi was constantly trying to connect but just wouldn't do it. I turned WiFi off and the phone began to work as normal. Thinking this was too odd I tried to look to see if I could limit the phone to a/b or g and no luck. I told my son to leave it off wifi at the house and the phone has worked fine since (granted a bit slow though but no where near like before)

    In the mean time I researched and found someone else with a similar problem, and they ended up as a last ditch effort and upgraded their routers firmware.... I tried it and seen mine did have an upgrade available, so I downloaded, applied snatched my sons phone and it connected and is working great.

    My router is a Buffalo Tech N450 running their DD-WRT build (in case anyone wonders when they are researching this same issue)
    03-11-2014 09:24 PM
  6. hopmedic's Avatar
    That's awesome! Glad to hear it worked.
    I also have a Buffalo router. I love the flexibility of DD-WRT (I actually put it onto a Linksys before buying the Buffalos). Two, actually. I've got the high-powered models. One in my basement and one in my attic. I bought high-powered routers when I was renting the trailer behind my church, and I put one on the platform of the church (closest part of the building to the trailer), and one in the trailer, and set them up to repeat the church's wifi. Free internet! When we bought our house two years ago, and set up the server and the router in the basement, I discovered two places in the house that got no signal. The kitchen - probably due to the tile floor, possibly duct work between floors, and the bedroom I use as my office. Who knows why, but I'd lean toward ductwork and the electric panel. So I stuck the second router in the attic and ran Ethernet between them. Works great, and can stream to my phone while on the riding mower anywhere on our 0.6 acres.
    03-13-2014 10:56 AM

Similar Threads

  1. Questions about Xbox Music on Windows 8
    By themadpoet1 in forum General Desktop, Laptop & Tablet Discussion
    Replies: 1
    Last Post: 03-14-2014, 02:42 PM
  2. get maps right on your lockscreen with this new app
    By vmnoodle71 in forum App Spotlight
    Replies: 4
    Last Post: 03-14-2014, 12:43 PM
  3. How to "fix" glossy shade on matte black L920?
    By pookyjoralyn in forum Nokia Lumia 920
    Replies: 6
    Last Post: 03-13-2014, 03:58 AM
  4. Problem(?) with earpiece
    By HyperionR in forum Nokia Lumia 925
    Replies: 3
    Last Post: 03-10-2014, 02:09 PM
  5. Microsoft shopping around for a new global advertising campaign to focus on One strategy
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 03-10-2014, 11:34 AM
LINK TO POST COPIED TO CLIPBOARD