1. anon8942354's Avatar
    I have WP8.1 installed on my HTC 8X and just the other day I started receiving this message when visiting certain websites.

    "Search for app in the Store? You need to install an app for this task. Would you like to search for one in the store? (Yes or No)"

    I can't understand why this started to happen. I don't see anything special of the websites in question. What can I do to prevent this popup message. Its very annoying.
    07-15-2014 07:36 AM
  2. Pete's Avatar
    This happens if you attempt to download or open a file from the internet - for example, if you want to download and view a PDF document, you need PDF Reader or Acrobat Reader.

    Without knowing what websites you're visiting, it's hard to assist more than this. If you're browsing off the beaten track, the internet may be attempting to trick you into installing a virus, for which you need to thank the phone for saving you...
    greenspot and a5cent like this.
    07-15-2014 08:28 AM
  3. anon8942354's Avatar
    One of them is CNN.com. And when I tap yes, the search comes up with nothing to install.
    07-15-2014 08:34 AM
  4. Pete's Avatar
    cnn.com seems to load ok for me. What are you tapping on to get the search message?
    07-15-2014 08:38 AM
  5. anon8942354's Avatar
    Oh, IE is configured to use the "mobile version" for website preference. And the message appears while the CNN.com homepage page is loading. When I tap on any other CNN page, I get the same message for every page in the domain. Could be something CNN introduced?
    07-15-2014 08:42 AM
  6. Pete's Avatar
    Very odd. I don't see that when I use the mobile version of the web site.

    Try deleting your internet cache and see if that helps at all.
    07-15-2014 08:49 AM
  7. anon8942354's Avatar
    What a freakin' mess. Deleted history/cache to the browser and restarted the phone. Nothing changed.
    07-15-2014 08:59 AM
  8. anon8942354's Avatar
    With the help of another WP8.1 user, I change the CNN address from mobile.cnn.com to m.cnn.com which stops the annoying store message. But the CNN pages are loaded in a different way and no video is available. I checked my latest installed apps. XBox Video (version 2.6.115.0) was recently installed automatically. Wondering if that has something to do with the problem.
    BBMINI likes this.
    07-15-2014 10:16 AM
  9. Pete's Avatar
    Great that you've managed to sort it out.
    Himanshu Chowdhary likes this.
    07-15-2014 10:52 AM
  10. BBMINI's Avatar
    I've had this exact same problem recently (with CNN.com and other sites) and have wondered why it was happening, so thanks for the thread and info.
    07-19-2014 10:49 AM
  11. anon8942354's Avatar
    I've had this exact same problem recently (with CNN.com and other sites) and have wondered why it was happening, so thanks for the thread and info.
    I haven't resolved anything though. I have checked with two other co-workers who also have Windows Phones installed with WP8.1 and they have the same exact issue. I believe it's a website thing and not the phone or the browser.
    07-21-2014 07:35 AM
  12. EdZ#WN's Avatar
    I've started getting this exact same problem. My phone is a W8 HTC 8x. The problem is always related to www.CNN.com, but I've seen it irregularly on other URLs.

    It is very annoying.
    07-22-2014 08:13 AM
  13. MrWhiteman's Avatar
    I don't have this problem with 930. CNN's mobile site comes straight up.
    07-22-2014 08:17 AM
  14. taymur's Avatar
    Yes happening with me also.
    07-22-2014 08:18 AM
  15. anon8942354's Avatar
    Hmmm. I've checked my OS version (on my HTC 8X), in which I'm running Preview for Developers version 8.10.12397.895. I can not definitively say this is the issue. But nothing else has changed on my device since that update. Maybe a change to IE was introduced. And it affects other browsers too. I installed the UC Browser and when accessing CNN.com I get the same annoying message.
    07-22-2014 12:48 PM
  16. EdZ#WN's Avatar
    So, its browser independent and occurs in 8 and 8.1. Mine is 8.0.10501.127. It also appears that its only recently appeared for most of us.
    07-22-2014 01:07 PM
  17. BBMINI's Avatar
    I haven't resolved anything though. I have checked with two other co-workers who also have Windows Phones installed with WP8.1 and they have the same exact issue. I believe it's a website thing and not the phone or the browser.
    That's interesting because after reading this thread previously and changing the URL saved for CNN in my favorites to m.cnn.com, it seemed to fix the problem for me. I haven't gotten the "search for an app" pop-up since then. For reference, I'm on 8.0 rather than the 8.1 dev preview.
    07-22-2014 06:19 PM
  18. anon8942354's Avatar
    One problem with using the "m.cnn.com" URL (for me), is that I can't play the videos linked to the pages.
    07-23-2014 09:57 AM
  19. BBMINI's Avatar
    One problem with using the "m.cnn.com" URL (for me), is that I can't play the videos linked to the pages.
    I haven't noticed (or even checked) to see if videos will play for me, but CNN's photos don't show when I use the m.cnn.com address so I suspect the videos won't play either.

    Also, as a related update, even though I no longer get the pop-up "search for an app" on CNN.com, I've now noticed it on a couple other sites so the problem isn't fixed for me yet either. Would still love to know what caused the problem to start happening in the first place. Could it be carrier related? I'm on VZW with a 928.
    07-24-2014 04:40 PM
  20. anon8942354's Avatar
    Without doing a single thing the annoying popup message has stopped appearing since Sunday. Gees! Isn't technology amazing when it fixes itself without human intervention.
    07-28-2014 08:23 AM
  21. foxbat121's Avatar
    Without doing a single thing the annoying popup message has stopped appearing since Sunday. Gees! Isn't technology amazing when it fixes itself without human intervention.
    It's more an CNN website authoring issue which they fixed due to complaints. I saw it multiple times before. Probably related to some file downloads that IE mobile doesn't recognize and throw up this 'search store ' message in order to view the files.
    07-28-2014 01:46 PM

Similar Threads

  1. [APP] ShareFolder Explorer for free today.
    By zinkpad in forum App Spotlight
    Replies: 4
    Last Post: 06-07-2015, 02:56 PM
  2. Microsoft won't let you set Google as default search on some new Lumias
    By PxuLL in forum Windows Phone 8.1 Preview for Developers
    Replies: 15
    Last Post: 07-16-2014, 03:59 AM
  3. Microsoft preventing new Lumia owners from changing the default search engine to Google
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 07-15-2014, 07:23 AM
  4. Can anyone help me install apps from my SD card?
    By pradyum mohta in forum Ask a Question
    Replies: 1
    Last Post: 07-15-2014, 06:37 AM
LINK TO POST COPIED TO CLIPBOARD