1. Eric J F's Avatar
    Recently my T-Mobile US 8X with OS 14203.306 has been making repeated tones when the charge hits 100%. Occasionally it briefly shows green, makes a tone, then goes back to red for a while until it stays green. One time it hit 100% and made a series of repeated tones until I restarted it.

    Otherwise, the phone works perfectly and the battery charges and runs down the same as before.

    By the way, I don't have any battery apps beyond the native Battery Saver.

    Has anyone seen this, and/or knows if a battery recalibration might help?
    11-16-2014 09:35 PM
  2. Maslikad's Avatar
    I have problem when charger hits 100%(green) i unplug USB cable and is shown 96%, i can't reach 100%.
    11-20-2014 01:31 PM
  3. Eric J F's Avatar
    That seems to be a common issue with these phones; there are some other earlier posts about this. Mine only stays at 100% a few seconds.
    Maslikad likes this.
    11-20-2014 04:02 PM

Similar Threads

  1. Last update drains my battery problem!
    By aziouazrayes in forum Nokia Lumia 1020
    Replies: 9
    Last Post: 12-02-2014, 07:43 PM
  2. Why is my battery draining so much faster than normal?
    By Windows Central Question in forum Ask a Question
    Replies: 5
    Last Post: 11-19-2014, 08:04 AM
  3. Why isn't my phone working after I took the battery out (Nokia 630)?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 11-17-2014, 01:02 AM
  4. Strange new playlist bug
    By Noahma in forum Groove Music
    Replies: 0
    Last Post: 11-16-2014, 09:33 PM
  5. Replies: 0
    Last Post: 11-16-2014, 05:19 AM
LINK TO POST COPIED TO CLIPBOARD