1. orangeman's Avatar
    I'm trying to use my Google Voice number as the number for my Arrive handset. I keep getting a message that this phone can't be configured for Google Voice integration. I know from another thread that others have used their Sprint Number as their Google Voice number, but I am doing it the other way around.

    As anyone gotten the integration to work on the Arrive using their Google Voice number?
    06-05-2011 06:57 PM
  2. kingp's Avatar
    Yeah, that usually means there is a flag on your account, that is preventing integration. For instance, is your phone provided by your employer? If so, this is why. You would need to contact someone at Sprint support and have them look at it.

    From there they have to determine if this phone is "corporate liable" or "person liable", meaning does your employer pay the bill, or do you? If you pay the bill, they will remove the flag and then the integration will go through.

    If this isn't your situation at all, and this is just your personal line, then it's another issue, maybe a billing or accounting error, and you willl need to call Sprint to resolve it.

    I had this issue on my EVO and my Arrive. I get a 25% discount through Dell which caused integration to fail. They removed the flag, since I pay the bill each month, and then it worked.

    Now, beware that if you integrate with option 2 and you call another Sprint number, the person receiving the call WILL BE BILLED (i.e. minutes deducted) on their plan. YOUR call to them will be free (any mobile, any time if you have the appropriate plan), but they will be deducted the minutes (even if they are on your family plan). Calls to your Google Voice number, will also have minutes deducted from your account, and for the caller, so have others call your Sprint number (like Family/Friends) so they (and you) won't be billed. Option 2 really is only a slightly better upgrade from just using the Google Voice app. I may un-integrate it and just go back to the app, personally.

    This is a huge debate over in the Google Voice forum and ZDNET ran a story on it.

    Sorry for the huge post, but thought it might be of worth.
    orangeman likes this.
    06-06-2011 10:14 AM
  3. orangeman's Avatar
    Thank you so much, this is excellent information. The store person had no clue as to what they were doing so I'll bet he mis-coded it somehow that caused this flag. Also, all that other information you provided was excellent, I didn't know about this. Thanks again!
    06-06-2011 11:58 PM
  4. St13fL3r's Avatar
    Do you have a ringback subscription? That has been a cause for this issue too.
    06-07-2011 08:20 PM
LINK TO POST COPIED TO CLIPBOARD