1. Crazgod's Avatar
    So I've seen that there a number of threads talking about Mango battery life. While I'm running into this I am experiencing a number of other issues. I wanted to see if anyone else has run into these and found anything that works to resolve it. As I type this, I am unable to access my phone at all.

    I've had my HTC Arrive for around 4 months and before installing Mango last week I could make it 2-3 days between charges with normal phone and data usage. I always left wi-fi and bluetooth on as they didn't appear to impact battery life too much.

    After installing Mango I quickly noticed that the battery wouldn't even last a whole day. Even charging the phone overnight, the battery wouldn't charge to more than 50-75%. I turned the battery saver on right after the upgrade but the battery saver icon stayed on all the time so I figured it may be linked to the problem so I turned it off a few days ago. The battery life has gotten progressively worse but I'll come back to that.

    Another new problem since installing Mango is that I now get some sort of notification every 3-5 minutes all day and night. It is typically only for emails but the phone notifies me for the same emails over and over each time displaying the new message notification and playing the notification sound. So when I read a message, a few minutes later I get another new message notification and have to read the same message to stop it from beeping. I assumed this was related somehow to whatever is going on but I don't know how to stop it. I've tried changing the account settings on my email boxes but nothing has helped.

    Now, back to the battery, at this point the phone has become completely useless. It has been on the charger for most of the last 36 hours while I've been working on my computer. It charges for 5-10 minutes before powering down and displaying the huge battery bar with a little red at the bottom. 5-10 minutes later it will turn on again and charge for another 5-10 minutes before powering down again. It is stuck in this 5-10 minute loop. When it is on and charging, I can enter my code and within seconds it will show "Goodbye", power down and display the battery for 5-10 minutes before powering on again.

    I will definitely be going to Sprint the next chance I get but I was hoping somebody here may have an idea of something I can try. This was the best phone I have ever had and now it is completely useless.

    Thanks in advance.
    10-09-2011 09:11 PM
  2. Coffee's Avatar
    sounds like a bad battery, not much you can do except swap it out.
    10-09-2011 09:22 PM
  3. Crazgod's Avatar
    sounds like a bad battery, not much you can do except swap it out.
    Yeah, I understand. Thats does sound possible I but i find it strange that things would occur that seem like it is working a lot harder than it should, and the battery goes bad as soon as I upgrade to Mango. It seems equally likely that some combination of applications and the new functions of Mango are draining it too fast for it to replenish.
    10-09-2011 09:30 PM
  4. kylej1050's Avatar
    Did you do a factory reset after the update?
    10-10-2011 11:22 AM
LINK TO POST COPIED TO CLIPBOARD