1. book1245's Avatar
    I just spent a semester in LA with my brand new Arrive, and I love this phone.

    Upon returning to Boston in December, MMS messages stopped working. I would get the usual errors associated with failed picture texts.
    A few days later, I went outside the city, and picture messages worked again, only to stop once I got back in. I began to wonder if this was a coincidence, or if it was my phone, or the city or what.

    I spent the holidays back home in Delaware, during which my phone's mms and picture text worked just fine. Landed in Boston fifteen minutes ago, and MMS ceased once more.

    Is any other Sprint user in Boston seeing this happen to them? I might go to a Sprint store to see if they have any answers.

    Anyone else in the area encountering something similar?
    01-02-2012 10:56 PM
  2. rchillin's Avatar
    I know its a late reply but I was in Boston on business in December and again in Feburary. I had similar issues where I could not send any MMS messages. I called Sprint, went through the motions, and said there was nothing wrong with my configurations. Back home, outside of Atlanta, I'm still continuing to have issues where I can't send and receive MMS messages on a more frequent basis and its just starting to become real annoying. I've been with Sprint for 13 years and the only reason why I'm still with them is the 20% discount I currently get. But with these failures of basic service and lack of a roadmap for Windows Phone devices has me seriously considering getting a different provider.
    02-27-2012 12:03 PM
LINK TO POST COPIED TO CLIPBOARD