1. rabit1's Avatar
    Hi,

    Starting today I notice that my HD7 led is blinking orange-green when I plug in the charger. And turns out it's not charging. It looks like it is charging when I plug it in.. It's making a familiar sound and the battery indicator shows that it is charging, but battery charge level is not increasing.
    Checking the Settings-Battery Saver, the percentage stay at the same number.. even after a few hours charging.

    I've tried removing the battery, and once or twice it looks like the blinking stopped. The led shows normal orange indicating it is charging, but after a few minutes it goes back to blinking orange-green.

    Anyone knows what the problem is? Could it be a dead battery? I've been using this battery for around 6 months I think.

    Thanks
    03-14-2012 07:44 PM
  2. eastbayrae's Avatar
    The battery is done. When it's low it will blink orange, not orange-green alternating.
    03-15-2012 06:53 AM
  3. Dave Blake's Avatar
    The orange green blinking is used by HTC in all there devices it indicates that the device has over heated it won't charge when it is blinking orange and green. If it's not hot then I would say it's the battery.
    03-15-2012 07:32 AM
  4. rabit1's Avatar
    well this one is defintely the worst battery i got ever since i remember. only 6 months?
    03-15-2012 08:50 AM
  5. jimski's Avatar
    If only six months old it should be covered by warranty (1 year). I always buy a spare battery for my new phones and switch them out every 3 months to balance the wear and tear. Will be a new experience with the Lumia 900 and their fixed battery.

    Sent from my HTC Surround using Board Express
    03-15-2012 09:21 AM
  6. rabit1's Avatar
    Update:

    So just for the heck of it I tried again after a few days..
    and.. the darn thing worked again.. The battery charges again.
    As far as I remember, I didn't do anything may have causes this behavior.

    I still don't know why it didn't work before, and why it works again now
    03-24-2012 08:39 PM
  7. rabit1's Avatar
    Update:

    So just for the heck of it I tried again after a few days..
    and.. the darn thing worked again.. The battery charges again.
    As far as I remember, I didn't do anything may have causes this behavior.

    I still don't know why it didn't work before, and why it works again now

    New update.
    Ever since my battery won't charged, I bought a second battery
    which was working fine.
    Yesterday both batteries won't charged initially. I got the same
    orange-green blinking led. After several tries (more like 20
    times, swapping batteries) finally one of them worked.

    Funny thing is after that one worked, I tried to charge the other one
    which won't charged initially, and it also worked. They were both charging.

    I'm starting to wonder if this is not the case of a bad battery, but could it
    be my HD7 problem? I mean, both batteries go bad? kind of unlikely don't u think?
    03-25-2012 08:29 PM
  8. jimski's Avatar
    Agree it would be unlikely both batteries would be bad. Charger, cable, micro USB port, or you HD7 could be the problem. But probably not the battery. Try eliminating some possibilities. Like will it charge when plugged into a PC, or with a different cable?

    Sent from my HTC Surround using Board Express
    03-25-2012 09:13 PM
  9. tcarroll12's Avatar
    help, im having the same issue the battery isn't charging (and neither is the new one I just bought off amazon) and the lights are blinking both red and green! Howeverrrr I did drop it and that's when the problem started. The new batt sort of holds a charge, when I put it in it had the heart over the battery but this morning (NINE hours ago) it seems to have charged *slightly*... Anyone have suggestions?? This was a free phone from my boss and I cant upgrade my phone for another 11mos!!!
    10-18-2013 08:56 AM
LINK TO POST COPIED TO CLIPBOARD