1. waazzupppp's Avatar
    Hey guys,

    I have an M8 Win coming tomorrow and plan to try it unlocked on T-Mobile. Anyone have any luck with this yet? I've heard that you can land HSPA+ 14.4 speeds in the 1900mHz bands, but no word on LTE or APN settings yet. HTC Connection Setup should take care of the T-Mobile settings (if it is compatible with WP 8.1.1) and I have a One M7 Dev Edition (again without proper LTE bands) and it pulls down some amazing speeds in the Seattle area.

    Anyone try it yet, and if so, what were your results? I'd hate to snag a Nano SIM from T-Mo only to find it borked.
    08-25-2014 09:37 AM
  2. rdubmu's Avatar
    An M8 is already unlocked, what have you found about this? Is MMS working? visual voice mail working?
    08-27-2014 08:38 PM
  3. waazzupppp's Avatar
    Sorry for the slow reply...

    With T-Mobile, the fast.t-mobile.com DATA APN got me an intermittent data connection. It was quick when I had it, but it was sketchy at best. It seemed to authenticate, do a quick 'sync attempt' then drop connection very quickly - almost like VZW messed with the settings on LTE. HSPA+/3G didn't seem to want to run at all, but again, it may just have dropped before it finished it's business.

    VVM worked after a soft reset of the device with the SIM inserted - but only over WiFi. I don't think the data connection would make it long enough to download it.

    MMS is a no go. There is no option to enter the MMS APN - at this point...
    08-28-2014 01:04 PM

Similar Threads

  1. How to delete "not installed" apps in "My Apps"?
    By WPCentral Question in forum Ask a Question
    Replies: 0
    Last Post: 08-25-2014, 08:43 AM
  2. T-Mobile Simple Starter plan gets quadruple the data for just $5 more
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-25-2014, 08:30 AM
  3. Still Waiting on Phone 8.1 in Canada
    By WPCentral Question in forum Ask a Question
    Replies: 0
    Last Post: 08-25-2014, 07:51 AM
  4. lumia cyan update for lumia 620 in India
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-25-2014, 07:46 AM
  5. mobile data not working on windows 8.1 lumia 520
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-25-2014, 07:23 AM
LINK TO POST COPIED TO CLIPBOARD