1. blakeam's Avatar
    Hey Guys!

    Just swapped out my Lumia for a Titan II (Lovin it!) and noticed that my battery drains a bit more than the Lumia's does. I'm in an office building most of the day so my signal isn't as strong as it could be, hence the faster drain. Also, LTE hasn't been switched on yet in Baton Rouge so I don't need the radio for it.

    When I had the Lumia, I did this:

    How to toggle EDGE, 3G and 4G on your Nokia Lumia 900 | WPSuperfanboy

    and noticed that I got a good EDGE signal in my building. I was just wondering if anyone had figured out how to apply the above fix to their Titan IIs, as that would be a great energy saving option for those of us who are not always in a good coverage area or in an LTE market (low signal = more battery needed).

    Any suggestions?
    05-04-2012 12:22 PM
  2. Tikerz's Avatar
    I assume you've tried it already on the Titan II and it doesn't work the same?
    05-04-2012 01:50 PM
  3. blakeam's Avatar
    Yes but the problem on the Titan is that when you get to the last step, there is no "Toggle ENS (REBOOT)" which apparently is required so that the settings stick. On the Lumia there is this option...but not on the Titan...
    05-04-2012 04:00 PM
  4. Binson#WP's Avatar
    I would also really like to know how to do this. It recognizes a 4g network but my data plan is only 3g so I need to get it to use 3g only.

    If anyone has any idea, that would be amazing. Thanks!
    05-16-2012 04:08 PM
  5. jaj324's Avatar
    I'm curious why you traded your Nokia for the HTC. If battery life is important to you the 900 has more battery capacity and a more energy efficient screen.

    Sent from my Lumia 900 using Board Express
    05-16-2012 04:26 PM
  6. rdubmu's Avatar
    The screen on the lumia is better when it works, if you don't use your phone at work, the battery should be good

    Sent from my PI86100 using Board Express
    05-17-2012 06:11 AM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD