1. raidel00's Avatar
    Is anyone else having location mapping issues with their titan? Endomondo tracks my runs just fine, but on bing.com through IE it will not find my current location AND when I try to find my phone on windowsphone.com it too will not successfully find my phone even though I have it turned on, on my phone (connected faster and the save randomly). Also my check in (ME hub) will not find places around me. My lumia 900 did work correctly when I did find my phone so I'm just wondering if it's something to do with the Titan?
    05-10-2012 02:51 PM
  2. naplesbill's Avatar
    My Titan II is working. Sometimes find my phone doesn't work on the first attempt. Log out and back in and see if it works. You have to enable location in search settings too. Hit the search button then go into settings there and turn on location.

    Also go into settings for the people hub and make sure location is turned on there. This is what allows you to check in.


    Sent from my PI86100 using Board Express
    05-10-2012 03:27 PM
  3. rdubmu's Avatar
    The maps app works just fine for me. Bing scout works great as well :)

    Sent from my PI86100 using Board Express
    banjaboo likes this.
    05-10-2012 09:16 PM
  4. karelj's Avatar
    My opinion is that the GPS functionality is horrendous compared to my old Focus. My Focus used to easily get a GPS lock even when Im inside my apt. The Titan II struggles even when outside.

    Sent from my HTC Titan II using Board Express
    05-11-2012 12:11 AM
  5. naplesbill's Avatar
    My opinion is that the GPS functionality is horrendous compared to my old Focus. My Focus used to easily get a GPS lock even when Im inside my apt. The Titan II struggles even when outside.

    Sent from my HTC Titan II using Board Express
    You must have a bad unit or a setting is turned off somewhere. My GPS performance blows the Focus away. Indoor or out, no problem getting a fix.

    Sent from my PI86100 using Board Express
    05-11-2012 01:54 AM
  6. Tikerz's Avatar
    I just got a replacement Titan II and the GPS location puts me in Akron Ohio. I live in Scottsdale, Arizona.

    It worked briefly once. I've been rebooting and turning Location services on/off with no luck. Do I have a defective device again?
    06-20-2012 02:28 PM
  7. j6ck83's Avatar
    I just got a replacement Titan II and the GPS location puts me in Akron Ohio. I live in Scottsdale, Arizona.

    It worked briefly once. I've been rebooting and turning Location services on/off with no luck. Do I have a defective device again?
    A few times I've used the GPS it's put me in Ohio. Couldn't figure out why. After messing with the map a little bit, it gave me the correct location.
    06-20-2012 04:24 PM
  8. Tikerz's Avatar
    Apparently, it's AT&T and their LTE network giving false A-GPS readings! Just a recent development! It puts me dead on top of the AT&T Data Center in Akron, Ohio. AT&T is aware of the problem.

    Titan 2 GPS issues. - AT&T Community Support
    06-20-2012 04:52 PM
  9. trazer's Avatar
    My Titan II GPS works great compared to my other phones. I have had no issues so far, which is a nice change coming from Samsung Android phones where GPS was a joke lol.
    06-21-2012 10:54 AM
LINK TO POST COPIED TO CLIPBOARD