1. gtg465x's Avatar
    In the dialer enter ##3282#. This will open a diagnostic menu. Select ... > settings and you will see an option for network type. This setting gets reset if the phone is restarted.
    12-04-2011 04:14 PM
  2. kevm14's Avatar
    Nice. Now, where is HSPA category...
    12-04-2011 05:27 PM
  3. gtg465x's Avatar
    Nice. Now, where is HSPA category...
    Heh, yeah. That's what I was looking for when I discovered this.
    12-04-2011 06:13 PM
  4. Billone's Avatar
    In the dialer enter ##3282#. This will open a diagnostic menu. Select ... > settings and you will see an option for network type. This setting gets reset if the phone is restarted.
    I must admit my ignorance here. I have a list of about 20 options. Where should I start with these options? Are theses documented anywhere?
    12-04-2011 06:15 PM
  5. HeyCori's Avatar
    What is the benefit of this?
    12-04-2011 06:21 PM
  6. gtg465x's Avatar
    What is the benefit of this?
    If you don't plan on using much data you can set your phone to 2G only for better battery life. I don't use it myself, but some people do.
    12-04-2011 07:06 PM
  7. jimski's Avatar
    Not sure if this works on AT&T. Tried this several times on my Surround, but the change never sticks once you exit the diagnostic menu. Always on 3G only (on my Surround).

    Sent from my HTC Surround using Board Express
    12-04-2011 07:40 PM
  8. gtg465x's Avatar
    Not sure if this works on AT&T. Tried this several times on my Surround, but the change never sticks once you exit the diagnostic menu. Always on 3G only (on my Surround).

    Sent from my HTC Surround using Board Express
    Worked for me. Can't remember if I backed out of the diagnostics app or just left it running in the background, but it showed E in the status bar and I got ultra low data speeds when I tested while browsing.
    12-04-2011 07:55 PM
  9. Billone's Avatar
    Worked for me. Can't remember if I backed out of the diagnostics app or just left it running in the background, but it showed E in the status bar and I got ultra low data speeds when I tested while browsing.
    I can't tell if it's working. I still have horrible connection speed and it still says 4g at the top of the display.
    12-04-2011 08:10 PM
  10. palandri's Avatar
    2G isn't bad if you are looking at things like Google News.
    12-04-2011 08:16 PM
  11. jd914's Avatar
    It didn't work for me. I can't manage to save the setting for it to stay on 2G its goes right back to 3g right away.
    12-04-2011 08:21 PM
  12. kevm14's Avatar
    Yeah the setting doesn't do anything on mine either.
    12-04-2011 09:19 PM
  13. gtg465x's Avatar
    Did you guys leave the diagnostic app open or back out after changing the setting? I definitely got it to stick for five minutes or so until I changed it back. Not sure if it would have eventually switched back on its own.
    12-04-2011 09:46 PM
  14. fkiehner's Avatar
    Mine doesn't hold either. Sure would like to get out of the 4g to see if the music apps work better.

    Sent from my HTC Titan using Board Express
    12-05-2011 12:22 AM
  15. ilifecomputer's Avatar
    Awesome trick, though I haven't tried it yet.

    Additionally, anyone know if HSPA+ uses a different tower than a phone on HSPA would? I would love to see my phone drop to 3G (from fake 4G). Sometimes I have no coverage and I see that people with non "4G" att phones still have a couple bars.

    Hopefully, this 2g trick will work when I need emergency coverage.
    12-05-2011 01:25 AM
  16. kevm14's Avatar
    Did you guys leave the diagnostic app open or back out after changing the setting? I definitely got it to stick for five minutes or so until I changed it back. Not sure if it would have eventually switched back on its own.
    Tried both. No change from "4G."
    12-05-2011 04:15 AM
  17. ZombieBacchus's Avatar
    I would LOVE to be able to force my Titan for 3G only when I am at work because I only have one bar of 4G and my phone's data connection is too slow to do anything. Most apps wont even connect. I called ATT and they tried to do something from their end to force 3G but it didnt work.
    12-06-2011 02:31 PM
  18. power5's Avatar
    I did not think the phone ever said 3G. Even if you are not in a 4G area. I live in a 4G city though so no idea. Have not traveled with my Titan yet. What do the people who live in 3g cities have on their top bar?
    12-06-2011 08:32 PM
  19. HeyCori's Avatar
    I did not think the phone ever said 3G. Even if you are not in a 4G area. I live in a 4G city though so no idea. Have not traveled with my Titan yet. What do the people who live in 3g cities have on their top bar?
    I live in 3G area but my phone still says 4G. They're programmed to say 4G even if you don't have 4G.
    12-06-2011 08:43 PM
  20. jmagwp's Avatar
    The benefit of this is that, like me, I can't get a data signal at all in my office on my Titan, but my coworker that has an iPhone gets a perfectly acceptable signal. A couple of times the phone has dropped down to Edge for a few seconds where it displays a full 5 bars of signal strength. On "4G" 99.9% of the time I'm getting 1 bar with no ability to actually transmit any data. I'm going to try this and see if it works. Edge would be a major improvement over the 4G I'm getting, or not getting.

    EDIT: Just tried it and it doesn't stick or do anything. :-(
    Last edited by jmagwp; 12-07-2011 at 04:57 PM.
    12-07-2011 04:49 PM
  21. shaileshk's Avatar
    In the dialer enter ##3282#. This will open a diagnostic menu. Select ... > settings and you will see an option for network type. This setting gets reset if the phone is restarted.
    i have tried but after setting it to 2g or gsm but when i call on from the phone niether i can hear nor the other side can here. also when i recieve the call both side cannot here.

    can anybody let me know why this is happening. Am i doing wrong setting . Please let me have detail procedure for the same.

    In NOkia Lumia 800 in the cellular setting they have the option to set at 3g when found. you can auto set this.

    rds
    shailesh
    02-11-2012 07:37 PM
  22. boss.king's Avatar
    What's wrong with Settings>Mobile network>Highest connection speed>edge ?
    02-11-2012 08:56 PM
  23. HeyCori's Avatar
    What's wrong with Settings>Mobile network>Highest connection speed>edge ?
    That option isn't there for AT&T Titans.
    02-11-2012 09:01 PM
  24. boss.king's Avatar
    That option isn't there for AT&T Titans.
    Ahh, I didn't know that
    02-11-2012 09:15 PM
LINK TO POST COPIED TO CLIPBOARD