1. Fred Mertz's Avatar
    I couldn't find a place to put this. So, if it exist elsewhere, feel free to move the thread.

    Anyway, what the hell is up with Google Chrome? This has been my go-to browser for the last few years and it was always super fast and error free. But within the last couple of months it has become unbearable to use with it's constant "Not Responding" issues. So, what can be done to fix this? I have used both CCleaner as well as internal browser diagnostics to clear out the cache. But neither are effective as the problems always resurface a few minutes later. YouTube hasn't been any help in finding a solution either.

    Any help is greatly appreciated. Thanks in advance.
    06-15-2014 01:55 PM
  2. Himanshu Chowdhary's Avatar
    I haven't used chrome much but if there is something like add ons / extensions try disabling them. Also what happens when you browse in private mode ?
    Lastly at what time /activity do you get not responding ?
    Guytronic likes this.
    06-15-2014 01:59 PM
  3. Corepc's Avatar
    Reinstall Chrome
    or
    USE Internet Explorer (if available)
    06-15-2014 02:00 PM
  4. CaptainAnywho's Avatar
    It's possible that it may be a hardware related issue (low-spec will run anything poorly in general). I'm more inclined to believe that it may just be chrome updates focusing less on stability and more on features. Try installing the beta builds to see if performance is any better.
    Himanshu Chowdhary likes this.
    06-15-2014 02:00 PM
  5. phing77's Avatar
    Feel free to try Internet Explorer if you want to. Everyone here gonna recommend it anyway. The new IE is pretty fast actually
    06-15-2014 02:01 PM
  6. Himanshu Chowdhary's Avatar
    True both ie10 and 11 are swift and stable. Not at all system hog :)
    Guytronic likes this.
    06-15-2014 02:03 PM
  7. Fred Mertz's Avatar
    I haven't used chrome much but if there is something like add ons / extensions try disabling them. Also what happens when you browse in private mode ?
    Lastly at what time /activity do you get not responding ?
    There is no rhyme or reason as to what causes the issues. It ranges from browsing online or even when I launch Chrome. This isn't to be confused with crashing as it never just stops working. It hangs from a few seconds to a few minutes until whatever it is correct itself. Then it becomes functional and I can browse away and then for whatever reason it's back to the 'Not responding" issues, until it corrects itself again. Lather, rinse, repeat.
    06-15-2014 02:07 PM
  8. Himanshu Chowdhary's Avatar
    There is no rhyme or reason as to what causes the issues. It ranges from browsing online or even when I launch Chrome. This isn't to be confused with crashing as it never just stops working. It hangs from a few seconds to a few minutes until whatever it is correct itself. Then it becomes functional and I can browse away and then for whatever reason it's back to the 'Not responding" issues, until it corrects itself again. Lather, rinse, repeat.

    did you try reinstalling chrome on your machine ?
    06-15-2014 02:13 PM
  9. Akash Patel's Avatar
    There is no rhyme or reason as to what causes the issues. It ranges from browsing online or even when I launch Chrome. This isn't to be confused with crashing as it never just stops working. It hangs from a few seconds to a few minutes until whatever it is correct itself. Then it becomes functional and I can browse away and then for whatever reason it's back to the 'Not responding" issues, until it corrects itself again. Lather, rinse, repeat.
    I was having this issue when I had install the dev version of chrome and sometimes the tab goes black the transition from one tab to other is also not smooth so I installed the public version and it is working fine now.But make sure you uninstall it completely
    I clean everything with ccleaner and also repair my registry.
    06-15-2014 02:22 PM
  10. AnestisL820's Avatar
    Had the same problem... So many lags... Finally i am using mozilla and IE. Propably they are caring more for Chrome OS and and not windows based PC.
    06-15-2014 02:30 PM
  11. xandros9's Avatar
    You could try resetting the browser's settings/reinstalling Chrome.

    Perhaps try Firefox or IE if you're up for a change.
    06-15-2014 02:47 PM
  12. trwrt's Avatar
    This kinda sounds like a problem with your DNS servers to me. If name resolution is slow/unreliable then you will get bad browser behavior because every page nowadays is pulling in stuff from all over the place. Do you have problems with other browsers besides Chrome? You could go into your network settings and try overriding your ISP's DNS server addresses with 8.8.8.8 or the opendns ones and see if that helps.
    06-16-2014 12:54 AM
  13. Fred Mertz's Avatar
    This kinda sounds like a problem with your DNS servers to me. If name resolution is slow/unreliable then you will get bad browser behavior because every page nowadays is pulling in stuff from all over the place. Do you have problems with other browsers besides Chrome? You could go into your network settings and try overriding your ISP's DNS server addresses with 8.8.8.8 or the opendns ones and see if that helps.
    I get the same issues with Firefox from time to time, but it's never as bad as Chrome though.

    As for uninstalling/re-installing, I've done that a few times with no success in fixing problem.
    06-16-2014 01:03 AM
  14. JamesPTao's Avatar
    I couldn't find a place to put this. So, if it exist elsewhere, feel free to move the thread.

    Anyway, what the hell is up with Google Chrome? This has been my go-to browser for the last few years and it was always super fast and error free. But within the last couple of months it has become unbearable to use with it's constant "Not Responding" issues. So, what can be done to fix this? I have used both CCleaner as well as internal browser diagnostics to clear out the cache. But neither are effective as the problems always resurface a few minutes later. YouTube hasn't been any help in finding a solution either.

    Any help is greatly appreciated. Thanks in advance.
    Ditto and to top it off the browser got an add on or infection and synched it to all devices. Disabled sync cleared all devices and reset chrome and it still comes up. Constantly loads bull**** on my co.puter. Doesn't effect operating system so far. Sent chrome the lead page it draws from and all information three months ago and it still isn't fixed. Used to love this browser but ready to quit if its just going to expose my computer to risks.
    06-16-2014 01:20 AM
  15. Laura Knotek's Avatar
    How about trying Firefox instead?

    I use Firefox in Windows 8.1 Update 1 and in Linux Mint 16, and I do not have any issues like you are having.
    Himanshu Chowdhary likes this.
    06-16-2014 01:29 AM
  16. Ixia's Avatar
    Also having issues with it on both the Ipad and PC. Frequently hangs or crashes, too slow a lot of the time.
    Himanshu Chowdhary likes this.
    06-16-2014 01:41 AM
  17. Conan143's Avatar
    hey dude try google 64 bit chrome released on developer channel it is faster than 32 bit and u will not notice any not responding issues...
    here is the link to google chrome 64-bit ...https://www.google.com/chrome/browse...tra=devchannel
    06-16-2014 01:44 AM
  18. Himanshu Chowdhary's Avatar
    @OP which version of chrome are you using ?
    Laura Knotek likes this.
    06-16-2014 01:45 AM
  19. Fred Mertz's Avatar
    @OP which version of chrome are you using ?
    It says that it's 'Up to Date' (Version 35.0.1916.153 m)
    06-16-2014 06:28 AM
  20. Jas00555's Avatar
    I think I know how to fix it. My grandmother had this problem and I fixed it for her and now she's super happy. Her browsing has been amazing ever since.

    1) Go to Control Panel
    2) Go to programs
    3) Go to programs and features
    4) scroll down to Google Chrome
    5) click on it
    6) uninstall
    7) use IE
    06-16-2014 03:37 PM
  21. wpgeek820's Avatar
    I cannot play youtube videos on IE. Midway through a video, the player freezes up but the audio still continues. I was hoping it would be fixed in the Windows 8.1 Update 1 but it didn't. So now I'm back to Firefox.

    If anyone else have the same problem, do share and let me know if you were able to solve it. I do want to come back to IE.
    06-17-2014 12:52 PM
  22. Akash Patel's Avatar
    I cannot play youtube videos on IE. Midway through a video, the player freezes up but the audio still continues. I was hoping it would be fixed in the Windows 8.1 Update 1 but it didn't. So now I'm back to Firefox.

    If anyone else have the same problem, do share and let me know if you were able to solve it. I do want to come back to IE.
    Update Microsoft Silverlight,adobe flash player(active x).
    06-17-2014 02:09 PM
  23. Funky Cricket's Avatar
    The only issues I have with IE are legacy network equipment with old java. I use firefox for that. I stopped using chrome over a year ago when it was taking longer to open and using more resources than IE 8. I have a few issues now and again with IE 11, but for the most part IE works for 90% of what I need, quickly and with out issues, and I spend 10 hours a day working with 20+ browser tabs open.
    06-17-2014 02:15 PM
  24. viper1986's Avatar
    Feel free to try Internet Explorer if you want to. Everyone here gonna recommend it anyway. The new IE is pretty fast actually
    06-22-2014 02:25 AM
  25. Ankit Nawlakha's Avatar
    True both ie10 and 11 are swift and stable. Not at all system hog :)

    What about mozilla firefox!??
    06-23-2014 02:33 AM

Similar Threads

  1. google account problem
    By Spiri91 in forum Windows Phone 8.1 Preview for Developers
    Replies: 2
    Last Post: 06-16-2014, 07:04 PM
  2. Book Reading app like google playbooks???
    By ketan2604 in forum Applications
    Replies: 6
    Last Post: 06-16-2014, 02:02 AM
  3. The Daily Show takes on Google Glass: 'Do you hear what you're saying?'
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 06-15-2014, 05:10 PM
  4. Google chat
    By cwahsayz in forum Nokia Lumia 1520
    Replies: 2
    Last Post: 06-14-2014, 05:08 AM
  5. Google chat
    By cwahsayz in forum Applications
    Replies: 1
    Last Post: 06-13-2014, 11:31 AM
LINK TO POST COPIED TO CLIPBOARD