1. jefim's Avatar
    I bought my phone (Optimus 7) last autumn when it just came out. And since then one problem have been there all the time - the phone constantly shows the roaming icon on top of its screen (and I am in my native network, it should not be there). The bills are normal (no roaming fees), so its the phone somehow detecting this roaming incorrectly.

    In addition - I tried two nokia phones (3310C, 5800) and an HTC Hero with the same SIM card - they work as expected (no roaming icons there).

    Any thoughts on this?

    PS My network is Elisa in Finland if it helps somehow.
    03-24-2011 01:30 AM
  2. Samsteele's Avatar
    I wouldn't have any Idea, but you should try and ask or look here Home - Microsoft Answers
    04-01-2011 12:17 PM
  3. ak0ska's Avatar
    I have the exam same problem. :) Did you manage to solve it?

    I had a Saunalahti prepaid card before (I switched to subscription because of this phone), but with that, there was no roaming icon.
    07-28-2011 03:07 AM
  4. Winterfang's Avatar
    I don't have this problem, but try to turn roaming off on the options. Then turn your phone off, turn it on and enable roaming again.

    To see what happens.
    07-28-2011 10:17 AM
  5. Aeon2k's Avatar
    I have the roaming icon too on the Optimus 7, but I've also had it on my previous basic phone. I think it's because my provider only rents the gsm/3G system from another provider, so technically I'm roaming in another provider's network.
    07-29-2011 07:43 AM
  6. ak0ska's Avatar
    @Winterfang
    It only allows me to turn off data roaming, which I did and tried what you said, but it's still the same.

    @Aeon2k
    Well that might be, but I had a SIM card from the same carrier (only that it was pre-paid) and there was no roaming icon.

    Maybe I will ask the carrier. :)
    07-29-2011 09:43 AM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD