1. murraye's Avatar
    I forced the Mango update and the process went flawlessly. I like Mango and everything appears to be working fine except for the compass.

    Using any compass program, the needle swings wildly before settling down in a random direction. Initially I thought it was the "Jack of Tools" app that was faulty because it wouldn't calibrate. I reported the fault and they acknowledged that there were problems and advised me of an update which I have subsequently received and installed, but the problem remains. Since then I have tried several compass apps and they all have the same, or similar, problems.

    I have been worrying that the LG firware has not updated. Has anyone else experienced similar problems?
    Last edited by murraye; 10-02-2011 at 07:20 PM.
    10-02-2011 05:24 PM
  2. shirleyboy's Avatar
    I.m on Vodafone uk.Forced the update on 2nd Oct.I had problems with the office editing (it would,t let me) so I had to restore my optimus7 back to previous version.I,m now just waiting for the update notification.
    It is starting to get a little annoying when Microsoft announce "Windows Phone7 Mango is here !" um.err.well it isn,t !
    10-19-2011 01:18 AM
  3. martin_strahilovski's Avatar
    I forced the Mango update and the process went flawlessly. I like Mango and everything appears to be working fine except for the compass.

    Using any compass program, the needle swings wildly before settling down in a random direction. Initially I thought it was the "Jack of Tools" app that was faulty because it wouldn't calibrate. I reported the fault and they acknowledged that there were problems and advised me of an update which I have subsequently received and installed, but the problem remains. Since then I have tried several compass apps and they all have the same, or similar, problems.

    I have been worrying that the LG firware has not updated. Has anyone else experienced similar problems?
    http://cdn.pocketnow.com/html/portal...781//reset.jpg

    You should make Reset on your phone. Backup your data via Zune and make Settings-> About-> "Reset your Phone". If the problem is still present, rollback Mango update and install it again.
    Last edited by martin_strahilovski; 11-20-2011 at 08:15 AM.
    11-20-2011 08:03 AM
  4. TheAndyMac's Avatar
    I am having the same problem. Have you managed to resolve this yet? It has been suggested to send phone back to LG for "repair".
    12-10-2011 09:04 AM
LINK TO POST COPIED TO CLIPBOARD