1. saket87's Avatar
    hi I have a Lumia 1020 and today I got the band but the health app keeps crashing and won't let me setup the band. it prompts about network error when logging in the splash page and keeps doing it and won't let me access the app. somebody please help. thank you
    Sowiarz likes this.
    10-30-2014 08:08 PM
  2. Ken Nye's Avatar
    works great on my 1020, are you on wp8.1?
    maybe uninstall, reboot and reinstall?
    10-30-2014 08:13 PM
  3. saket87's Avatar
    yes, I'm in 8.1. I tried that too, the app tries to connect and gives network error, during either WiFi , lte or both on together. same error always
    10-30-2014 08:17 PM
  4. ygtgngr's Avatar
    See the next comment:
    Last edited by ygtgngr; 10-31-2014 at 09:04 PM.
    10-30-2014 11:00 PM
  5. ygtgngr's Avatar
    Anyone know how to solve this? I can open the app and use it manually but it is giving a network error when I want to login to my Microsoft Account.
    My device:
    L820
    8.1 Update
    Cyan
    10-31-2014 09:03 PM
  6. borisvaskin's Avatar
    Same problem with mine! What and importantly when Microsoft will do something about it? I couldn't find any useful information regarding this problem on the web.
    11-11-2014 12:38 AM
  7. TLD63's Avatar
    I am having the same problem with my iPhone. Keep getting Network error on the iphone cannot connect the band. I had similar issues with the Surface last year. Ended up returning it. Hopefully there is a fix for this.
    12-31-2014 11:59 AM
  8. TLD63's Avatar
    Deleted the app and reinstalled. Working now.
    12-31-2014 12:07 PM
  9. bksalt's Avatar
    Unpair phone and band delete app start all over fresh that is how I fixed mine and be sure to use the right log-in a common mistake
    12-31-2014 06:08 PM
  10. Sowiarz's Avatar
    Network Error. Today I found the solution. I am from Poland and I have the same "loop" error. I have in my microsoft account polish specials signs in my name and surname. I change them to simple sing for example change "ł" into "l". Now application works perfectly.
    01-02-2015 09:29 AM
  11. d0m1's Avatar
    My lumia 1020 with DevPreview broke so I had to setup a Lumia 635 without DevPreview: Got bluetooth connection issues and also network error. Then I've installed DevPreview and everything works perfectly now. No more Bluetooth connection issues and more important no more networ errors. Hope that helps.
    01-03-2015 12:33 PM
  12. KatNovik's Avatar
    Hi.
    I had "Network Error" when my WP app tried to log in. On my both Lumia 630 and 1520. First, I ensured I could log in HealthVault app with my account and could not go to dashboard.microsofthealth.com, I just was redirected to Band's homepage. So something wring was with my account. Steps which helped me:
    1. Connect band to the charger.
    2. Install Microsoft Band Sync app for Windows on your PC.
    3. Log in. Then app asks you to fill a few fields.
    4. Then I could access the dashboard.
    5. WP app started successfully too.

    P.S. Do not forget to ensure your phone uses US location, timezone and language when installing the app and on the first run. Also, your account has to have only Latin symbols.
    Hope this helps.
    02-26-2015 12:17 PM
  13. Nathan Bensler's Avatar
    Thank you thank you thank you. I thought I bought a paperweight. Guys running denim outside the US be careful. Be extra sure all settings are set to US. What I got hung up on was the language setting. I had the US language but I also had Canadian. The US had to be moved up to the top of the list. The phone had to restart but I didn't have to reinstall the app. I don't have the band on me but at least now the app doesn't loop on the network error message. BTW I am running a denim ICON but the app also ran fine right away on my cyan 920 but I don't know what my settings were because I didn't need to fiddle with it.
    04-09-2015 05:11 PM
  14. Samuel Zhou's Avatar
    I couldn't even download the app on my lumia 1020, it just says pending, although sometimes it goes through 42mb and that it, just stuck there. In before anyone say it's the " Download Pending Glitch " , No, I tried downloading other apps and they worked just fine. I tried restarting the phone too, didn't work. FYI, my phone is operating on WP8.1 if that means anything. Plz Help

    -Samuel
    05-28-2016 09:40 PM

Similar Threads

  1. Will the Microsoft Band display unicode characters (Japanese, Chinese, etc.)?
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 11-06-2014, 10:19 AM
  2. does Nokia Lumia 925 upgradeable to wp9 version??
    By Dasaradh Nimmala in forum Nokia Lumia 925
    Replies: 5
    Last Post: 11-01-2014, 09:23 PM
  3. Band & Myfitnesspal syncing
    By Likwidz in forum Ask a Question
    Replies: 2
    Last Post: 10-31-2014, 10:32 AM
  4. Why does my lumia restart by itself after configuring vpn?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-30-2014, 08:06 PM
  5. How to pair the Microsoft Band with the iPhone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-30-2014, 07:42 PM
LINK TO POST COPIED TO CLIPBOARD