1. Yossarian2014's Avatar
    Been using my band for over a week now and a couple of questions I have for those on the forum:

    1. About 2 days ago when I plug the USB cable into my computer (Surface Pro 3), I get a message that the computer does not recognize the device and the Band App shows not connected - how do I make my PC recognize my band (tried a full reset, delete and reinstall the band app with no fix)

    2. How do I make the weather tile recognize my location, I have it synched to an iPhone, have the health app installed and enabled for location services, tried synching the band to the app which did update it but the weather still shows for the city I was in yesterday before I flew across the country?

    3. When I run with the band (GPS on) then sych to the phone app after my run it shows all stats except my route map - tells me to use GPS next time to record a map. I did use GPS on the band and phone - any ideas on how to make my route show on the app?

    3. My band seems to have very good battery life compared to reports, currently been wearing it for two days and when I plug in to charge it still shows 85% down from 90% last night - is this normal with no gps or is my band malfunctioning and likely to run out of juice soon (going to see how long it lasts with no recharge)

    Overall very pleased with it though - despite other reports heart rate seems pretty accurate vs my chest strap, I need to test the GPS accuracy more, I ran a route with Map My Run enabled on my phone and the band GPS and my phone app says I went 4.5 miles, Band says 5 miles so need to test this some more around a track with a known distance.

    Thanks in advance for any replies/comments
    11-19-2014 12:35 PM
  2. DroidUser42's Avatar
    When I run with the band (GPS on) then sych to the phone app after my run it shows all stats except my route map - tells me to use GPS next time to record a map. I did use GPS on the band and phone - any ideas on how to make my route show on the app?
    Did the GPS on the band report getting a lock? When I start a run with the GPS on, it first says it's looking, but allows me to start the run anyway. It then alerts me when it gets a lock. But if your running on a concrete canyon of a city, it might never get a lock.
    11-19-2014 02:05 PM
  3. Yossarian2014's Avatar
    Good point - I know when I turned it on it said it was searching but after a couple of minutes I got tired of hanging around so never checked to see if it 'found' a GPS. Not sure why it would struggle so much though. Will check that out next time.
    11-19-2014 04:02 PM
  4. smatofu's Avatar
    [[1. About 2 days ago when I plug the USB cable into my...]

    Don't know solution, but it's not just your PC, I have the same problem.

    [[2. How do I make the weather tile recognize my location...]]

    I had the same problem. Fix: I had to remove the weather app, sync, add it back, and sync.

    [[GPS accuracy]]
    I tested the Band on routes where I used other GPS watches. The Band is accurate: 7.11 mi vs 7.06 mi on another very good GPS watch.
    11-19-2014 04:20 PM
  5. Dima Habenko's Avatar
    Been using my band for over a week now and a couple of questions I have for those on the forum:

    1. About 2 days ago when I plug the USB cable into my computer (Surface Pro 3), I get a message that the computer does not recognize the device and the Band App shows not connected - how do I make my PC recognize my band (tried a full reset, delete and reinstall the band app with no fix)
    I use Surface pro 3 and connected right away with no problems. Not that you are missing anything, as, at this time, the windows application is only good for syncing band results back to the cloud - there is literally no information displayed like on mobile apps. But I heard that some people had problem connecting to USB3.0 ports, while USB2.o ports or 2.0 adapters worked fine for them. Maybe you should try connecting via adapter on your surface and see if your problem would be solved.
    2. How do I make the weather tile recognize my location, I have it synched to an iPhone, have the health app installed and enabled for location services, tried synching the band to the app which did update it but the weather still shows for the city I was in yesterday before I flew across the country?
    The weather app and stock app are very unreliable at the moment. I would suggest removing them from your band and waiting until MS would post a fix. They seem to sync arbitrarily if at all sometimes and I often have stocks displayed from 2 days ago and weather, not only showing wrong temperature, but often forgetting to advance day and showing my temperature from yesterday.
    3. When I run with the band (GPS on) then sych to the phone app after my run it shows all stats except my route map - tells me to use GPS next time to record a map. I did use GPS on the band and phone - any ideas on how to make my route show on the app?
    You probably never get a lock on the GPS satellites. The very first time you turn on GPS in the new location, it may take awhile to lock on. But MS is caching satellite coordinates, so the subsequent runs would achieve lock anywhere from 5 - 15 seconds and I now never wait for the lock, but simply double click action button to start run immediately. Having said this, I find map results to be poor. First of all, there is no live tracking, which would be very helpful in hiking. Secondly, MS band uses Bing map (of course) on the results page and Bing just does not cut it when you are used to the best (Google). There is no satellite mode, no trails, old, outdated and sometimes simply inaccurate street maps.
    3. My band seems to have very good battery life compared to reports, currently been wearing it for two days and when I plug in to charge it still shows 85% down from 90% last night - is this normal with no gps or is my band malfunctioning and likely to run out of juice soon (going to see how long it lasts with no recharge)
    I also found battery display to be highly inaccurate. I often have band showing half the charge left for long stretches only to show suddenly that I need to recharge it right away. The percentage display in charging is very approximate - it jumps quickly to 80% (which is not true since it can as quickly go down to 30% after only 1 hour) and then is stuck there for hours in charging mode, often failing to indicate that the charge has completed. Only when I disconnect/reconnect it to charge would it show 100%. I am not sure if this is firmware v1.0 (which could be fixed if MS cares at all) or simply battery can not provide exact information back to the band and they have to approximate.
    Overall very pleased with it though - despite other reports heart rate seems pretty accurate vs my chest strap, I need to test the GPS accuracy more, I ran a route with Map My Run enabled on my phone and the band GPS and my phone app says I went 4.5 miles, Band says 5 miles so need to test this some more around a track with a known distance.
    Thanks in advance for any replies/comments
    I found GPS so far to be pretty accurate and reliable. Known marked routes show exact mileage, the repeating exercises never deviate by more then 1-2% over 5+ miles and the lock is very fast, even under trees. Turns are registered well enough (I think it logs every 5 seconds or so, so some very sharp turns may be miscalculated). I did not try it in city dwellings where GPS lock can be very challenging to achieve.
    11-19-2014 05:56 PM
  6. DroidUser42's Avatar
    I also found battery display to be highly inaccurate. I often have band showing half the charge left for long stretches only to show suddenly that I need to recharge it right away. The percentage display in charging is very approximate - it jumps quickly to 80% (which is not true since it can as quickly go down to 30% after only 1 hour) and then is stuck there for hours in charging mode, often failing to indicate that the charge has completed. Only when I disconnect/reconnect it to charge would it show 100%.
    Battery measurement isn't an exact science. I'd try leaving it on charge for as long as it takes to get to 100% on it's own and see if that doesn't resolve the rest of the problems.
    11-19-2014 10:45 PM

Similar Threads

  1. I think I'm fully accustomed to the Band
    By JPDVM2014 in forum Microsoft Band & Band 2
    Replies: 13
    Last Post: 11-20-2014, 11:13 AM
  2. Replies: 1
    Last Post: 11-20-2014, 08:44 AM
  3. Why isn't the Lumia 1020 camera living up to the hype?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-19-2014, 01:35 PM
  4. Why is my speaker and earpiece not working on my Nokia Lumia 928 ?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-19-2014, 11:22 AM
LINK TO POST COPIED TO CLIPBOARD