1. VRocker88's Avatar
    So I've had my Microsoft Band for a month now and i'm really happy with it. Unfortunately lately it's been playing up...

    For the last few days, i'll be wearing it when all of a sudden it will start vibrating every few seconds. Looking at it I see tat it gets stuck in a reboot loop. It looks like it is crashing 5-6 seconds after starting up then the watchdog timer is causing it to hard reset which is causing an endless loop of start -> crash -> reboot -> crash. The only way to stop it is to very quickly execute a proper shutdown, which takes a bit of doing as sometimes it crashes when saying goodbye... causing another reboot.

    Another issues I've noticed (which is related to the above issue) is that the graphics get majorly corrupted. The icons flicker or simply don't exist, labels get renamed (such as heart rate showing as DeviceNameDeviceNameDeviceName) and characters don't display properly when receiving notifications.
    When this issue happens it's usually an indication that it's going to crash, and also happens in those 5-6 seconds before crashing when it's rebooted (have you ever tried to execute a blind shutdown where you have 2 blank buttons and nothing else? Not fun)

    I have noticed that turning off Bluetooth and not using GPS helps to stop it crashing as often. It's gone into reboot loops twice today and i'm currently sat with Bluetooth off. Sometimes I can't turn it back on for hours without it looping so i'm assuming this has helped anyway.
    Edit: Shortly after posting this it crashed again >< so not Bluetooth or GPS related. Going to try disabling heart rate next!

    I'm guessing my band is broken and needs servicing, so I'll be contacting support later on today. I was wondering if anyone else had had similar issues though?
    Such a shame that it's playing up after only one month. I'm hoping that I just got one from a bad batch because this is a really nice device.
    Last edited by VRocker88; 04-15-2015 at 08:13 AM. Reason: Crashed again :(
    04-15-2015 07:24 AM
  2. rmerriwether's Avatar
    Only had mine for a few days, only issue I've have is the phone notification not displaying the names of contacts I have saved in my phone.
    04-15-2015 10:28 AM
  3. Stiv X's Avatar
    That is a big issue. My wife's step counter stopped working. She called support where they had her try reboots. After those didn't work, they said she can exchange at MS store or send it in for exchange. I drove 2 hrs to the nearest store and exchanged it with no problems. While I waited, I played extensively with the Surface 3 on display. I went ahead and per-ordered the S3 later that night.
    rmerriwether likes this.
    04-15-2015 12:35 PM
  4. Philip Clemow's Avatar
    I have this exact problem with reboot loops. Only today since the update.

    its driving me mad.

    Keep us informed with support ... not sure what im going to do about it as i bought my band on ebay. Will support help me?
    04-15-2015 05:20 PM
  5. gadgetrants's Avatar
    I drove 2 hrs to the nearest store and exchanged it with no problems. While I waited, I played extensively with the Surface 3 on display. I went ahead and per-ordered the S3 later that night.
    So what you're suggesting is: Microsoft deliberately bricked some of our Bands to trick us into coming to the store, seeing a more expensive toy, and buying it! Classic bait and switch!!!

    -Matt
    Stiv X likes this.
    04-15-2015 06:35 PM
  6. Stiv X's Avatar
    Lol. If so they timed out brilliantly. I bought my wife the band in Nov 2014 for Christmas. So, if that was by design I bow to the Microsoft overlords
    gadgetrants likes this.
    04-15-2015 10:21 PM
  7. VRocker88's Avatar
    So an update on this (a bit late but i've been busy)

    I contacted Microsoft support and they were really helpful. Gave them an explanation of what happened as well as a video and they agreed it was faulty. They arranged the shipping and collected it the following day. 2 weeks later a brand new one dropped on my doorstep.

    They had no problems with it being a US one, although i think that's why it took 2 weeks as my replacement states 'US Hardware' on the box so they sent it from the states.
    I've had the replacement band since Friday and so far it's working well but time will tell if i get this problem again...
    05-07-2015 08:11 AM

Similar Threads

  1. Why does my Lumia 520 lags with the Windows 10 update?
    By Arvind Mehra in forum Windows 10 Mobile Insider Preview
    Replies: 8
    Last Post: 06-14-2015, 12:54 AM
  2. Band Screen Protector in UK
    By slysy in forum Microsoft Band & Band 2
    Replies: 7
    Last Post: 04-17-2015, 11:20 AM
  3. Sensible to use band as normal smart watch (non-fitness)?
    By wps81 in forum Microsoft Band & Band 2
    Replies: 18
    Last Post: 04-16-2015, 05:54 PM
  4. Here are our impressions of the BLU Win HD with Dual SIM LTE
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-15-2015, 07:11 AM
  5. The ultimate guide to Microsoft Band
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-15-2015, 05:42 AM
LINK TO POST COPIED TO CLIPBOARD