Galaxy Note 10 Deal: BOGO at Verizon!
06-01-2016 06:27 AM
49 12
tools
  1. metsfan421's Avatar
    So, I just upgraded from the 1520 and purchased the Lumia 950XL. Got home and updated all the apps on the phone. Turns out Microsoft Health app running on the 950XL will not recognize and properly pair with the Microsoft Band 2. Called Microsoft support and they said it is not yet compatible with the Lumia 950XL and they are working on fixing the issue. Anyone else have this problem as well?
    11-27-2015 09:13 PM
  2. david90531's Avatar
    What? No, I got both my Lumia 950XL and the band 2 yesterday and opened them pretty much at the same time and paired easily and working well ever since. Health app, all the band related stuff works. That sounds like either faulty device or something's wrong with the firmware?
    11-27-2015 11:01 PM
  3. Likwidz's Avatar
    Had my Band 2 before getting my 950XL, took a few try's to get it to see the Band when setting BT connection, but once it did haven't had any problems
    david90531 likes this.
    11-27-2015 11:03 PM
  4. PhilWitt's Avatar
    I can not get my band 2 to sync with my 950 XL either. I've tried multiple times but nothing seems to work. I've paired it back up to my Nexus 6 (which works every time) just to get the band off the 'getting things ready' screen. But I'd like to get my notifications working again as I'm not going to be using my nexus as my daily driver anymore.
    11-28-2015 01:54 AM
  5. metsfan421's Avatar
    I've gotten it to pair with Bluetooth, but the Microsoft Health app allows you to select the name of the Band and choose to pair, but then the Health app never gets off the Pair your band screen. It fails with a message that says "Unable to Pair" An error occurred while attempting to pair your selected device. I've tried every which way and can never get past that screen in the Microsoft Health app. As far as being paired to your phone with Bluetooth, yes that works, but the Microsoft Health App will not work, at least for me. And when I called into Microsoft support the tech stated they knew about the issue, and were working on it, but said it could take a week or a month to get a fix out to users, and even told me to go back to using my 1520 until the fix is out.
    hguerra likes this.
    11-28-2015 09:32 AM
  6. jjmorgan64's Avatar
    My band 2 and Xl paired no issues and are working perfectly, absolutely no issues at all
    11-28-2015 09:34 AM
  7. metsfan421's Avatar
    Ok, after posting my last post I tried it again. I went in to my Bluetooth settings and realized that the band was still paired in my phone even though it wasn't in the app. I then deleted it from the phones Bluetooth pairing under settings, and then went back into the Health app. This time each prompt that It gave when you get to pairing the device through the health app I made sure I hit the Pair now on the phone and the band at the same time, and it worked. I swear I tried everything but this yesterday. Hope this helps, glad it's working now.
    Likwidz and Mark Baker3 like this.
    11-28-2015 09:39 AM
  8. Rezzee's Avatar
    I'm running into the same issue. Hell of it is, I had it all working last night with no problems until I had to hard reset my phone to get the Lumia Offers app to work.

    Here is my sequence of events:

    wp_ss_20151128_0004.jpg
    I go through the steps, everything works fine. The phone sees the Band, the Band sees the phone. I grant it permission to show notifications, etc etc.

    wp_ss_20151128_0003.jpg
    The phone proceeds to the final "Getting Things Ready..." step, this message is displayed on the Band and the App.

    wp_ss_20151128_0002-1.jpg
    Then, even though the pairing process is completed and the phone is connected to the Band (I confirmed in Bluetooth settings), I get this error message. Every time.

    Things I've tried to resolve this:

    • Reset the Microsoft Band 2
    • Uninstall Microsoft Health
    • Remove Microsoft Band 2 from the known devices in Bluetooth menu
    • Check for updates on the Microsoft Health app
    • Performed another hard reset on the phone. No luck.


    I'm truly at a loss for words since I had this up and running fine before I had to do a hard reset this morning. Any additional suggestions would be wonderful, I feel like I'm losing my mind.
    Last edited by Rezzee; 11-28-2015 at 01:43 PM.
    PhilWitt likes this.
    11-28-2015 12:54 PM
  9. PhilWitt's Avatar
    Rezzee, this is exactly what is happening to me.
    I was about to post the same screen shots. I've tried all your steps and also no success. Hopefully someone will have some other ideas or a solution.
    11-28-2015 01:53 PM
  10. Rezzee's Avatar
    Rezzee, this is exactly what is happening to me.
    I was about to post the same screen shots. I've tried all your steps and also no success. Hopefully someone will have some other ideas or a solution.
    I fixed it! I did some digging and found a "hard reset" for the Band 2. Make sure you are ready to start fresh again (remove the Band from Bluetooth, close the Health app, etc), and make sure your Band is on the language select screen.

    Press and hold the power & action buttons for roughly 5 seconds. The Band will vibrate and flash a red screen before rebooting. Be sure to have a charger handy, it will require you charge to a certain % before it goes back to language selection.

    Start the process over again. It should go through this time.
    11B1P likes this.
    11-28-2015 02:33 PM
  11. PhilWitt's Avatar
    Still not getting it. This is the acrren shot of the phone "oops" and my band says "Getting things ready..."
    wp_ss_20151128_0002.jpg
    MrMax99 and Rezzee like this.
    11-28-2015 07:48 PM
  12. MrMax99's Avatar
    I have the same exact problem as you PhilWitt. I tried hard resetting the watch a few times. It still connects to my old android phone fine. Microsoft support also told me that it was a known bug in the Microsoft Health app that Microsoft is working on, but I couldn't get a firm ETA for when it would be fixed. I hope it is fixed soon.
    11-29-2015 02:33 AM
  13. metsfan421's Avatar
    Look at my last post before this one, I was having the same issues as you guys with it giving an error every time when pairing, but I finally got it to work. Here are the steps I did, remove from Bluetooth settings as a paired device, remove from health app. Once this is done hard reset the band with the action and power buttons for 10 seconds till you see flashing red screen. Go through prompts on band till you get to pair now option, but wait don't hit it yet, open health app on phone and add a band. When you see the name of the band come up literally select it on phone AND hit pair now on the band at the same time. Sounds crazy but this is what worked for me.
    11-29-2015 11:39 AM
  14. PhilWitt's Avatar
    Thanks metsfan421 for the comment but unfortunately it looks like there are two different problems that most people are experiencing. The one you had was a pairing issue "band error" that can eventually be resolved with some persistence. Then you have the getting things ready... error 'oops' that I've yet see anyone solve or get past so far.
    I don't know anything about anything but my gut is telling me this is either a 'cloud' setting that we've stumbled into or an actual Windows 10 mobile MS Health App bug/issue that we can't get past.
    I'm resigned to just waiting for someone to fix it or come up with a new set of things to try. I spent a few hours trying different combinations with the PC sync app, my android app and my windows mobile app to no avail.
    11-29-2015 04:11 PM
  15. Jon_Rubinstein's Avatar
    Hey. My Pre 3 still works great
    Last edited by Jon_Rubinstein; 12-08-2015 at 10:24 PM.
    11-30-2015 03:03 PM
  16. anon(8555314)'s Avatar
    It works for me on my 950XL.
    11-30-2015 04:03 PM
  17. SeeVuPlay's Avatar
    I have the 950xl. And it works with band 2.
    11-30-2015 06:20 PM
  18. PhilWitt's Avatar
    I have the same exact problem as you PhilWitt. I tried hard resetting the watch a few times. It still connects to my old android phone fine. Microsoft support also told me that it was a known bug in the Microsoft Health app that Microsoft is working on, but I couldn't get a firm ETA for when it would be fixed. I hope it is fixed soon.
    Here are the steps I followed to get mine to finally work:

    Just got it to work.
    In my situation where I could always pair my Band 2 to my Nexus 6 without fail I followed these steps to get my Band 2 to finally work with my Lumia 950XL.
    1) Start Add Band process on my Nexus 6. On my Band 2 I selected Windows Phone instead of Android (Not sure this is needed but it seemed logical to me).
    2) Finish successfully adding the Band to my Nexus 6 and turned off Bluetooth on my Nexus 6.
    3) On my Lumia 950XL I uninstalled and reinstalled MS Health App and I had the My Microsoft Band option but when hitting it you can't actually see the Band 2 information.
    4) On my Band 2 I went to settings and Bluetooth and turned it off, turned it to 'pairing' and it asks if I'm pairing to iPhone and I said no. Waited for pair between 950XL and Band 2. After successful pairing I went into MS Health App and I am able to use everything just like on my Android but now with the added ability to use Cortana.
    I'm thrilled, and hope this works/helps for anyone else in the same situation.
    -Phil
    11-30-2015 07:58 PM
  19. Rezzee's Avatar
    Here are the steps I followed to get mine to finally work:

    Just got it to work.
    In my situation where I could always pair my Band 2 to my Nexus 6 without fail I followed these steps to get my Band 2 to finally work with my Lumia 950XL.
    1) Start Add Band process on my Nexus 6. On my Band 2 I selected Windows Phone instead of Android (Not sure this is needed but it seemed logical to me).
    2) Finish successfully adding the Band to my Nexus 6 and turned off Bluetooth on my Nexus 6.
    3) On my Lumia 950XL I uninstalled and reinstalled MS Health App and I had the My Microsoft Band option but when hitting it you can't actually see the Band 2 information.
    4) On my Band 2 I went to settings and Bluetooth and turned it off, turned it to 'pairing' and it asks if I'm pairing to iPhone and I said no. Waited for pair between 950XL and Band 2. After successful pairing I went into MS Health App and I am able to use everything just like on my Android but now with the added ability to use Cortana.
    I'm thrilled, and hope this works/helps for anyone else in the same situation.
    -Phil
    Good to see you got it resolved, despite the frustration. Thanks for posting your fix!
    12-02-2015 11:05 PM
  20. MrMax99's Avatar
    Great idea PhilWitt, thanks for the suggestion!

    I got my Lumia 950 XL paired to my Band 2 now following your steps, but it seems like there's some issue with sending information from my band to my phone. For example, I can't reply to texts with the keyboard and I can't ask Cortana anything, it just stays on "connecting" or asks me to make sure i'm close enough for bluetooth and my phone is on. I can now get email, text, call notifications and calendar info and it seems things like step count transfer correctly to my phone (hopefully it still automatically periodically syncs).

    Anyone have any idea what trick might get my cortana and text replying working?

    ---EDIT---

    I rebooted my watch and phone a couple times and turned on and off bluetooth on both a couple times and eventually one of the times everything got fixed. I can now use cortana and the keyboard!
    Last edited by MrMax99; 12-04-2015 at 02:57 AM. Reason: figured out a solution to my problem
    zei20t and willy_013 like this.
    12-04-2015 02:30 AM
  21. willy_013's Avatar
    Same issue, Band 2 was working good with Lumia 950 XL and after a Phone reset I started to get errors sync messages on the app, after several attempts the band just freeze in black screen, the only way to wake it up Is connect it to the cable charger and then shows on the screen "Welcome Back, Battery ran out, please set date and time" The time that is on the Band is the last time that synced with the cellphone. (Battery at 92%)
    Turning of Bluetooth stopped the "freeze issue" but now is only a watch :(.
    Tried PhilWitt suggestion and results are the same. Thanks.
    Hope we get a fix soon.

    ---EDIT---
    Freeze black screen still persist - Now is impossible to use the Band. Contacted Microsoft support and he said that Microsoft engineers are working hard to fix the issue with Lumia 950 XL compatibility.
    Last edited by willy_013; 12-04-2015 at 06:20 PM. Reason: Updates on my issue
    12-04-2015 02:11 PM
  22. lovesurface's Avatar
    I consider myself a fanboy... but it is hard to forgive them not to fix this BEFORE the release date... band 2 is silent from monday, the day I got my 950XL. I realized it after a couple of days... no notification and so on... then i said WTF? i will try everything you wrote here... i do love my band and do really love 950xl. but i am missing my previous config 1520+band 1!
    12-05-2015 01:30 PM
  23. 11B1P's Avatar
    Check your Health app for an update. The update fixed an issue for some of us on the Band 1 and may help your issues too.
    12-05-2015 01:49 PM
  24. cnashx's Avatar
    So I didn't read ALL the comments. But I had this issue as well initially... Restarted my phone and it went through smooth as butter. Everything works now. :)
    12-08-2015 07:19 AM
  25. Devan Hammack's Avatar
    Mine works fine :)
    12-08-2015 07:20 PM
49 12

Similar Threads

  1. Win 10 mobile on 950xl live tiles not working as in 8.1
    By brettpfleiger in forum Ask a Question
    Replies: 1
    Last Post: 12-20-2015, 01:16 PM
  2. Updating win 10 lumia insider to official win 10 lumia update
    By khalil_sial in forum Windows 10 Mobile Insider Preview
    Replies: 1
    Last Post: 11-27-2015, 10:55 PM
  3. Replies: 4
    Last Post: 11-27-2015, 10:25 PM
  4. Where to download HD wallpapers for the 950XL?
    By david90531 in forum Microsoft Lumia 950 XL
    Replies: 0
    Last Post: 11-27-2015, 08:58 PM
  5. Why won't my Lumia email app connect to an exchange account?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 11-27-2015, 08:29 PM
LINK TO POST COPIED TO CLIPBOARD