1. glbsolutions's Avatar
    I have tried it with stock music player, Google Play Music, Groove Music and it just won't connect. All other notifications are working well. Am I missing something?
    12-21-2015 03:35 PM
  2. Josh Harman's Avatar
    I don't know if this is applicable to your situation, but I've noticed that if you're playing the music through Bluetooth headphones or radio you must connect to your Band before connecting to whatever device your playing through. Otherwise it never connects.
    driedl likes this.
    12-21-2015 03:57 PM
  3. glbsolutions's Avatar
    No other bluetooth items connected, it's strange
    12-22-2015 04:14 PM
  4. devbent's Avatar
    I have tried it with stock music player, Google Play Music, Groove Music and it just won't connect. All other notifications are working well. Am I missing something?
    Hi glbsolutions,

    What model of phone are you using, and what version of Android is it running? I'll see if I can help you out.
    12-22-2015 04:18 PM
  5. glbsolutions's Avatar
    It's an Allview P8 Energy (not popular I know) running stock Android 5.1. MS Health is upto date, when I double click the button on the band it says connecting but then just reverts back to previous screen. It is connected find via bluetooth as all alerts come through correctly.
    12-22-2015 06:16 PM
  6. devbent's Avatar
    Unfortunately I cannot find any information on that particular phone, but thankfully phone specific problems on Android 5.x and 6.0 are rare (I haven't seen any phone model specific problems since 4.3!)

    We are working on a fix for a handful of Android Bluetooth issues where we will be more resilient to errors. Until then here are some suggestions, if these don't work reply and let me know and I can escalate the complexity of the steps. :)

    • Reboot the phone
    • Uninstall and reinstall the health app
    • If you are paired to any wireless speakers in your house, remove the pairing on the phone, some speakers keep their connection open all the time.
    • If you have another phone available, try setting yourself up on that phone and seeing if music controls work


    If none of those work, let me know.
    12-22-2015 10:37 PM
  7. luke31's Avatar
    Mine were working fine until I got the Android 6.0 Marshmallow upgrade on my Moto X 2014. Now, the Band connects for one second to my music, then switches over indefinitely to "connecting." I've tried all the steps and nothing works.

    Posted via the Windows Central App for Android
    12-29-2015 09:32 AM

Similar Threads

  1. Slow WIFI on 950XL
    By Tomika1234 in forum Microsoft Lumia 950 XL
    Replies: 40
    Last Post: 12-21-2016, 04:24 PM
  2. I Can't Deal With The 950XL Anymore...
    By Witness in forum Microsoft Lumia 950 XL
    Replies: 53
    Last Post: 12-28-2015, 07:39 PM
  3. Home button won't power on / off or sleep / wake
    By Alex Szabo1 in forum BLU Win HD
    Replies: 1
    Last Post: 12-28-2015, 06:29 AM
  4. Unlocking the password entry?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 12-21-2015, 03:50 PM
  5. What is the code to unlock Nokia Lumia 435? It uses O2 Network
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-21-2015, 01:42 PM
LINK TO POST COPIED TO CLIPBOARD