1. SolidHollow's Avatar
    I cant get anything faster than a E connection on my Nokia Lumia 530. I am getting AT&T service through Straight Talk. I contacted Straight Talk customer service and the service rep. said I could not correctly set up the APN for 3G on their system with my device. He said I can set up my SIM on another device and switch it back. I have never heard of "setting up a SIM on another device". Is this even possible? It sounds like bull to me. Can anyone help me troubleshoot this issue? I have the "Highest connection speed" set to 3G but I am still stuck with an E. Any idea how to remedy this?
    03-23-2015 03:57 PM
  2. xandros9's Avatar
    I'm sure thats not bull, but back up a bit. Is this a T-Mobile 530?
    If so, it may not have the hardware bands for 3G on AT&T's network.
    03-23-2015 04:24 PM
  3. SolidHollow's Avatar
    Thanks for the reply. It is a dual SIM factory unlocked Lumia 530.
    03-23-2015 05:12 PM
  4. pankaj981's Avatar
    As far as I know, only one of the SIM slots on a dual SIM supports HSPA speeds. Check the SIM slot and try with the one that supports it
    SolidHollow and xandros9 like this.
    03-23-2015 05:23 PM
  5. SolidHollow's Avatar
    Give me a moment and I will give it a try. I will report back with the results in a few minutes.
    03-23-2015 05:25 PM
  6. SolidHollow's Avatar
    No luck. Still getting the E only.
    03-23-2015 05:31 PM
  7. pankaj981's Avatar
    Hmm can you try using this link?

    How To Update Data Settings: StraightTalk Wireless


    Also there is thread about this discussion, see if it helps

    http://forums.windowscentral.com/nok...gs-change.html
    Laura Knotek and SolidHollow like this.
    03-23-2015 06:11 PM
  8. SolidHollow's Avatar
    I have tried the first link and I do have the updated APN settings already. I read through some of the suggestions on the 2nd link and tried them and I am still only getting an E connection.
    03-23-2015 09:19 PM
  9. SolidHollow's Avatar
    Is there a way to access the "field test app" on the Lumia 530? I was reading on the Lumia 1020 forum and someone was able to solve this same issue by getting in the field test app and changing some settings.
    03-24-2015 08:44 AM
  10. AntiAB's Avatar
    Hi to access field test in Windows Phone just dial ##3282#
    SolidHollow likes this.
    03-24-2015 08:51 AM
  11. SolidHollow's Avatar
    It doesn't work on my phone. It only shows USSD and my phone number. I have read that some carriers don't allow it. I've seen work arounds with developer software, but I don't really know how to use any of that. I am hoping someone might be able to walk me through an alternate method.
    03-24-2015 09:12 AM
  12. AntiAB's Avatar
    At&t service doesn't block this so it must be Straight Talk. To save yourself the trouble your better off buying a ATT device. L520 or L635 both are cheaper and better in my opinion. L635 even grabs LTE
    SolidHollow likes this.
    03-24-2015 11:04 AM
  13. SolidHollow's Avatar
    Thanks but I have already tried 3 phones through T-mobile and finally this one through straight talk in the last 2 weeks. I think I am going to try to make this one work before I do anymore returns. Apparently there is a way to do it, but the directions aren't very clear on the forums I am searching. I would share a link to inquire about the method further but I haven't posted enough to share links yet.
    03-24-2015 11:19 AM
  14. SolidHollow's Avatar
    Alright, I have found 2 different fixes that I am looking into. Since I am new to Windows Phones I could really use some input on these.

    I tried downloading Native Toast Launcher and opening field test with a Code I found on a tutorial but apparently this doesn't work anymore on version 8.1. If anyone knows otherwise I would appreciate any info.

    Also, I am reading that flashing the firmware with Vietnam's BLACK firmware brings back the field test. (That is if it is not blocked by my carrier) Can anyone confirm this? Is there any risk involved with messing with the firmware?
    03-24-2015 03:40 PM
  15. Mahmoud Hussein's Avatar
    I cant get anything faster than a E connection on my Nokia Lumia 530. I am getting AT&T service through Straight Talk. I contacted Straight Talk customer service and the service rep. said I could not correctly set up the APN for 3G on their system with my device. He said I can set up my SIM on another device and switch it back. I have never heard of "setting up a SIM on another device". Is this even possible? It sounds like bull to me. Can anyone help me troubleshoot this issue? I have the "Highest connection speed" set to 3G but I am still stuck with an E. Any idea how to remedy this?
    Did this happen after upgrading to Denim? This happened to me after updating my 925 to DENIM.
    SolidHollow likes this.
    03-24-2015 03:46 PM
  16. SolidHollow's Avatar
    Nah. I haven't done any upgrades yet. I am not sure what firmware comes stock with the phone. I clicked on "about" in settings to check, but all I see is numbers listed under firmware. I don't see DENIM.
    03-24-2015 04:05 PM
  17. Josip Zeljko's Avatar
    Did you allow 3G in SIM settings. Maybe it's set to 2G only
    SolidHollow likes this.
    03-24-2015 04:15 PM
  18. SolidHollow's Avatar
    Yeah It's set to 3G but my network selection only picks up 2G networks. Before I put the SIM in it detected AT&T 4g. so It is definitely an issue with the phone/SIM. The Straight Talk rep. said I could set up the SIM in another phone for 3G but I have never heard of anything like that and internet searches have yielded nothing of the sort.
    03-24-2015 05:11 PM

Similar Threads

  1. Replies: 4
    Last Post: 06-03-2015, 12:51 AM
  2. Replies: 6
    Last Post: 04-09-2015, 12:59 PM
  3. Can I download files that are larger than 5 GB (Windows 8.1 tablet)?
    By Night Dx in forum General Desktop, Laptop & Tablet Discussion
    Replies: 2
    Last Post: 03-24-2015, 12:01 AM
  4. My data connection speed is dimmed and can't switch from 2G to 3G, why?
    By Windows Central Question in forum Nokia Lumia 925
    Replies: 1
    Last Post: 03-23-2015, 03:30 PM
LINK TO POST COPIED TO CLIPBOARD