1. varunmechie-me's Avatar
    Default video app loads for hours but doesn't play video. How do I solve dis problem??
    05-20-2015 04:07 AM
  2. charlatan1978's Avatar
    Are you on WP8.1?
    What file format is the video? (avi, mkv, mp4, etc)
    varunmechie-me likes this.
    05-20-2015 04:15 AM
  3. varunmechie-me's Avatar
    L640 xl comes with win 8.1 out of box. Its mp4
    05-20-2015 05:47 AM
  4. charlatan1978's Avatar
    I asked about WP8.1 just in case it had been updated to the W10 tech preview, as I know I have had issues playing videos on that.
    Is the mp4 something you have downloaded onto the phone or have you copied it manually (from your pc) on to the phone?
    varunmechie-me likes this.
    05-20-2015 05:56 AM
  5. realwarder's Avatar
    Try VLC app too.
    varunmechie-me likes this.
    05-20-2015 06:25 AM
  6. varunmechie-me's Avatar
    I hvnt updated to win 10 technical preview. My phone doesn't play any video irrespective of the source. It just loads for hours.
    05-20-2015 10:04 PM
  7. Gaurav Chaudhary002's Avatar
    soft resetting the phone (pressing the power and volume down button simultaneously) solved the problem for me
    05-20-2015 11:21 PM

Similar Threads

  1. Back to Windows, what device to buy...?
    By NafcMontana in forum Ask a Question
    Replies: 5
    Last Post: 05-26-2015, 05:37 PM
  2. Win 10 10122 Trying to install 3d Builder
    By BryceMD in forum Windows 10 Insider Preview
    Replies: 5
    Last Post: 05-22-2015, 08:08 PM
  3. How to resize tiles ...Build 10122
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 05-20-2015, 08:46 PM
  4. Can't connect to Wifi (HELP)
    By epiczacktime in forum Ask a Question
    Replies: 2
    Last Post: 05-20-2015, 04:41 PM
  5. Not connecting to wifi! HELP
    By epiczacktime in forum Ask a Question
    Replies: 1
    Last Post: 05-20-2015, 03:34 PM
LINK TO POST COPIED TO CLIPBOARD