1. Nandakumar Kesavan's Avatar
    Hi,

    Anyone with Lumia 640XL Dual SIM upgraded to the latest insider build??? 10568.11, if yes, could you please share your thoughts?

    1. Phone call Quality
    2. Message
    3. WhatsApp
    4. Outlook and GMail (Mail App)
    5. Battery

    please please please, the current build is so tempting....

    Regards,
    Nandakumar
    Daniel Gilbert M likes this.
    11-19-2015 07:34 AM
  2. kristalsoldier's Avatar
    I updated my 640XL today to 568.11...

    In reply to your questions:

    1. Call quality - I can't see any difference. It is as good as it was. which means it is good at least to me

    2. Messaging seems to work just fine, but one thing I noticed that now the messaging for both SIMs seems to be combined in a single Messaging App. Earlier I had a Messaging app for SIM1 AND for SIM 2. Now I only seem to have one. This is a bit worrisome for me. I will be looking into this a bit more.

    3. Whatsapp is working just fine.

    4. |I don't use Gmail so can't speak about it. But otherwise the Mail app is working fine. I have two Outlook accounts - both seem to work just fine. I am not into linking accounts so I have not looked into that though I believe this feature has been withdrawn recently because of some crashes.

    5. Have not tested the battery yet. I had drained the battery while updating the OS and resetting and updating a heap load of apps. Charging up now and will test through the night.

    One extra point - apps like Network, Motion Data etc are showing an error when updating from the Store. But I think these will be fixed in the next update.

    All in all the 640XL - since the last two updates including the recent one - looks and feels like a brand new phone and it works very well.
    11-19-2015 07:52 AM
  3. Nandakumar Kesavan's Avatar
    Oh Boy Oh Boy, thank you so much @kristalsoldier.

    Any issues with WiFi (any drops)?
    Any Issues with 3G/4G?

    Moved from L1320 to L640XL DS two weeks ago and haven't tried WM10 on these yet.
    11-19-2015 08:25 AM
  4. kristalsoldier's Avatar
    Well, my 640XL does not have 4G only 3G but no dropping of calls or anything like that. No problems with WIF either!!! In my opinion, moving from 8.1 to this latest build via the previous one seems to have made my device like a brand new one. The only problem now is should I really spend the money and buy the 950XL when it is released!!!!! One thing: The previous build onwards, the 640XL does not feel like a 1GB phone!!!!!

    I have yet to update my 1520, which I will later in the evening!
    11-19-2015 08:41 AM
  5. Nandakumar Kesavan's Avatar
    One thing: The previous build onwards, the 640XL does not feel like a 1GB phone!!!!!
    @kristalsoldier - should i take this positive or negative? can you elaborate on your statement? i'm kind of freaking out now on what to make of your statement
    11-19-2015 09:41 AM
  6. kristalsoldier's Avatar
    @kristalsoldier - should i take this positive or negative? can you elaborate on your statement? i'm kind of freaking out now on what to make of your statement
    LOL!!! Sorry!!! It is a very positive statement!!!! It feels fast and smooth as if it is a device that is running more than 1GB. Its amazing actually how light and smooth the OS feels on the 640XL!!!!

    Edit: And in that sense this is a problem because I will have a tough time to justify to myself buying the 950XL!!!!! But I will probably get it anyways - or maybe not...or maybe...or maybe not...you see the problem!!! :)
    11-19-2015 09:49 AM
  7. N0ki4N's Avatar
    One thing: The previous build onwards, the 640XL does not feel like a 1GB phone!!!!!
    As in it runs faster or runs slower like a 512mb ram phone?
    11-19-2015 09:50 AM
  8. N0ki4N's Avatar
    Whoops didn't see that comment. Thanks 😊
    11-19-2015 09:51 AM
  9. Nandakumar Kesavan's Avatar
    LOL!!! Sorry!!! It is a very positive statement!!!! It feels fast and smooth as if it is a device that is running more than 1GB. Its amazing actually how light and smooth the OS feels on the 640XL!!!!

    Edit: And in that sense this is a problem because I will have a tough time to justify to myself buying the 950XL!!!!! But I will probably get it anyways - or maybe not...or maybe...or maybe not...you see the problem!!! :)
    @kristalsoldier
    i see your problem and now you got me into it too... 640XL is like a intermediate phone i want to have till the 950XL was released but now, you messed up my mind

    Thank you for the inputs, i'm downloading the build now....
    kristalsoldier likes this.
    11-19-2015 11:46 AM
  10. kristalsoldier's Avatar
    @kristalsoldier
    i see your problem and now you got me into it too... 640XL is like a intermediate phone i want to have till the 950XL was released but now, you messed up my mind

    Thank you for the inputs, i'm downloading the build now....
    Please do share, if you can, your thoughts after you download and use it. There is so little cvomments about the 640 XL that it would be nice to hear about the experiences of another 640XL user.

    Cheers!
    11-19-2015 08:59 PM
  11. Nandakumar Kesavan's Avatar
    @kristalsoldier

    One Word Buddy.... It's awesome......

    Warning: this is going to be a lengthy post

    This is what happened. Signed into Windows Insider, selected Fast Ring. Mobile restarted.... post reboot, with in few mins i had a notification stating that updates are available. didn't start the installation as i didnt charge my mobile was 2 days and the battery was 38%. so plugged it in the charger and clicked download... around at 1:10 am, the battery was 78% and download was completed long back (40 mbps connection). un-hocked from charger. click install.. Installation started at 1:15, first screen freaked me out.... in the middle of the screen i saw a small blue rectangle and below that a red rectangle (could be red on top and blue on bottom, size 3mm in width and 6mm in height) and after some space there was question mark.

    Man that freaked me out...

    in few seconds it moved to the spinning wheel with 3% done after that 30 mins no movement, after that it started moving swiftly to somewhere around 80% and then it took it own sweet time... by 2:15 am, the whole thing got completed and migration started, Darn, that too alot of time, waited for 1 hour for the whole Darn thing to complete.... 3:30 am, all done....

    swiped from home screen to check app installation, they was a bunch of 45 apps with pending status, clicked back arrow, saw the "Loading...." message on home screen with black screen, i was like 'what....', was thinking i should stay awake and revert back to wp8.1 but decided to leave it that way and went to sleep. last time when i installed insider preview in my L1320, the loading message in home screen was so consistent i got frustrated in 1 hour and reverted back.

    Morning at 9 am, woke up, checked my mobile, it said there is an update available, checked the details, it said some configuration update, click install, came to gears again and in 30 mins, it went to migration step and it took a while. post that again the bunch of 45 apps downloaded (dont know why the heck that happened)

    post all installation, i shutdown my mobile, kept it aside for 5 mins and fired it up. Voila... the main screen with lock appeared... swipe up and WOW, transparent PIN, nice.... (early morning i didn't notice the transparent pin screen, was still sleepy)

    now went on to check the other things, clicked store, it popped up right away and was fast to respond, the new store looks very good, now came the difficult part, going to close the store and go back to home screen, was praying that the Loading message shouldn't appear, to my surprise the home screen appeared in a snap as soon as the store closed. opened the contacts and everything was there and looked different (in a good way). wen to settings to change my background picture and other things. hit the windows button, again the home screen just popped up. impressed, checked for message icon in home screen (remembered you saying that there is only one message instead of two) , i still had two, one for SIM 1 and one for SIM 2, the same with Call. clicked the call icon and the new UI was awesome.... Dialer is soo good...

    Opened messages but i didn't see my messages restored properly, all messages after Oct 27 to till date was missing... i'm fine with that, i was lazy to delete them so this helped me in cleaning up few messages.

    Mail, opened, configured 1 outlook, 1 AOL and 3 Gmail. nice.... all synced fine. tap the hamburger menu, saw all my five accounts there, click and navigated to the designated mailbox to check that mail. awesome....

    Photos : Love it, new UI is so so so good....

    Camera : Lumia Camera is missing

    HERE App Suite : all were in wp8.1m, works fine in WM10, updates are available but gives error while trying to update

    Motion data : error while updating...
    Network : error while updating

    there were another two apps which were giving error while updating....

    i checked my mobile for only 30 mins post upgrade, i came to my office and no smartphone allowed, another 2 hours to get my hands on my phone again...

    As of now, WM10 is Legen (wait for it) Dary.....
    11-20-2015 08:21 AM
  12. dimi516's Avatar
    My 640xl dual sim(only 3g) works fine...it's really impressive that with with only 1gb ram works so good...although w10 are ok on my phone,I have to say that it's not as smooth as it should be(like w8.1)..I'm talking about start screen scrolling and "loading" when you try to open some apps and some other stuff like that...

    Nonetheless I think it's almost perfect...just a little more adjustments and I think it's going to be the best midrange phone with w10....
    11-20-2015 08:42 AM
  13. Desmond Antwi's Avatar
    Everything works except my Outlook Mail app it opens but I just cant add my account so I have lost all my contacts. Supposing I was able to synchronise I will gain my contacts back. it's a technical previews so at least you will face problems.
    11-21-2015 01:35 PM
  14. Nandakumar Kesavan's Avatar
    Everything works except my Outlook Mail app it opens but I just cant add my account so I have lost all my contacts. Supposing I was able to synchronise I will gain my contacts back. it's a technical previews so at least you will face problems.
    @Desmond Antwi - i just came to update the issues i found, same kind of issue but on a different scenario

    Issue 1 : i can configure my outlook (primary) account in mail but my contacts are not syncing, i checked the settings in contacts i cant add my outlook account there, even though i go through the registration process successfully, it doesn't show the account information there and doesn't sync my outlook contacts (bummer)

    Issue 2 : Just like contacts my calendar account doesn't register my outlook account - lost my appointments

    Lost Lumia camera and the internal camera app isn't that good.

    Movies & TV - doesn't show in the app list but when i go to the store its shows the open button, select and the app launches.

    few applications icons are not showing in the application list....

    @kristalsoldier - can you verify these in your phone?

    @Desmond Antwi - do you have any other issues i have listed?
    Last edited by Nandakumar Kesavan; 11-21-2015 at 01:48 PM. Reason: included more content
    11-21-2015 01:47 PM
  15. Derausgewanderte's Avatar
    no major problems here except the ones listed in the blog post when released. Everything is working, including notifications with my Band. there are a couple system apps from Extras that want to update but are stuck with error in the store app. The actual apps work though.
    Works great on mine. The last two builds definitely were working very well as daily driver.

    Gmail accounts work fine and battery life is just as good as on 8.1 for me. I typically get two days out of it. No WiFi drops or connection issues at all. As I wrote, no problems here.
    11-21-2015 02:54 PM
  16. chmun77's Avatar
    I realized that calendar and MS store on 640 XL are having an older version as compared to 1520. I cannot view calendar in Week view, and the Downloads and updates are in a different menu location as compared to 1520. Already running the 10568 build on my 640 XL. Anyone else facing similar situations?
    11-22-2015 07:21 PM

Similar Threads

  1. Lumia 930|W10M users I need your help urgently!
    By Martsicky in forum Nokia Lumia 930
    Replies: 43
    Last Post: 03-18-2016, 05:51 PM
  2. How can I fix a usb connection issue in build 10581 after factory reset?
    By Windows Central Question in forum Nokia Lumia 930
    Replies: 11
    Last Post: 12-21-2015, 07:15 PM
  3. Is Lumia 735 'Qualcomm Quickcharge 2.0' capable?
    By Marc_SP in forum Nokia Lumia 730 & 735
    Replies: 2
    Last Post: 11-20-2015, 03:52 AM
  4. 10586.11 + nokia 1020 = brick (stuck at nokia logo)
    By markm75 in forum Windows 10 Mobile
    Replies: 6
    Last Post: 11-19-2015, 07:54 AM
  5. Lumia 950 and 950 XL launching in India on November 30
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 11-19-2015, 06:00 AM
LINK TO POST COPIED TO CLIPBOARD