1. daniel cooper2's Avatar
    My brand new 640 is a great phone with no problems but its slow on wifi i just don't get it. Everything else on the same wifi network is fine. It looks like the 640 is getting hung up on something in the middle of loading the page.
    07-26-2015 03:10 PM
  2. Rose640's Avatar
    If you're using IE I suggest trying different browser. Can't really suggest anything better since I'm not facing that issue mine is very smooth except for some IE crashes after the last update which screwed up more than few things.
    07-26-2015 05:52 PM
  3. kgraham182's Avatar
    I was having slow wifi speeds as well. If you are on TMO turn off wifi-calling, I think the phone is prioritizing phone calls over data.
    daniel cooper2 likes this.
    07-27-2015 11:11 AM
  4. daniel cooper2's Avatar
    I was having slow wifi speeds as well. If you are on TMO turn off wifi-calling, I think the phone is prioritizing phone calls over data.
    Thanks that worked.
    07-28-2015 10:38 AM
  5. Babs011's Avatar
    What does TMO stand for?
    11-07-2015 06:34 AM
  6. boonesmi's Avatar
    What does TMO stand for?
    t-mobile
    11-07-2015 04:40 PM

Similar Threads

  1. Windows 10 RTM very laggy and slow
    By angelblast1997 in forum Windows 10
    Replies: 3
    Last Post: 07-27-2015, 10:01 PM
  2. Is there an app so different passwords will open different screen views?
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 07-27-2015, 12:39 AM
  3. Build 10240 took my setting app away
    By namy_grooves in forum Ask a Question
    Replies: 0
    Last Post: 07-26-2015, 03:01 PM
  4. My Lumia 535 dual sim can't reset, why?
    By Windows Central Question in forum Microsoft Lumia 535
    Replies: 0
    Last Post: 07-26-2015, 02:29 PM
  5. Replies: 5
    Last Post: 07-26-2015, 02:03 PM
LINK TO POST COPIED TO CLIPBOARD