1. Neil Cannadine's Avatar
    Hi, My Lumia 640 will connect at work to WiFi and elsewhere but at home it continually freezes or restarts. If I manage to get in quick and switch off the WiFi on the phone it works perfectly well, or if I move out of range, the instant it connects again the problems re-appear.

    Any ideas?

    Thanks
    jlangner likes this.
    09-03-2015 07:25 AM
  2. Jazmac's Avatar
    Did you update to WinXM?
    Neil Cannadine likes this.
    09-03-2015 08:54 AM
  3. Neil Cannadine's Avatar
    Its brand new out of the box form my employer, and it didnt update and there are no updtaes available. not entirely sure what WinXM is either!
    09-03-2015 09:02 AM
  4. vipme's Avatar
    What band does your router emit the WiFi signal at, (b, g, n,) or a combination of them?
    Try switching between them and see what happens.
    09-03-2015 09:20 AM
  5. Jazmac's Avatar
    Its brand new out of the box form my employer, and it didnt update and there are no updtaes available. not entirely sure what WinXM is either!
    Windows 10 Mobile. I use WinXM for short.
    09-03-2015 07:51 PM
  6. jlangner's Avatar
    Hi, My Lumia 640 will connect at work to WiFi and elsewhere but at home it continually freezes or restarts. If I manage to get in quick and switch off the WiFi on the phone it works perfectly well, or if I move out of range, the instant it connects again the problems re-appear.

    Any ideas?

    Thanks
    I am not sure if same is my wife's phone would boot up, freeze, reboot and repeat. I went thru 3 phones, finally on 3rd phone I happened to turn off WiFi right before froze and worked from then on. I flipped WiFi back on and soon as started connecting phone locked, rebooted. I was able to turn back off again. After 1 week all good, except no WiFi... luckily she doesn't use much data.
    09-03-2015 08:14 PM
  7. jlangner's Avatar
    In case matters, I am using Netgear Nighthawk b/g/n.
    09-03-2015 08:37 PM
  8. Neil Cannadine's Avatar
    I am not sure if same is my wife's phone would boot up, freeze, reboot and repeat. I went thru 3 phones, finally on 3rd phone I happened to turn off WiFi right before froze and worked from then on. I flipped WiFi back on and soon as started connecting phone locked, rebooted. I was able to turn back off again. After 1 week all good, except no WiFi... luckily she doesn't use much data.
    Looks like we have the same problem!! Strange thing is the WiFi elsewhere seems fine. Will try the suggestion above with regards the band but really shouldn't have to, no other devices, which there are many, have had any problems connecting to my WiFi, not impressed so far!

    Using a ZTE router.
    09-04-2015 02:21 AM
  9. jlangner's Avatar
    Let me know if works...scared to mess with it after the 2 weeks of hell I had..lol. Same as you, I have used several other windows phone on my wifi, no issue, HTC one m8, lumia 635, lumia 521, lumia 925, none had any problem on wifi.
    09-04-2015 02:30 PM
  10. rchillin's Avatar
    I'm actually having similar issues but since I'm running Windows mobile 10, thought it was related to that. My 640 will come to screeching halt when it's switching radio bands (LTE to Wi-Fi, Wi-Fi to LTE, and recently no LTE to LTE). I was about to switch back to 8.1 and upgrade again but no I'm wondering if its a firmware issue???
    09-08-2015 06:22 PM

Similar Threads

  1. Replies: 4
    Last Post: 09-06-2015, 07:17 AM
  2. Replies: 1
    Last Post: 09-03-2015, 06:07 AM
  3. Replies: 1
    Last Post: 09-03-2015, 06:06 AM
  4. Replies: 1
    Last Post: 09-03-2015, 05:55 AM
  5. wi-fi isn't working properly on lumia 640xl.
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 09-03-2015, 05:28 AM
LINK TO POST COPIED TO CLIPBOARD