1. Birgitte Sciarretta's Avatar
    I have a Lumia 640 LTE that I use with a Straighttalk T-Mobile sim. This works great, I can browse the internet on my cellular network, I can send MMS and people see the pics I send. But I can't receive MMS. I get a message to download media content but it never shows up.

    I have a feeling it is not the APN settings, I have tried about 15 different configurations and the settings I have now work great except for receiving MMS. Any other settings won't let me send MMS or browse the internet.

    If not APN, what else can I try? I have owned my phone since July and have yet to receive a single MMS....
    Arlan Henry likes this.
    10-09-2015 05:29 PM
  2. worldspy99's Avatar
    Is the 640 the T-Mobile or the ATT version or the factory unlocked version? Can you post your internet settings? I have a ATT unlocked Lumia 640 that I am using on T-Mobile and I receive MMS without any issues. Usually I get the download media content message when I am on 2G or if I have a MMS from a iPhone. But when I am in a good signal area with LTE, I click that message and the picture always shows up.
    10-09-2015 06:18 PM
  3. Birgitte Sciarretta's Avatar
    This is the T-Mobile version, no contract, with a T-mobile compatible Straight Talk SIM.
    10-09-2015 06:28 PM
  4. Birgitte Sciarretta's Avatar
    10-09-2015 06:37 PM
  5. Birgitte Sciarretta's Avatar
    I get the message even with 4G LTE reception, and from both Android and iPhones. I don't know anyone else with Windows Phone, but when I send myself an MMS it's the same thing.
    10-09-2015 07:01 PM
  6. libra89's Avatar
    Do you have wifi calling on? Have you tried turning it off and seeing if it makes a difference? I recall wifi calling not allowing for MMS to work, only SMS.
    10-09-2015 08:44 PM
  7. Birgitte Sciarretta's Avatar
    I have Wi-Fi calling set to cellular preferred. I will try turning it off and see. Thanks for the suggestion.
    libra89 likes this.
    10-10-2015 11:39 AM
  8. Birgitte Sciarretta's Avatar
    Tried turning off Wifi calling but no change.

    Any other suggestions?
    10-10-2015 03:27 PM
  9. neodk's Avatar
    I do not think it's the WIFI calling because I have that on and get MMS just fine. I'm on the unlimited T-Mo plan so I rarely use WIFI unless I'm at some place that has a really strong signal / fast data.

    Now did you call Customer Service to verify you had the right APN settings? For about an hour or so after I got my T-Mo phone I didn't have working MMS on the 640. My APN settings were completely wiped out. Maybe you need to remove them completely, reboot the phone, re-add the APN settings, reboot the phone and then try again. I'm not sure if there was a problem loading the MMS settings from the SIM card or what - at least on mine this is how I've had to fix it. I also keep a text file handy that has these settings in case a factory reset kills them.
    10-12-2015 11:24 AM
  10. Birgitte Sciarretta's Avatar
    10-12-2015 12:24 PM
  11. neodk's Avatar
    Nobody?
    To be fair, before you posted "anybody" I did ask you to see if you contacted Customer Service to verify you did in fact have the correct APN settings for your phone. It could be that they just didn't provision correctly and you need to remove them, reboot, and reapply them.
    10-13-2015 08:51 AM
  12. Birgitte Sciarretta's Avatar
    How would I reapply them?
    I did use the settings from my carrier's website (Straighttalk) but I hesitate to call them, since they usually make things worse, not better.
    11-23-2015 10:09 AM
  13. allenc85's Avatar
    This is whats been working for me. Hope it helps
    mms apn name straight talk
    apn tfdata
    ip type IPv4
    proxy server mms3.tracfone.com
    proxy port 80
    mmsc htxp://mms-tf.net
    max mms size 1024
    11-23-2015 10:35 AM
  14. Birgitte Sciarretta's Avatar
    I finally managed to fix it. The settings are different for the T-mobile sims with Straight Talk.

    These settings work!!

    For Internet, just put wap.tracfone for APN and save.
    For MMS:

    APN: wap.tracfone
    WAP Gateway: 216.155.165.40
    WAP Port: 8080
    MMSC: http://mms.tracfone.com
    MMSC port: 80
    Max MMS Size: 10485
    libra89 likes this.
    11-23-2015 02:59 PM

Similar Threads

  1. Why am I unable to receive MMS on Lumia 640 LTE?
    By Birgitte Sciarretta in forum Windows Phone 8.1
    Replies: 5
    Last Post: 05-23-2016, 02:08 PM
  2. Microsoft is not ready to do "whatever it takes" for Windows Mobile
    By JohnIvory in forum Microsoft News & Rumors
    Replies: 115
    Last Post: 11-06-2015, 09:49 AM
  3. Why can't I start the Windows 10 Install (Win7)?
    By Windows Central Question in forum Windows 10
    Replies: 0
    Last Post: 10-09-2015, 05:25 PM
  4. App never pinned to start
    By honda accord 99 in forum Nokia Lumia 1520
    Replies: 2
    Last Post: 10-09-2015, 04:40 PM
  5. With a Surface 3 and Windows 10, does anyone know how to keep the camera function unlocked?
    By Windows Central Question in forum Microsoft Surface Pro 3
    Replies: 0
    Last Post: 10-09-2015, 04:38 PM
LINK TO POST COPIED TO CLIPBOARD