1. LumiaGuy's Avatar
    My Brother just unlocked his T-Mobile L640 and switched over to AT&T GoPhone service. He took his phone in to the AT&T Store in Santa Rosa and they moved his contact info over from his TM Sim card and supposedly changed any settings in the phone so it would work properly. He can make calls and send/receive texts but when you dial his phone, it doesn't ring and you immediately are prompted to leave a voicemail message.

    I have checked that Flight Mode and Quiet Hours aren't on etc, but can't figure out what the issue is.
    11-02-2015 09:15 PM
  2. ven07's Avatar
    check if anything was changed under call settings if anything was changed (maybe call forwarding). Remove the voicemail number and try again and lastly, insert a different sim to see if the issues still persist
  3. ven07's Avatar
    check if anything was changed under call settings if anything was changed (maybe call forwarding). Remove the voicemail number and try again and lastly, insert a different sim to see if the issues still persist
    11-02-2015 10:06 PM
  4. LumiaGuy's Avatar
    OMFG - I just spent over two hours calling AT&T GoPhone Customer Service multiple times, getting shuffled around between the Tech Dept, Porting Dept, getting disconnected multiple times, finally to be told I need to take the phone back to the AT&T Store.

    And I thought T-Mobile CS sucked!
    ven07 likes this.
    11-03-2015 01:29 AM
  5. ven07's Avatar
    OMFG - I just spent over two hours calling AT&T GoPhone Customer Service multiple times, getting shuffled around between the Tech Dept, Porting Dept, getting disconnected multiple times, finally to be told I need to take the phone back to the AT&T Store.

    And I thought T-Mobile CS sucked!
    I honestly can't imagine how pissed you must be at this point :/ but hope it works out.. keep us in the loop kay? :)
    11-03-2015 01:30 PM
  6. LumiaGuy's Avatar
    I honestly can't imagine how pissed you must be at this point :/ but hope it works out.. keep us in the loop kay? :)
    My brother has been at the AT&T Store this morning since 10:00 and they haven't been able to figure out what's wrong. I told him if they can't get it to work then just break the POS since he bought a protection plan and get his money back from Walmart then repurchase the AT&T version from WM. Not the most ethical thing to do but what else can he do?
    11-03-2015 02:48 PM
  7. ven07's Avatar
    My brother has been at the AT&T Store this morning since 10:00 and they haven't been able to figure out what's wrong. I told him if they can't get it to work then just break the POS since he bought a protection plan and get his money back from Walmart then repurchase the AT&T version from WM. Not the most ethical thing to do but what else can he do?
    Lol ethical? they shouldn't have boinked the phone in the first place :/
    libra89 likes this.
    11-03-2015 05:42 PM
  8. Mike Nelson5's Avatar
    Try a soft reset
    11-03-2015 06:56 PM
  9. LumiaGuy's Avatar
    Well, the folks at the AT&T Store on Santa Rosa Ave in Santa Rosa, CA don't have much of a clue as to what they're doing. My brother spent 2-1/2 hours there and his phone is still FUBAR. They used to have an employee that was very knowledgeable on Windows Phone and Smartphones in general but he is no longer there.

    Looks like one T-Mobile L640 is going to have a little accident...
    ven07 likes this.
    11-03-2015 07:37 PM
  10. LumiaGuy's Avatar
    Try a soft reset
    That was one of the first things I tried and more than once.
    ven07 likes this.
    11-04-2015 01:06 AM
  11. LumiaGuy's Avatar
    Finally, the problem is solved!

    Took escalating things to an AT&T Mobility Expert at AT&T Corporate. Turns out there was something screwed up in the Porting process and my Bro's phone is working fine now.
    libra89 and ven07 like this.
    11-06-2015 04:58 PM
  12. ven07's Avatar
    Finally, the problem is solved!

    Took escalating things to an AT&T Mobility Expert at AT&T Corporate. Turns out there was something screwed up in the Porting process and my Bro's phone is working fine now.
    Like we said earlier "they shouldn't have boinked the phone in the first place". Happy you guys managed to get it solved tho!
    11-07-2015 04:27 PM

Similar Threads

  1. Why won't my Microsoft Band connect to my Android phone?
    By Windows Central Question in forum Microsoft Band & Band 2
    Replies: 10
    Last Post: 12-15-2015, 09:53 PM
  2. Replies: 16
    Last Post: 12-03-2015, 08:32 PM
  3. Email Notification not in Action Center
    By The19thD0CT0R in forum Windows 10 Mobile Insider Preview
    Replies: 5
    Last Post: 11-12-2015, 11:25 AM
  4. Acer releases Windows Phone companion app for Liquid Leap fitness trackers
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 11-02-2015, 06:42 PM
  5. Replies: 0
    Last Post: 11-02-2015, 04:21 PM
LINK TO POST COPIED TO CLIPBOARD