1. rk agarwal's Avatar
    I have 2 android devices, 1 Windows 7 laptop and 1 Lumia 640 with Windows 10 anniversary update on it.

    I have an Airtel 3G dongle with WiFi for internet. All the android devices and the laptop can connect to the WiFi without issues. I can see the IPs being assigned for each device as it connects.

    But as soon as I try to connect the Lumia 640 to the WiFi, it first kicks out all other devices from the dongle, and then doesn't connect itself either. Other devices are now unable to connect as well. When I turn off the WiFi on my Lumia, other devices start coming back one by one.

    It is as if the Lumia is messing up the WiFi dongle completely!

    Can someone suggest what is happening and how to fix this?
    08-19-2016 12:20 AM
  2. Chintan Gohel's Avatar
    try changing the password of the wifi and try again
    Also, remove the network from the 640 and add it back
    libra89 likes this.
    08-19-2016 04:17 AM
  3. rk agarwal's Avatar
    Already done all that. Factory reset the dongle as well. Nothing helps. Only when 640 is trying to connect to wifi, the dongle kind of "resets" its IP leases to other already-connected devices and everything is dark.
    08-19-2016 06:13 AM
  4. Tom Snyder's Avatar
    Already done all that. Factory reset the dongle as well. Nothing helps. Only when 640 is trying to connect to wifi, the dongle kind of "resets" its IP leases to other already-connected devices and everything is dark.
    Seems like you've answered your question of what's causing your problem. I have not installed W10 on any of my devices, which includes 3 WP, 1 desktop, 2 laptops and 1 tablet because of problems I have saw some have and really take notice I said 'some' not all users.

    The bad thing about being one of the 'some' MS kinda lets you hang out in the outfield before a fix is issued. Windows 8.1 works to slick and problem free to even want the upgrade, plus the fact W10 runs as a service on your laptops, tablets and desktops at the control of MS.
    08-20-2016 10:38 AM
  5. rk agarwal's Avatar
    Bumping this thread in hopes of getting a solution!
    08-20-2016 05:44 PM
  6. Chintan Gohel's Avatar
    Already done all that. Factory reset the dongle as well. Nothing helps. Only when 640 is trying to connect to wifi, the dongle kind of "resets" its IP leases to other already-connected devices and everything is dark.
    try with only one device connected and then connect the 640. I'm trying to see if there is a certain number limit
    08-21-2016 01:57 PM
  7. rk agarwal's Avatar
    That was my first thought as well. Tried with no other devices connected, 640 still did not connect (or did once a twice after a long long wait). And with only one other device (laptop) connected, it still kicked out the laptop, reset the leases and sat there like a fool doing nothing.

    I am only able to use data on the phone for now. I don't want to do a reset because I have spent too much time customizing things. And this looks like a hardware issue? Funny that WiFi worked absolutely fine on this phone at my place in USA, but here at my dad's place in India, it is messed up. No clue why,.
    Chintan Gohel likes this.
    08-21-2016 05:55 PM
  8. Chintan Gohel's Avatar
    That was my first thought as well. Tried with no other devices connected, 640 still did not connect (or did once a twice after a long long wait). And with only one other device (laptop) connected, it still kicked out the laptop, reset the leases and sat there like a fool doing nothing.

    I am only able to use data on the phone for now. I don't want to do a reset because I have spent too much time customizing things. And this looks like a hardware issue? Funny that WiFi worked absolutely fine on this phone at my place in USA, but here at my dad's place in India, it is messed up. No clue why,.
    does the dongle have both 2.4GHz and 5GHz wifi signals?
    08-21-2016 11:34 PM
  9. rk agarwal's Avatar
    The dongle has only 2.4GHz wifi channels (and supports 802.11bgn). I read elsewhere on different posts that people actually had issues with 5GHz and they switched to 2.4GHz. Unfortunately, for me that is not an option.

    I should highlight that when I bought this phone in USA, it had ATT branded ROM on it. I had gone ahead and de-branded and put on AR CV ROM on it to get official Win10 update right away. Hope that has nothing to do with it.
    08-21-2016 11:51 PM
  10. Chintan Gohel's Avatar
    The dongle has only 2.4GHz wifi channels (and supports 802.11bgn). I read elsewhere on different posts that people actually had issues with 5GHz and they switched to 2.4GHz. Unfortunately, for me that is not an option.

    I should highlight that when I bought this phone in USA, it had ATT branded ROM on it. I had gone ahead and de-branded and put on AR CV ROM on it to get official Win10 update right away. Hope that has nothing to do with it.
    I don't think so.
    By the way, as an experiment, what if you connected to a public wifi, say at a cafe or college campus? Would all other devices disconnect there?
    08-22-2016 01:40 AM
  11. rk agarwal's Avatar
    Let me first thank you for taking time to reply to my questions and providing so many insights :)
    I am here in India visiting my parents for a little while. I haven't had a chance to connect to a public wifi here yet. But it is a good point. Let me see if I can connect to any wifi other than my dongle here and at least the issue can be narrowed down to the dongle then. I tried looking for some diagnostic/debug logs within the dongle, but doesn't look like it saves anything.

    It would be fun though if I were to whip out my Lumia 640 at a cafe and kick out hundreds of users there instantly! :)
    Chintan Gohel and Tom Snyder like this.
    08-22-2016 07:51 AM
  12. Chintan Gohel's Avatar
    Let me first thank you for taking time to reply to my questions and providing so many insights :)
    I am here in India visiting my parents for a little while. I haven't had a chance to connect to a public wifi here yet. But it is a good point. Let me see if I can connect to any wifi other than my dongle here and at least the issue can be narrowed down to the dongle then. I tried looking for some diagnostic/debug logs within the dongle, but doesn't look like it saves anything.

    It would be fun though if I were to whip out my Lumia 640 at a cafe and kick out hundreds of users there instantly! :)
    these USB dongles are sometimes poorly made and don't always work perfectly. This might be one case
    08-22-2016 08:22 AM

Similar Threads

  1. AT&T Lumia 1520 - Anniversary Update
    By mickeyd1000 in forum Windows 10 Mobile
    Replies: 4
    Last Post: 08-22-2016, 02:18 AM
  2. To Restore or Not to Restore after AU?
    By RealtorTechGuy in forum Windows 10 Mobile
    Replies: 17
    Last Post: 08-21-2016, 02:01 PM
  3. Anniversary Update
    By Windows Central Question in forum Ask a Question
    Replies: 5
    Last Post: 08-21-2016, 11:05 AM
  4. BestBuy has some Windows PCs on sale for it's 50th anniversity
    By drjekel_mrhyde in forum Expired & Archived Deals
    Replies: 3
    Last Post: 08-20-2016, 12:43 AM
  5. Microsoft re-releases Windows 10 build 14393.82 for PC Insiders with additional fix
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-18-2016, 09:00 PM
LINK TO POST COPIED TO CLIPBOARD