1. Leonidas Figueroa's Avatar
    Hello guys, just posting this in looking for a fix or solution, I Have my PC toshiba with Windows 10 Pro X86 based build already on Windows Insider release preview build 14393.187, so happens that when I connect my Microsoft Lumia 640 via usb showd an device connected as Lumia 640 LTE (RM-1073) without giving me acces to MTP, just days ago I was able using my device at MTP showing my device name and his respective icons as a lumia 640, I installed and repaired WDRT to fix drivers issues but no luck anyone with this problem?
    09-27-2016 04:56 PM
  2. abhishek singh21's Avatar
    Reboot the device when connected to laptop, this way your lap will install drivers once again and possibly you will be able to do MTP again
    RumoredNow and AnakoAlbert like this.
    09-28-2016 01:46 AM
  3. RumoredNow's Avatar
    Download and extract USBDeview Inside the folder > right click the exe > run as admin

    Delete all drivers marked Nokia or Lumia >plug the device into USB and let a fresh set of drivers install.
    09-28-2016 10:20 PM
  4. Mike Newport's Avatar
    Hello guys, just posting this in looking for a fix or solution, I Have my PC toshiba with Windows 10 Pro X86 based build already on Windows Insider release preview build 14393.187, so happens that when I connect my Microsoft Lumia 640 via usb showd an device connected as Lumia 640 LTE (RM-1073) without giving me acces to MTP, just days ago I was able using my device at MTP showing my device name and his respective icons as a lumia 640, I installed and repaired WDRT to fix drivers issues but no luck anyone with this problem?
    I had the same exact issue, tried everything. Finally I decided to install drivers from storage and I went into device manager , selected update driver software, selected browse my computer,then selected let me pick from a list of device drivers on my pc, there where 3 different choices all for MTP Driver the first two didn't work , but then boom the third one worked like a charm.
    10-04-2016 08:07 PM
  5. geoff morris's Avatar
    Brill!!!
    11-10-2016 02:14 PM
  6. Alexander Tvorogov's Avatar
    Thank you man!
    12-29-2016 03:08 PM
  7. Nahk786's Avatar
    Download the 'Windows Phone app for desktop' and use the B2X app an official outsourced support helpline by Microsoft with a live chat.option with humans not bots.
    02-26-2017 09:18 AM
  8. MakThaNife's Avatar
    I had the same exact issue, tried everything. Finally I decided to install drivers from storage and I went into device manager , selected update driver software, selected browse my computer,then selected let me pick from a list of device drivers on my pc, there where 3 different choices all for MTP Driver the first two didn't work , but then boom the third one worked like a charm.
    This worked for me! THANK YOU!
    03-13-2017 03:09 AM
  9. angelitto2005's Avatar
    I had the same exact issue, tried everything. Finally I decided to install drivers from storage and I went into device manager , selected update driver software, selected browse my computer,then selected let me pick from a list of device drivers on my pc, there where 3 different choices all for MTP Driver the first two didn't work , but then boom the third one worked like a charm.

    Excellent answer and solution. Thanks Sir.
    I had the same problem trying to connect my Lumia 650 to my PC. Nothing worked until i found this topic and this post. I reinstaled the MTP driver like Mike said and now everything works great again. YEY!
    03-13-2017 03:16 PM
  10. prabu d's Avatar
    I had the same exact issue, tried everything. Finally I decided to install drivers from storage and I went into device manager , selected update driver software, selected browse my computer,then selected let me pick from a list of device drivers on my pc, there where 3 different choices all for MTP Driver the first two didn't work , but then boom the third one worked like a charm.
    Thanks Man, i tried the third driver directly, (didnt try the first two) and boom. It worked.
    03-26-2017 04:48 PM
  11. Arung Isyadi's Avatar
    I had the same exact issue, tried everything. Finally I decided to install drivers from storage and I went into device manager , selected update driver software, selected browse my computer,then selected let me pick from a list of device drivers on my pc, there where 3 different choices all for MTP Driver the first two didn't work , but then boom the third one worked like a charm.
    Tried this method and it worked like a charm. Probably to make it clearer is to open device manager (please make sure that you have uninstall all Lumia related drivers first), then plug in you phone. There will be a new device detected in Other Devices section, right click it and chose "Update Device Driver" option. After that follow the exact steps from Mike and chose the #3 option. It was "MTP USB Driver" CMIIW. You should get your device works again.
    03-28-2017 12:05 AM
  12. rhapdog's Avatar
    I had the same exact issue, tried everything. Finally I decided to install drivers from storage and I went into device manager , selected update driver software, selected browse my computer,then selected let me pick from a list of device drivers on my pc, there where 3 different choices all for MTP Driver the first two didn't work , but then boom the third one worked like a charm.
    My phone quit being recognized after getting the Creators Update. I have tried over a dozen solutions listed on the Internet to no avail. THIS fixed it for me. YUUUGE Thanks for this.
    04-13-2017 09:25 AM
  13. shashank 1's Avatar
    I had the same exact issue, tried everything. Finally I decided to install drivers from storage and I went into device manager , selected update driver software, selected browse my computer,then selected let me pick from a list of device drivers on my pc, there where 3 different choices all for MTP Driver the first two didn't work , but then boom the third one worked like a charm.
    thanks man. it worked in 2 seconds
    06-14-2017 05:27 AM

Similar Threads

  1. Where are my pictures?????
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 10-02-2016, 05:11 AM
  2. Microsoft Lumia 535 Exclamation mark on boot up attempt
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 10-02-2016, 04:41 AM
  3. Why is my laptop stuck on the booting screen?
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 09-29-2016, 08:43 AM
  4. Microsoft's Visio diagram creation tool slated to be released for Windows phones
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-27-2016, 03:11 PM
  5. Guide to Windows 10 Precision Touchpad gestures
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-27-2016, 03:11 PM
LINK TO POST COPIED TO CLIPBOARD