1. dontbeso's Avatar
    I have an AT&T (unlocked) lumia 640. I've been notified about an update since last week. Successfully downloaded (many times). The phone, however, won't prompt me to install it after the download is complete. it just says: downloading uptade 100% for more than two hours. is anyone else having this issue?

    I am right now on build 10586.107

    Thanks all.
    Last edited by dontbeso; 10-29-2016 at 12:35 PM.
    10-28-2016 09:38 AM
  2. libra89's Avatar
    How's your storage space? Do you have enough to do the update? Are you trying to install on WiFi?

    Also, how's your battery? I can't recall the percentage, but if your battery is under that, it's not going to install at all.
    10-28-2016 09:44 AM
  3. dontbeso's Avatar
    @libra89 I have around 4 gig free. I don't have an SD card yet on it. I did a hard reset just to clear up things and tried again: same result.
    The phone is being charged meanwhile so I don't think it is related to the battery.
    Yes I am on WiFi.
    I am seriously thinking of rolling back to 8.1, maybe when I upgrade again to windows 10 I will have the latest available build?
    10-28-2016 12:29 PM
  4. libra89's Avatar
    Hmm, this is strange. Not sure what the deal is.

    You can try that possibly. I hate that you might have to do such a solution, but that should work.
    10-28-2016 02:56 PM
  5. Palm_forlackofchoice's Avatar
    When my 635 updated to .321 it took forever and then failed on first try. I hard reset then it updated again and took longer than two hours. Try letting it go over night.
    10-28-2016 04:28 PM
  6. dontbeso's Avatar
    Well, I was still not able to have it installed, so I enrolled back in insider preview and got build 14393.351. That one installed smoothly and everything seems to be working properly. Thanks all.
    libra89 and abhishek singh21 like this.
    10-29-2016 12:35 PM
  7. abhishek singh21's Avatar
    i guess the issue had been because you were way behind on updates as you needed the initial anniversary update first over which this patch would be downloaded as you were on th2 build that too the old one. insiders solved the issue that great.
    10-30-2016 04:17 AM

Similar Threads

  1. lumia 650 switches off in pocket
    By atomicadam13 in forum Microsoft Lumia 650
    Replies: 2
    Last Post: 11-16-2016, 01:23 PM
  2. What if song is not DRM free in Lumia for ringtone
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 10-28-2016, 11:57 AM
  3. Unable to install skype on Lumia 535
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-28-2016, 08:59 AM
  4. Skype Video button N/A on Lumia 735 running Windows 10
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-27-2016, 09:48 PM
  5. Windows 10 PC build 14393.351 now rolling out to the general public
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-27-2016, 04:50 PM
LINK TO POST COPIED TO CLIPBOARD