1. Philip Hamm's Avatar
    I got a new Lumia 650 dual SIM for Black Friday and I'm having two extremely frustrating issues with it. I was hoping someone here may have a fix or two for me.

    1) Major problems with taking and viewing photos on my micro-SD card, a Patriot branded 64G card I got because I was having major issues with a SanDisc micro-SD card in my Lumia 635. (The issues I was having with the SanDisc in the 635 were not fixed by replacing it in that phone so I think the Patriot may have the same issues).

    So this long story goes back to my T-Mobile Lumia 635. I had a SanDisc Micro-SD card in that phone that worked great until the final software update that T-Mobile provided - that made it so that apps on the card all broke, crippling the phone. I replaced the micro-SD with another one, but had the same problem (it was the same make and model). Recently I had been using the Lumia 635 again so I replaced the SanDisc branded 64G card with one from Patriot, and sadly it had the same bug.

    Fast forward to current day - part of the reason I got this 650 was because of this frustrating incompatibility.

    I do not save any apps on the 650. Only music and photos. The problem is sometimes when I save photos (using two different versions of pro-shot and the built-in photo app - I think all photo apps would have the same bug but I've only tried 3) it will take forever to save the photo - when I open the photos app the photos don't save. Sometimes the photos if I try to delete them say I don't have permission to delete. When the photos are messed up like this if I try to turn off the phone it will sit on "Goodbye" forever - I have to open the back and pull the battery or do a hard power down to power the phone down. This happens ALL THE TIME whenever I use my cameras. I haven't tried another micro-SD card yet. I don't want to buy another micro-SD card. For now I've changed the photo saving to the in-phone memory. I'll see if this fixes the issue.

    Also - perhaps related - if I try to access files and folders on the SD card through the phone - using a USB cable to connect the phone to my computer - the access to the SD card is excruciatingly slow. It's basically unusable. I have to dismount the card and power down, open the phone and remove the card to add music files or download photos or anything like that. When I connect the card to my computer or Surface tablet it is blazingly fast.

    Anyone having similar odd issues with a Micro-SD card?

    2) It loses WiFi capability for network connection. I have a WiFi router in my house and the phone is connected often I will look down and the WiFi signal will be gone. When I try to connect it says there's no internet connection but I know there is - other devices are connected like my tablets. If I re-boot the phone I get no problem great wifi.

    Other than these issues I like the phone. Nice screen, nice form factor, good cameras, reasonable performance (if slow sometimes - could be caused by the SD card problem?).

    It's odd that my SD card issues started with a specific Windows 8.1 phone build, and continue to Windows 10 with many of the same symptoms.
    AbhiWindows10 likes this.
    12-27-2016 12:13 PM
  2. Dano91's Avatar
    1.) Did you try to format that SD card in your L650?
    2.) This WiFi bug has been fixed with last firmware update, but I'm not sure if T-mobile already pushed it out to public. Can you tell us which firmware version you have? (Settings > System > About > More info)
    libra89 and aximtreo like this.
    12-27-2016 12:31 PM
  3. Philip Hamm's Avatar
    I have not tried to format the SD card in the L650. I believe I formatted it in the 635 before. I can try that. It will be a PITA to copy my music off it then back but it will be fast. Do you think that would actually help>


    Firmware revision number is: 01078.00042.16352.50002

    The 650 is unlocked from the Microsoft store, T-Mobile doesn't support it. There's nothing on that pane on the phone for updating the firmware.
    AbhiWindows10 likes this.
    12-27-2016 05:49 PM
  4. AbhiWindows10's Avatar
    Originally posted by Philip Hamm
    I have not tried to format the SD card in the L650. I believe I formatted it in the 635 before. I can try that. It will be a PITA to copy my music off it then back but it will be fast. Do you think that would actually help>


    Firmware revision number is: 01078.00042.16352.50002
    1) THAT is the mistake you made my friend.
    You need to format a card (new or old) whenever you use it with a "new" or different device. This is a fact and it applies to even Android phones.

    2) Your firmware is up to date and there's none that was released recently. Try updating the OS to the latest, i.e., 14393.576

    Since you aren't an app guy, it wouldn't hurt to do a HARD RESET (factory reset) just in case the above doesn't help. Also, do you always keep RESTORING from backup when setting up the phone???? If yes, then don't do that. Even if you DON'T restore and start clean, you WILL NOT lose your contacts and SMS's. They'll sync back automatically. The only thing you'll need to tweak are the settings and which is for the better since WP8.1 backups won't work on W10M. For all you know, it might be corrupting parts of your OS.

    Tip - Always use a good card reader (not cheap ones) or plug in direct to PC if it has one (like Surface) to get the best speeds. I use a SanDisk UHS-1 32GB card and its great. Don't even think of using USB 2.0 via cable to transfer large number of files. A few files aren't an issue but no thousand's of songs.

    :)
    libra89 likes this.
    12-27-2016 10:04 PM
  5. AbhiWindows10's Avatar
    And for your wife issues, i think it'll be just better if you do a hard reset for now and make sure the OS is at 10.0.14393.576 "before" resetting.
    12-27-2016 10:06 PM
  6. Philip Hamm's Avatar
    I can copy the files and re-format the card because I don't keep apps on the card. I'll do that; it should be easy enough.

    I did not restore from a previous save when I first set up this phone. I got an error and just started from scratch. When my Lumia 635 was lost/stolen I used that function to restore and it was fantastic under Windows Phone 8.1.

    I'm not doing a hard reset on a phone that's a month old. That's not a reasonable suggestion IMO. The OS is up to date according to the settings "update" page.
    Last edited by Philip Hamm; 12-27-2016 at 10:49 PM.
    12-27-2016 10:24 PM
  7. Philip Hamm's Avatar
    For micro-SD file transfer I'm using the micro-SD connector on my computer, similar to the one on my Surface tablet. Mid-teens MB/sec transfer times.
    12-27-2016 11:19 PM
  8. Player Piano's Avatar
    A WiFi bug persists. This began a few builds back on my 950. The initial WiFi bug was squashed with the firmware update, but there is a new WiFi bug not surprisingly.
    Last edited by Player Piano; 12-29-2016 at 08:29 AM.
    12-28-2016 09:16 PM
  9. darrell reimer's Avatar
    I got a new Lumia 650 dual SIM for Black Friday and I'm having two extremely frustrating issues with it. I was hoping someone here may have a fix or two for me.

    1) Major problems with taking and viewing photos on my micro-SD card, a Patriot branded 64G card I got because I was having major issues with a SanDisc micro-SD card in my Lumia 635. (The issues I was having with the SanDisc in the 635 were not fixed by replacing it in that phone so I think the Patriot may have the same issues).

    So this long story goes back to my T-Mobile Lumia 635. I had a SanDisc Micro-SD card in that phone that worked great until the final software update that T-Mobile provided - that made it so that apps on the card all broke, crippling the phone. I replaced the micro-SD with another one, but had the same problem (it was the same make and model). Recently I had been using the Lumia 635 again so I replaced the SanDisc branded 64G card with one from Patriot, and sadly it had the same bug.

    Fast forward to current day - part of the reason I got this 650 was because of this frustrating incompatibility.

    I do not save any apps on the 650. Only music and photos. The problem is sometimes when I save photos (using two different versions of pro-shot and the built-in photo app - I think all photo apps would have the same bug but I've only tried 3) it will take forever to save the photo - when I open the photos app the photos don't save. Sometimes the photos if I try to delete them say I don't have permission to delete. When the photos are messed up like this if I try to turn off the phone it will sit on "Goodbye" forever - I have to open the back and pull the battery or do a hard power down to power the phone down. This happens ALL THE TIME whenever I use my cameras. I haven't tried another micro-SD card yet. I don't want to buy another micro-SD card. For now I've changed the photo saving to the in-phone memory. I'll see if this fixes the issue.

    Also - perhaps related - if I try to access files and folders on the SD card through the phone - using a USB cable to connect the phone to my computer - the access to the SD card is excruciatingly slow. It's basically unusable. I have to dismount the card and power down, open the phone and remove the card to add music files or download photos or anything like that. When I connect the card to my computer or Surface tablet it is blazingly fast.

    Anyone having similar odd issues with a Micro-SD card?

    2) It loses WiFi capability for network connection. I have a WiFi router in my house and the phone is connected often I will look down and the WiFi signal will be gone. When I try to connect it says there's no internet connection but I know there is - other devices are connected like my tablets. If I re-boot the phone I get no problem great wifi.

    Other than these issues I like the phone. Nice screen, nice form factor, good cameras, reasonable performance (if slow sometimes - could be caused by the SD card problem?).

    It's odd that my SD card issues started with a specific Windows 8.1 phone build, and continue to Windows 10 with many of the same symptoms.
    I'm having both of these same problems. I keep loosing wifi connections, on all wifi services (home, stores, Starbucks etc), and... I have repeat episodes of my phone crashing, then saying there is a problem with my SD card, scanning and fixing it; then the same thing happening a few days later. This phone crashes way too much. I've done 2 full hard resets; works great for the first day or two; then everything starts to go bad. Apps crash (especially Starbucks, Facebook), then my screen goes dark; I get the 'resuming......' thing happening; then my phone freezes and crashes....very frustrating.
    12-29-2016 09:14 PM

Similar Threads

  1. How to restore wireless connection?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-27-2016, 11:04 AM
  2. Ring in 2017 with 25% off all the best Windows accessories!
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-27-2016, 10:42 AM
  3. Can I buy a surface pro 4 in the US and have the warranty in Canada.
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 12-27-2016, 10:33 AM
  4. How to spend the Amazon gift card you got for the holidays
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-27-2016, 10:11 AM
  5. Bust a move, not your knees, with Skateboard Party 3
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-27-2016, 09:11 AM
LINK TO POST COPIED TO CLIPBOARD