02-10-2018 01:06 PM
720 ... 2223242526 ...
tools
  1. Nabikun's Avatar
    Hello everyone!

    I just got a Lumia 950XL (coming from a Lumia 1020) and want to know if my device have a problem or if this is normal:

    In very low light, when I use the rear camera I got a purple/pinkish haze or fog. Especially when recording videos.
    I watched many "950/950XL versus" videos on youtube and almost every recording have this haze.
    I know that when there is almost no light the sensor uses a high ISO to compensate.
    On picture mode we can lower the ISO, but not on video mode.
    What bugs me is this haze showing not on entire scene but almost only at one side (top of the screen).
    The symptom is exactly like this one @3:40:

    Switching to video mode and completely covering the lens easily shows the symptom.

    Is this normal for this sensor? Or I got a bad sample/batch?
    Thank you very much!
    Last edited by Nabikun; 05-22-2016 at 03:40 PM. Reason: Add when the youtube video shows the "problem"
    05-22-2016 02:39 PM
  2. P1ng0fDeath's Avatar
    Its visible only on gray background that is strange.
    Have anyone this "strange" greenish grey tint?

    I have a strange purple-ish tint on grey backgrounds on my 930, which also has OLED screen, and it's very common among this model. I'm not sure if it's common for all OLED displays out there or if there's a fix.
    You can try increasing the low level of brightness on Brightness Profile until it makes it less apparent.
    05-22-2016 03:17 PM
  3. eins2dreivier's Avatar
    @Nabikun
    It's normal, no worries! And it's not the sensor, it's the software. I went through 3 XL's and tested a few more in stores and all of them had the issue...
    Nabikun likes this.
    05-22-2016 03:27 PM
  4. Nabikun's Avatar
    Oh, I see. But why almost only at one side?
    Well, I felt relieved now. Hopefully they bring a good camera app with more options and/or a new firmware to correct this.
    Thank you for your quick reply!
    05-22-2016 03:57 PM
  5. vader42's Avatar
    Actually, I thought it was the sensor picking up heat when the ISO has been cranked up. All sensors suffer from what is called "dark current". This basically means, that heat rather than light can be converted into an image. In normal use, this is drowned out by light, but in very dark situations it can be seen.

    ISO is simulated by increasing the gain from the sensor. Think of it like an amplifier - the only problem is that as well as amplifying the signal (light), you also amplify the noise (dark current). These small sensors are pushed to, and sometimes beyond their limit. With photos, you can compensate by slowing the shutter to get more photons, which in turn make the image brighter. With video, you want to maintain a frame rate, so there is only so much you can do with the shutter. To combat this, they increase the ISO (gain) of the sensor. The heat from the device is enough to show a purplish tinge in this case. In astronomy, cameras are cooled to avoid this phenomenon.

    It is normal, so don't worry - you can choose between no video (ie too dark), or a purplish tinge. You can always post process the video to remove the purple.

    Cheers

    PS. That is why you normally just see one corner/side - that is where the CPU/GPU is closest. Happens to many phones, even the great pureview 808 suffered from purple tinge :)
    sahib lopez and Nabikun like this.
    05-22-2016 04:14 PM
  6. Nabikun's Avatar
    Wow! Very nice explanation!
    It makes perfect sense.
    Thank you!
    05-22-2016 04:53 PM
  7. eins2dreivier's Avatar
    @vader42
    At first I thought it was a heat problem...but when you check the raw files you can see that there is no hue or any other anomalies. And there's purple hue at low iso too if you set the shutter speed to be short enough. The purple hue is just a result of the software trying too hard to make the picture brighter.
    05-23-2016 03:22 PM
  8. kastron's Avatar
    Hi, i have problem with gray colors on my lumia 950 xl. For example when i have gray background such as setting have. On higher brightness setting gray is true gray but when i change brightness to lower settings gray start showing greenish tint, usually visible in dark. Is that normal on amoled displays or i have defective device?

    left side brightness 15% right side 100%

    Attachment 126655
    Have anyone this issue? please
    Last edited by kastron; 05-24-2016 at 08:30 PM.
    05-23-2016 06:59 PM
  9. Nabikun's Avatar
    Hi!
    Well, I guess this is common for AMOLED displays. I see different shades of gray on my 950 XL depending of the screen brightness level and/or ambient light. This is how my 1020, 1520 an 950 XL (from left to right) exhibits the settings screen (almost pitch black ambient, auto brightness off):

    0-brightness.jpg
    0% Brightness

    100-brightness.jpg
    100% Brightness

    Sorry for the bad pictures. I didn't use a Lumia.

    Bear in mind that these pictures do not represent an accurate reproduction of the screens' gray tint. And probably can't be used as a proof that your device is defective or normal, as we used different cameras on different ambient lighting.

    Hope this helps.
    05-24-2016 03:39 PM
  10. kastron's Avatar
    Hi!
    Well, I guess this is common for AMOLED displays. I see different shades of gray on my 950 XL depending of the screen brightness level and/or ambient light. This is how my 1020, 1520 an 950 XL (from left to right) exhibits the settings screen (almost pitch black ambient, auto brightness off):

    Click image for larger version. 

Name:	0% brightness.jpg 
Views:	23 
Size:	1.41 MB 
ID:	126750
    0% Brightness

    Click image for larger version. 

Name:	100% brightness.jpg 
Views:	16 
Size:	1.63 MB 
ID:	126751
    100% Brightness

    Sorry for the bad pictures. I didn't use a Lumia.

    Bear in mind that these pictures do not represent an accurate reproduction of the screens' gray tint. And probably can't be used as a proof that your device is defective or normal, as we used different cameras on different ambient lighting.

    Hope this helps.
    Thanks Nabikun! But why you have different settings menu (i mean that icons, i have only text)? In your photo i see black background on 0%, what is the real tint?
    That green tint in my picture is accurate reproduction :(
    05-24-2016 04:38 PM
  11. Nabikun's Avatar
    Hi! The different settings menu is because I'm on insider's preview build 10.0.14342.1003. They introduced icons for individual settings pages on Build 14322. The 950 XL real tint is not black. It's a brighter, slightly greener gray tone.
    It looks like the 1520 tint at the 0% brightness picture above, just a tad darker.
    I guess your 950XL is fine. :)
    05-24-2016 06:36 PM
  12. mtf1380's Avatar
    The symptom is exactly like this one @3:40:
    Looked to me like the camera on right @3:40 was picking up luminous flux from the security light on the building off camera on left. when you pan left the light brightness is pretty evident.
    05-24-2016 08:11 PM
  13. kastron's Avatar
    Hi! The different settings menu is because I'm on insider's preview build 10.0.14342.1003. They introduced icons for individual settings pages on Build 14322. The 950 XL real tint is not black. It's a brighter, slightly greener gray tone.
    It looks like the 1520 tint at the 0% brightness picture above, just a tad darker.
    I guess your 950XL is fine. :)
    Ok thank you. It was strange because I looked for this problem on google and all I found was "pink/yellow tint when brightness low on amoled" but not mention that green hue only appears on some gray colors... ie i dont have to refund my lumia? :)

    PS: I must correct myself - green tint is most noticeable at brightness 15% or so
    Last edited by kastron; 05-24-2016 at 08:46 PM.
    05-24-2016 08:18 PM
  14. aetneerg83's Avatar
    Anyone having trouble with the keyboard not popping up when trying to type things into the text boxes of anything? I.E. texting, searching, forums, etc... I am on the latest Fast Ring build and everything is broken trying to text and type things into the text fields. I have to refresh pages to type on it.
    05-25-2016 12:55 AM
  15. mtf1380's Avatar
    Anyone having trouble with the keyboard not popping up when trying to type things into the text boxes of anything? I.E. texting, searching, forums, etc... I am on the latest Fast Ring build and everything is broken trying to text and type things into the text fields. I have to refresh pages to type on it.
    Yes, experiencing the same issue on the 950XL.
    05-25-2016 06:35 AM
  16. Jack Ciriello's Avatar
    My 950XL restarts after taking pictures sometimes. It freezes while trying to save the picture and then restarts (and the picture doesn't save). I had originally thought it was because I was saving to the microSD (and assumed it was a faulty card) but I have since stopped saving to the SD and it still does it.

    Any ideas?
    05-25-2016 08:15 AM
  17. kastron's Avatar
    I found another problem with display on lumia 950 XL - smearing when scrolling dark gray elements/options mainly on low brightness in dark room. The gray will kind of turn a lil' bit purple/blue or something like that.

    For example here is test picture:

    Set brightness to 15% or so, go to dark room an scroll that picture to see if you got same problem.
    Have I defect display or its normal?
    7c49c58.png
    Last edited by kastron; 05-25-2016 at 12:43 PM.
    05-25-2016 10:59 AM
  18. jirkahtc's Avatar
    Amoled = normal
    05-29-2016 01:30 PM
  19. Nabikun's Avatar
    Yes. Unfortunately it's one of the AMOLED weakness. =( At low brightness the pixels can't light up fast enough and creates this smudge/trail on screen. Well, if you aren't satisfied with you current device, and have the option to swap for a new one, go for it!
    05-29-2016 02:57 PM
  20. zimilaci's Avatar
    Hi There,

    I have a short question...or I noticed a bug...


    Every time when I download a picture in the Photos app, in the app it seems as it should (the pictures are gone) but when I attach my phone to the pc, I can still see the deleted pictures in the camera roll folder.... HOW the Heck could that happen (after restart is the same, photos app does not see the deleted ones, but whatsapp for instance ....Yes....
    05-30-2016 01:48 AM
  21. kastron's Avatar
    Yesterday i compared with other lumia 950XL, both brightness 0% and gray background (mine is right):

    1.jpg
    05-30-2016 10:02 AM
  22. kastron's Avatar
    If you want to see what tint you have try this: download app: Screen Test Helper, go to custom color, set Red Green Blue to 11%
    And set brightness to 15-25. Post picture to see how your grays looks like.
    06-04-2016 03:04 PM
  23. Shayan Davoodi1's Avatar
    Hello people.
    I have audio problems.

    When I'm using headphones and listening to music, suddenly it starts to drop the volume to 0. I have to press the volume down button one or two times to be able to increase the volume again.

    Any idea how to fix this?

    I also removed the back cover cuz at first I thought it's a pressure caused from the inside of back cover to the volume down button and makes this happen but it also happens without the back cover on !

    The problem doesn't exist when I'm not using headset ( on the loud speaker ).

    Making me mad because I can't listen to a music which is also possible with a 20$ phone...
    06-05-2016 01:48 PM
  24. Michael Bromley's Avatar
    I started having the same problem recently, where the phone freezes then shuts down on trying to take a picture or video. It's in frequent but has happened enough to be a concern.
    Then the phone completely froze and started buzzing loudly and wouldn't stop until a power/vol-down shutdown (soft reset). This has happened three times in the last month.
    Mine is a 950 not XL, but seeing your post I thought to ask if we are having similar trouble. I have OS build 39033. Next time it happens I'll do a hard reset and hope it's not a hardware issue.
    06-09-2016 01:03 PM
  25. Shayan Davoodi1's Avatar
    I started having the same problem recently, where the phone freezes then shuts down on trying to take a picture or video. It's in frequent but has happened enough to be a concern.
    Then the phone completely froze and started buzzing loudly and wouldn't stop until a power/vol-down shutdown (soft reset). This has happened three times in the last month.
    Mine is a 950 not XL, but seeing your post I thought to ask if we are having similar trouble. I have OS build 39033. Next time it happens I'll do a hard reset and hope it's not a hardware issue.
    Neither hard nor soft reset didn't work.
    I think that's hardware's fault...

    Dear Microsoft, If you can't make devices, then JUST SIMPLY DON'T. I PAID FOR THIS USELESS PIECE OF PLASTIC !!!
    06-10-2016 04:11 AM
720 ... 2223242526 ...

Similar Threads

  1. [Quick Impressions] Who Just Got The Lumia 950 XL?
    By Indistinguishable in forum Microsoft Lumia 950 XL
    Replies: 397
    Last Post: 10-13-2017, 10:21 PM
  2. Cases/Covers + Accessories for your Lumia 950XL
    By Indistinguishable in forum Microsoft Lumia 950 XL
    Replies: 538
    Last Post: 09-30-2017, 08:36 AM
  3. [Showing Off] My 950 XL Start + Lock Screens
    By Indistinguishable in forum Microsoft Lumia 950 XL
    Replies: 228
    Last Post: 06-29-2017, 02:13 PM
  4. How can I print from a Nokia Lumia 1320?
    By Windows Central Question in forum Nokia Lumia 1320
    Replies: 3
    Last Post: 12-27-2015, 07:00 AM
  5. Save some cash on Lumia 950 and 950 XL accessories with new Essentials Bundle promotion
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 11-20-2015, 10:00 AM
LINK TO POST COPIED TO CLIPBOARD