1. Ethan Alvaree's Avatar
    Just got two unlocked Lumia 950 XLs from the Microsoft Store. Took them to T-Mobile, purchased a plan for 2, and got new SIM cards. While we were in the store, our 950 XLs had service and were able to place/answer calls and send/receive MMS messages. Everything seemed OK.

    Unfortunately, as soon as we got home, both 950 XLs lost celluar service. We see a circle with a slash through it over the network bars. Going into Settings > Network & Wireless > Cellular & SIM we see "no network found". To further investigate, we went into "SIM 1 settings" to see what options are selected:
    -Under "Highest connection speed", we tried changing from LTE (highlighted) to both 4G and 2G, however that didn't fix the problem
    -Under "Search for networks" we have the options "automatic", "AT&T (LTE,3G,2G)", and "Verizon (Forbidden)". This option is currently set to "automatic".
    -Under "Cellular connection profile", we have set "T_Mobile". (That is the only option.)
    -Under "get the latest cellular settings from your mobile operator", tapping "update settings" has no effect.
    -Under "Internet APN" we have "Default APN" added, and under "MMS APN" there seems to be no setting added yet.

    Anyone else having issues with voice and text on their Lumia 950 XLs with T-Mobile?
    11-28-2015 02:49 AM
  2. rdubmu's Avatar
    What are the settings you have under Internet APN? Have you tried to reboot your phone? Do you have service in your home?
    11-28-2015 03:44 AM
  3. Rezzee's Avatar
    Just got two unlocked Lumia 950 XLs from the Microsoft Store. Took them to T-Mobile, purchased a plan for 2, and got new SIM cards. While we were in the store, our 950 XLs had service and were able to place/answer calls and send/receive MMS messages. Everything seemed OK.

    Unfortunately, as soon as we got home, both 950 XLs lost celluar service. We see a circle with a slash through it over the network bars. Going into Settings > Network & Wireless > Cellular & SIM we see "no network found". To further investigate, we went into "SIM 1 settings" to see what options are selected:
    -Under "Highest connection speed", we tried changing from LTE (highlighted) to both 4G and 2G, however that didn't fix the problem
    -Under "Search for networks" we have the options "automatic", "AT&T (LTE,3G,2G)", and "Verizon (Forbidden)". This option is currently set to "automatic".
    -Under "Cellular connection profile", we have set "T_Mobile". (That is the only option.)
    -Under "get the latest cellular settings from your mobile operator", tapping "update settings" has no effect.
    -Under "Internet APN" we have "Default APN" added, and under "MMS APN" there seems to be no setting added yet.

    Anyone else having issues with voice and text on their Lumia 950 XLs with T-Mobile?
    I have T-Mobile and also purchased a 950 XL unlocked from the Microsoft Store. No abnormal issues to report here. Have you had T-Mobile prior to getting these phones? My service generally takes a serious hit when I go into my apartment, but I still usually get 1-2 bars (enough for phone calls and texting).
    11-28-2015 03:47 AM
  4. ferretzombie's Avatar
    My 950xl hooked up to t-mobile fine. But I can't figure out how to get wifi calling to work.
    11-28-2015 04:03 AM
  5. gerrymad's Avatar
    Just got two unlocked Lumia 950 XLs from the Microsoft Store. Took them to T-Mobile, purchased a plan for 2, and got new SIM cards. While we were in the store, our 950 XLs had service and were able to place/answer calls and send/receive MMS messages. Everything seemed OK.

    Unfortunately, as soon as we got home, both 950 XLs lost celluar service. We see a circle with a slash through it over the network bars. Going into Settings > Network & Wireless > Cellular & SIM we see "no network found". To further investigate, we went into "SIM 1 settings" to see what options are selected:
    -Under "Highest connection speed", we tried changing from LTE (highlighted) to both 4G and 2G, however that didn't fix the problem
    -Under "Search for networks" we have the options "automatic", "AT&T (LTE,3G,2G)", and "Verizon (Forbidden)". This option is currently set to "automatic".
    -Under "Cellular connection profile", we have set "T_Mobile". (That is the only option.)
    -Under "get the latest cellular settings from your mobile operator", tapping "update settings" has no effect.
    -Under "Internet APN" we have "Default APN" added, and under "MMS APN" there seems to be no setting added yet.

    Anyone else having issues with voice and text on their Lumia 950 XLs with T-Mobile?
    I had a similar issue and it was easily resolved or me. Go back into your SIM 1 settings and look for the "Cellular connection profile" drop down. I had originally selected T-Mobile and my service was horrible. Switch the drop down to t_mobile. This should reprovision the phone with new settings. You may also need to follow that up with tapping the update settings button. After I switched profile my phone restarted and my connection has been great.
    11-28-2015 10:05 AM
  6. TexasLabRat's Avatar
    could be that your house is just a black hole for t-mobile signal. Drive back to the store and see if it starts working again.
    11-28-2015 12:20 PM
  7. copjake's Avatar
    I think there is no T-Mobile service in your house the fact that you scan for networks and it doesn't show T-Mobile as one of them tells me your area is dead for T-Mobile my XL actually have the best signal of any T-Mobile branded phone I have ever used, only the Lumia 640 had this good of a signal but, the XL actually work in one area where the 640 would not, It sucks that the specs say it supports WI-FI calling when it clearly doesn't.
    11-28-2015 12:39 PM
  8. rdubmu's Avatar
    It does support wifi calling but T-Mobile needs to send an update to activate it
    11-28-2015 02:37 PM
  9. Ethan Alvaree's Avatar
    Hey all. Thanks for your replies. I wanted to post an update.

    It seems like the problem is our condo is a coverage dead zone. When we left the condo today, our service gradually returned as we reached the street.

    If that's the case, we don't have many options - we may have to switch to AT&T. Practically speaking, what would be the differences (aside from AT&T being more expensive)? Would I have all the same features (e.g. WIFI calling, Visual Voicemail, etc.) between T-Mobile and AT&T?

    Speaking of WIFI-calling, is this something I could enable with T-Mobile? Theoretically speaking, that would solve the problem of the coverage dead zone in my condo, since we do have WIFI in our condo. But how would we go about setting that up?
    11-28-2015 03:55 PM
  10. mattdistro's Avatar
    You're not going to have WiFi calling or Visual Voicemail with the 950 XL on any carrier.

    You have 2 options.

    1. Switch to AT&T
    2. Get a 4G LTE Cellspot from T-Mobile (https://support.t-mobile.com/communi...g-lte-cellspot)

    The latter will give you coverage in your condo, but it is open, so if you have neighbors close by that have T-Mobile they could potentially bog down your internet connection. Probably not likely anyone would if your condo is a dead spot.
    jmajid likes this.
    11-28-2015 04:02 PM
  11. spdsk8race's Avatar
    on your phone would you mind checking and seeing if you have your band 2, 4, 12 and 1700 turned on? they might have somehow got disabled.. and add a new apn fast.t-mobile.com
    11-28-2015 07:39 PM
  12. TexasLabRat's Avatar
    Hey all. Thanks for your replies. I wanted to post an update.

    It seems like the problem is our condo is a coverage dead zone. When we left the condo today, our service gradually returned as we reached the street.

    If that's the case, we don't have many options - we may have to switch to AT&T. Practically speaking, what would be the differences (aside from AT&T being more expensive)? Would I have all the same features (e.g. WIFI calling, Visual Voicemail, etc.) between T-Mobile and AT&T?

    Speaking of WIFI-calling, is this something I could enable with T-Mobile? Theoretically speaking, that would solve the problem of the coverage dead zone in my condo, since we do have WIFI in our condo. But how would we go about setting that up?
    call them (from the street, I suppose) and request a new LTE cell spot. It plugs into your internet connection and is effectively a miniature t-mobile cell tower. I have one..it works great.

    https://support.t-mobile.com/communi...g-lte-cellspot
    maestromato and jmajid like this.
    11-28-2015 07:45 PM
  13. maestromato's Avatar
    Unfortunately, TexasLabRat has stated your only option other than switching carriers!
    TexasLabRat likes this.
    11-28-2015 11:01 PM
  14. Bartdog's Avatar
    I'm having ZERO luck getting a data or MMS signal to work with ATT.
    12-01-2015 07:38 PM

Similar Threads

  1. Win 10 mobile on 950xl live tiles not working as in 8.1
    By brettpfleiger in forum Ask a Question
    Replies: 1
    Last Post: 12-20-2015, 02:16 PM
  2. Win 10 mobile live tiles vs win phone 8.1
    By brettpfleiger in forum Windows 10 Mobile
    Replies: 9
    Last Post: 12-13-2015, 08:12 AM
  3. Replies: 0
    Last Post: 11-28-2015, 02:32 AM
  4. Replies: 0
    Last Post: 11-28-2015, 01:24 AM
  5. Random reboot on windows 10 mobile build 10586
    By nufcfanatic in forum Windows 10 Mobile Insider Preview
    Replies: 1
    Last Post: 11-27-2015, 11:58 PM
LINK TO POST COPIED TO CLIPBOARD