1. don4law's Avatar
    My new Lumia 950xl keeps dropping my wifi connection. I have numerous devices on the same wifi network, including an iPad and none of them have the same issues. Is anyone else experiencing dropped wifi connections with their new phone?
    11-29-2015 06:09 PM
  2. Oscart#WP's Avatar
    For the second time in the ~4 days I've had it, my 950XL has decided to disconnect from my (and not see it or any other) wifi network even thought wifi is turned on. Haven't figured out anything short of a restart to get it to work again... :/ Hopefully it doesn't become a regular thing!
    11-29-2015 08:46 PM
  3. n7slc's Avatar
    It's not limited to the XL. My 950 has been dropping WiFi as well.
    11-29-2015 09:14 PM
  4. DeathMoJo's Avatar
    No issues here for 5 days, might be a production defect. I'd request a replacement.
    11-29-2015 09:19 PM
  5. don4law's Avatar
    I've just about had it too. I do think it might have something to do with either Bluetooth or Fitbit as it seems that it gets disconnected whoever I try to sync up my FitBit. I haven't tried any other Bluetooth devices, but this to be a consistent issue with the FitBit. I am at my wits end with this new phone. My Lumia 640 was working flawlessly on all levels.
    11-30-2015 12:22 PM
  6. don4law's Avatar
    It also seems that the only way to get wifi reconnected after it disconnects is to restart. This is totally unacceptable.
    11-30-2015 12:25 PM
  7. Babs75's Avatar
    Only problem I've had is here at work in the building. Dropped off several times this morning. And it was a problem on my old Android phone too to the point where I would just go to 4G. We have a number of wifi networks available so I changed about an hour ago and not having issues. Other than that, working great at home.
    11-30-2015 01:30 PM
  8. don4law's Avatar
    UPDATE: it turns out this was probably not a phone issue, but rather a wifi issue. We have a dual band wifi router and one band for 2.4 GHz was not connecting to the network. So, it was only connecting to the alternate and when it dropped from that network it was not able to reconnect. It looks like the wifi has been stable since I recognized and repaired this issue. I'll provide another update if I have more problems.
    11-30-2015 05:26 PM
  9. CaptainLumia's Avatar
    I've heard of this happening solely with people using 5 GHz routers, is this the experience of everyone else? I too, have this issue at home. I think I'll switch to my 2.4 and see if that fixes it. I was on vacation all weekend with my phone and it stayed connected very well to the poor free wi-fi at the hotel. I have a horrible time at work with wi-fi, but that's par for the course here.
    11-30-2015 05:30 PM
  10. Thorgal Aegirsson's Avatar
    Lumia 950XL has serious issues with 5GHz ac wifi. It causes some devices (like mine) to randomly reboot. I also noticed disconnects from wifi. If, for some reason, your wifi loses internet connectivity Lumia will automatically switch to LTE/4G and frequently will not come back to wifi, until restart.

    I noticed that Windows 10 in general has a lot of problems with wifi. All of my devices (HP laptop, HP tablet, Surface Pro2) have all sorts of issues with wifi. The worst being the tablet - after going to sleep it will not recognize the wireless adapter at all. So, I think this problem might be more general than just our Lumias.
    11-30-2015 09:22 PM
  11. Noob1ee's Avatar
    Yep, I have WiFi issues with my 950XL as well.
    11-30-2015 11:44 PM
  12. christophersw1's Avatar
    My Lumia 950 drops all wifi connections every 6-8 hours. Without warning (or notice), the Wifi settings will show no networks found. Turning wifi on and off has no impact. Rebooting the Lumia instantly fixes the problem (for a few hours...). I travelled with the phone over the holidays, and experienced the same problem on 3 separate networks (two of them dual band, one a single band old-school 802.11b network).

    This is a major problem ...
    12-02-2015 10:52 AM
  13. CaptainLumia's Avatar
    I added both my 5 and 2.4 networks to my phone, I use my 5 as primary. Last night, it dropped the 5, but connected to my 2.4 immediately.

    Ideal? No. But at least it keeps me from losing total connectivity without noticing it.
    12-04-2015 05:37 PM
  14. winboy's Avatar
    I have the same problem with my dual band Netgear AC router and XL. So is there any solution???
    12-14-2015 07:30 AM
  15. wpctrlfan's Avatar
    I am using AVM FritzBox and haven't had a single Wifi problem yet. Connecting only via 2.4 GHz.
    12-14-2015 05:02 PM
  16. Petlaw99's Avatar
    I have just started having this problem with my 950XL. The Wifi (2.4G) drops. When I reconnect it quite often connects again but says "no internet". A soft reset sometimes fixes the problem. Every other device on the network (iPad, TV, Android phone) is rock solid so I doubt it is a problem with the router. I'm using the .29 firmware. Judging by the volume of posts this is an issue (one of the many) with this phone.
    01-08-2016 03:26 PM
  17. Mad Cabbie's Avatar
    Causes an issue for 930 and 950. As far as I can tell, it's down to the dual band router in my house. If I have to restart the router we have all sorts of issues. It does pick the two bands up, and after a soft reset, all seems well again.
    01-08-2016 03:35 PM
  18. Z80_Man's Avatar
    Try turning Bluetooth off...
    04-26-2016 08:05 AM

Similar Threads

  1. Por qu se prende y apaga solo mi telfono Lumia 520 de Nokia?
    By Windows Central Question in forum Nokia Lumia 520
    Replies: 4
    Last Post: 11-29-2015, 08:57 PM
  2. Beats Studio wireless headphone pairing with Lumia 950 XL
    By rdubmu in forum Microsoft Lumia 950 XL
    Replies: 1
    Last Post: 11-29-2015, 04:26 PM
  3. Lumia 640 - Display problems?
    By Windows Central Question in forum Microsoft Lumia 640
    Replies: 1
    Last Post: 11-29-2015, 03:41 PM
  4. Replies: 0
    Last Post: 11-29-2015, 03:11 PM
LINK TO POST COPIED TO CLIPBOARD