1. Jon_Rubinstein's Avatar
    Ok...MS was wrong...it does work....
    Last edited by Jon_Rubinstein; 12-01-2015 at 01:54 AM. Reason: correcting
    11-30-2015 04:14 PM
  2. Dzik's Avatar
    I had no problem getting my Band 2 working with my new 950XL.
    11-30-2015 04:15 PM
  3. Uncled1023's Avatar
    I was able to pair my Band 2 just fine with my 950 XL. It works better than when it was paired with my 1520 actually.

    Did you do a factory reset on the band if it was paired with another device before? You can only pair it to another device after a reset.
    Hans Swolfs and aximtreo like this.
    11-30-2015 04:17 PM
  4. Hans Swolfs's Avatar
    Same here... Needed factory reset indeed but no issues afterwards...
    11-30-2015 04:19 PM
  5. feereless's Avatar
    also might have to go to health and do "unregister band"
    11-30-2015 04:19 PM
  6. Roman Royter's Avatar
    My band 2 works flawlessly with 950XL. I didn't even have to factory reset anything. Just pair to 950XL and when prompted if pairing an iphone, say no.
    Kevin Schaefer likes this.
    11-30-2015 04:20 PM
  7. PhilWitt's Avatar
    Just to save people some time and energy, here are a couple of links that are discussing the same topic:
    http://answers.microsoft.com/en-us/b...f-f592165e3da0
    http://forums.windowscentral.com/mic...950xl-yet.html

    If people are having Bluetooth pairing issues this can be resolved but if you are having the 'oops' error after hitting finish in the Microsoft Health app this doesn't have a solution as of yet.
    11-30-2015 04:23 PM
  8. muness's Avatar
    Works great here too.
    11-30-2015 04:29 PM
  9. snakebitten's Avatar
    Ummmm, actually the Band 2, Microsoft Health, Fanband, and Wall Paper Studio 10, are a marriage made in heaven on the 950XL. It's actually one of the great success stories of the much-battered new W10M 9fiddies. :)
    11-30-2015 04:56 PM
  10. Mark Kaplan's Avatar
    No problems here. Did a reset on my band 2 and easily added to my new 950 XL
    11-30-2015 04:59 PM
  11. 206Husky's Avatar
    Not to pile on.... but works for me too.
    11-30-2015 06:32 PM
  12. Juan Stevens's Avatar
    lol. I just think some people don't do research before they post. smh.
    11-30-2015 07:02 PM
  13. Witness's Avatar
    I had an issue with my Band 1 not quite working. I get notifications and it syncs just fine, but trying to reply or use Cortana was not possible. It even showed that it wasn't connected in Bluetooth status. Reset both devices, but that didn't help. Put the Band in discovery mode and connect, but that did't work. I started the sync process and went back tapping on BT status for it to connect and it worked. It works fine now.

    Anyways, buggy.
    11-30-2015 07:08 PM
  14. Ken1ceo's Avatar
    I didn't have an issue syncing my Band 2. A few things to point out. 1) The Microsoft App needs to be reset. You'll need to forget the band and go through the setup again from the beginning. 2) I'm taking part of the insider program, but the OS version is the same as the factory release version. However, there may be something in the developer preview download that could be allowing the band to sync. 3) It may be a good idea to also reset the band to factory settings. Good Luck.
    11-30-2015 09:22 PM
  15. HarleyBigDog's Avatar
    For those of you hoping to get your Band 2 to work with your 950 XL,think again....

    Spent time with MS on the phone today and they said that the 950XL is not yet supported! OMG
    Also they cant tell us when it is going to be supported....

    Is this some sort of a joke? MS needs to either come out and say they dont give a damn about this new phone so that we can move on, or go ahead and support your OWN PRODUCTS!!! How hard is it?

    I hate IOS and Android....but I'm afraid I'm starting to lose my patience after 5 years......
    I had issues with my Band 1, and posted a fix on the forum, but can't post links yet, so I will post the Title and repost the link here, in the hopes that it will work for Band 2 as well.

    Microsoft Band 1 sync issues with 950XL

    I was having issues with my Microsoft Band 1 and the 950XL I just got. It worked from the Band to the phone, but not the other way. I was not getting the nice txt and email messages, couldn't reply to txt with Cortana, nothing. So I unregistered my band, removed the MS Health App, restored my band, turned it back on, reinstalled the app, and it saw my Band right away, but wouldn't pair. And I couldn't get the Band to "reset" again, and thought I was screwed. I got on the Band Chat Support, and talked to someone who tried their best, but just said I had to reset the phone, or I could go into a MS Store and get a new Band.

    I was about to take them up on the offer, but thought, while I was waiting for them to get back to me, that I would check my Bluetooth connections, to make sure it was turned on and such. And there, I saw the Band was there, paired. So, I removed that from my saved Bluetooth devices, went back into Health to Add Device, and there it was, a new icon, and it then SEARCHED for my device, found it, and set everything up great. Now everything goes back and forth, I can reply via Cortana to txts, but for some reason, I can't initiate the txt from my Band. I can only reply to them. But, maybe that gets fixed later. Not that big a concern for me.

    So, if you are finding that you are having issues with your Band 1 or probably Band 2, give this a try and see if it helps you too. I hope it does.
    11-30-2015 09:43 PM
  16. woodie5's Avatar
    Works perfect for me. No issues what so ever. Make sure you do a factory reset.
    11-30-2015 09:51 PM
  17. kwill's Avatar
    Is anyone having issues replying to text or getting anything to initiate using Cortana? When I try to reply to text I get message that says "Make sure Bluetooth is on and your phone is close by". I've already tried resetting the Band, unpairing from phone and the Microsoft Health app. Kind of annoying as I just lost my entire days worth of data trying to fix it.
    12-03-2015 12:10 AM
  18. nokia4life's Avatar
    My band 2 is working as well paired just fine after registration of the new band and unregistering the old one.
    12-03-2015 12:47 AM
  19. mwgeek's Avatar
    I have the same reply issues kwill
    12-03-2015 12:53 AM
  20. kwill's Avatar
    Yep, looks like that did it. Had to unregister it from my 1520. Then set it up again on my 950 XL. Finally let me respond using Cortana.
    12-03-2015 01:15 AM

Similar Threads

  1. My experience with preview build 10586 on Lumia 928
    By HTC13 in forum Windows 10 Mobile Insider Preview
    Replies: 6
    Last Post: 12-02-2015, 12:43 PM
  2. Replies: 2
    Last Post: 12-01-2015, 01:46 PM
  3. What is your use case for the display dock?
    By kiteless in forum Microsoft Lumia 950 XL
    Replies: 5
    Last Post: 11-30-2015, 07:19 PM
  4. Replies: 1
    Last Post: 11-30-2015, 03:47 PM
  5. Couple of issues with my 950
    By tboling in forum Windows 10 Mobile
    Replies: 0
    Last Post: 11-30-2015, 02:39 PM
LINK TO POST COPIED TO CLIPBOARD