1. A54D's Avatar
    Just wanted to know if others are having the battery drain issues on the official release of the .29 update?

    I have got it and I'm using the Lumia 950XL. Battery was so good before. Now it drains a lot faster.
    12-08-2015 07:48 PM
  2. Xsled's Avatar
    Mine showed a drain while plugged in to the continuum dock and I just dropped a percent while on standard charger. Earlier today after the update, it showed 100% when I knew it shouldn't have been. So, right now my assumption is that the battery is calibrating. Hope to see a difference by this time tomorrow. At least not dramatically draining, especially while charging.

    Edit: Sitting here watching it, it continues to go to 100% then back to 98% while charging. I am sticking with my original thought right now. Calibrating.
    Last edited by Xsled; 12-08-2015 at 08:06 PM.
    12-08-2015 07:52 PM
  3. A54D's Avatar
    Mine showed a drain while plugged in to the continuum dock and I just dropped a percent while on standard charger. Earlier today after the update, it showed 100% when I knew it shouldn't have been. So, right now my assumption is that the battery is calibrating. Hope to see a difference by this time tomorrow. At least not dramatically draining, especially while charging.

    Edit: Sitting here watching it, it continues to go to 100% then back to 98% while charging. I am sticking with my original thought right now. Calibrating.
    I'm with you on that, could be a calibrating issue. I haven't received my dock yet so can't confirm anything in that regard.

    I guess only time will tell. I'll keep this thread updated on anything I find.
    12-08-2015 08:28 PM
  4. Xsled's Avatar
    Seems much better today. Pulled off the charger at 7cst and sitting at 72% right now. Did a conference call, read some news, updated star wars, bunch of messaging, some emails came in. So, moderate use and it isn't doing bad.

    Same with my work one. Pulled off about the same time, looked at calendar a few times, bunch of emails and a few calls and it is at 91%.

    Personal device shows 11 hours left at 72% and work one shows 1 day 9 hours at 91%. (I have a lot more going on it the background than my work one)

    So, not much difference in the builds from what I can tell. Too early to get a great gauge though.

    Edit: To be clear, both are 950s.
    12-09-2015 12:22 PM
  5. A54D's Avatar
    Well I did a hard reset and that seems to have done the trick! The battery lasted me over 12 hours, easy!

    I hope it stays like this.
    12-12-2015 03:20 PM
  6. Tim Maggi's Avatar
    Any word on the battery issue? Ive hard reset mine and it is still draining like crazy. I cannot get build .29 installed. it wont freaking download! sits at 0% saying its downloading.
    12-17-2015 07:42 AM
  7. R3mis's Avatar
    I can confirm the battery issue. Sometimes I have to charge my Lumia 930 twice a day, depends on te usage. The phone also heats up a little just from regular use, I don't do any crazy multitasking or run any games.

    I've had these issues since 10586.11. The battery was great with the the previous build (10581).

    Can't wait for the official (non-insider) W10M update!
    12-17-2015 07:53 AM
  8. A54D's Avatar
    Apparently the new update, .36, fixes the battery issue. Available to fast and slow ring.
    12-18-2015 07:32 AM
  9. VegaNovus's Avatar
    I need to find out why I'm not getting the .36 update and/or go for a hard reset.

    http://forums.windowscentral.com/mic...-my-950xl.html
    12-18-2015 07:48 AM
  10. slysy's Avatar
    I need to find out why I'm not getting the .36 update and/or go for a hard reset.

    http://forums.windowscentral.com/mic...-my-950xl.html
    Are you signed up for the preview? It's only available on preview, not officially yet
    12-18-2015 07:50 AM
  11. VegaNovus's Avatar
    Are you signed up for the preview? It's only available on preview, not officially yet
    Indeed I am, fast ring.
    12-18-2015 12:53 PM
  12. Rose640's Avatar
    Battery life is so much better on .36 than on .00 .
    Though i'm not on the 950 but on 640.
    Last edited by Rose640; 12-19-2015 at 06:01 AM.
    12-18-2015 12:56 PM
  13. Wookieekiller's Avatar
    My battery idle time is great on .29 but it drains fast while using it (950 XL). On my 640 though my battery life is amazing, much better then on my 950 XL. How can this be?
    12-19-2015 03:00 AM
  14. Charles Brown8's Avatar
    I'd hazard a guess...

    *950xl 8core high performance soc qhd 5.7" screen
    *640 4core mid performance soc 720p 5" screen

    Takes alot of juice to run high end specs even if the OS is perfect.

    This would be kinda like comparing my icon to a Lumia 520 far as battery usage. Lol.
    12-19-2015 03:40 AM
  15. Wookieekiller's Avatar
    what about the 1520? I hear that gets amazing battery life and yet that's a huge screen and higher end specs right? I would expect them to at least get similar battery life considering the battery in the 950 XL is so much larger then the 640.
    12-19-2015 03:55 AM
  16. Charles Brown8's Avatar
    1520 has the same Soc "snapdragon 800 4core" as my icon with a way higher capacity battery than the icon / 930 yup the 1520 does have a 6" screen verses the 930 / icons 5" but they are both 1080p screens.. The larger battery of the 1520 really shines when compared to the icon / 930. If Verizon had offered the 1520 I would have it instead of the icon just for that battery, the 6" screen is icing on the cake ;)
    12-19-2015 04:03 AM
  17. Abdullah Sulman's Avatar
    Fix the brightness toggle ... Low brightness setting gives u max brightness... And their should be option to set brightness even lower than low setting manually like in battery saver mode..
    12-19-2015 04:10 AM
  18. Charles Brown8's Avatar
    Fix the brightness toggle ... Low brightness setting gives u max brightness... And their should be option to set brightness even lower than low setting manually like in battery saver mode..
    Had that brightness issue along with a few others on .36..

    What's weird is I rolled back to 8.1 denim on my icon yesterday morning and then did the upgrades .29 then .36 without a hard reset.. Screen settings work right, even auto brightness.. Wonder why it quits working on a hard reset or as I understand oem install on the 950s?
    12-19-2015 04:18 AM
  19. Abdullah Sulman's Avatar
    I actually checked battery usage in settings ... And was surprised to find that system is using mare battery than screen.. Which is pretty odd .... Since screen is the biggest battery hog by miles .. Something is not right with system processes
    12-19-2015 11:53 PM

Similar Threads

  1. Help with picking new laptop
    By arjan wolthuis in forum General Tablet & Laptop Discussion
    Replies: 4
    Last Post: 01-13-2016, 06:25 PM
  2. Has Hey Cortana on ATT been fixed with this new build?
    By Windows Central Question in forum Cortana
    Replies: 0
    Last Post: 12-08-2015, 06:08 PM
  3. We chat with 10tons about its upcoming Windows 10 and Xbox One game Baseball Riot
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-08-2015, 05:20 PM
  4. Email on Windows 10 not updating
    By pedmar007 in forum Windows 10
    Replies: 0
    Last Post: 12-08-2015, 05:09 PM
LINK TO POST COPIED TO CLIPBOARD