1. TC_808's Avatar
    I've been using a 950 XL since early December and have been experiencing spotty performance with receiving App notifications. After performing 2 hard resets (one in particular to solve the Outlook email image problem), my 950 XL has been performing well except with failure to receive notifications from apps which are all set ON for background use. These include the MSN News, Sports, and Money apps, as well as other apps such as CNN, ESPN, ABC NEWS, NBC NEWS. Fortunately, Outlook mail and calendar notifications work fine and IM apps such as Telegram and WhatsApp seem to work on occasion (with some delays), but Skype rarely works.

    But after I do a soft reset, a flood of notifications from the aforementioned apps will normally come through. Notifications will continue to work for up to about an hour, then nothing until after I do another soft reset. The same thing then happens and notifications start to come through. I have Bluetooth enabled and paired with my Vector watch and Band 1, and notifications work perfect for them. I've tried turning off Bluetooth, but this did not solve my problem with receiving notifications. I just received the most recent firmware update 2 days ago and I'm currently on build .29.

    Any suggestions for this problem? (I prefer not to do my 3rd hard reset!).
    01-09-2016 08:55 AM
  2. TC_808's Avatar
    Anyone have suggestions? Anyone experiencing the same or any problems with app notifications on their dual sim 950 XL?
    01-10-2016 08:23 PM
  3. TC_808's Avatar
    Is no one else having the same problems? I just updated to the latest build 10586.107, and still don't always get notifications unless I reset phone.
    02-19-2016 11:25 PM
  4. final_fantasy781's Avatar
    Do you have them turned off in the background, as far as those apps go? Is your phone connected to internet?

    I have noticed some notification bottleneck on my XL, but it sometimes stems from my internet at home going out. If my phone connects to Xfinity, things just stop working.
    02-20-2016 07:12 AM
  5. Babs75's Avatar
    Yes, I got the new OS 2 days ago and I noticed this yesterday. I did a soft reset and it seemed to fix, although I continue to get notifications for emails I have deleted. Maybe I'll do another soft reset today.
    02-20-2016 08:53 AM
  6. TC_808's Avatar
    Notifications work after I soft reset (CNN, MSN News, ESPN, etc.). Then for the next few hours, I won't get any until I soft reset. Mail notifications constantly work, but others seem to bottleneck. Yes, they are all on as background apps. This happens whether I'm connected to my home wifi or cell data.
    02-20-2016 10:55 AM
  7. Dieter Felix's Avatar
    I have the same behaviour on my Lumia 950DS,,version .107, after restarting it Works for some time, then notifications stuck 😒
    02-20-2016 11:59 AM
  8. Ryujingt3's Avatar
    I thought this was just me but I seem to get it too. 950XL, single SIM, Thailand, latest 14xxx OS version.
    02-21-2016 02:29 AM
  9. white90box's Avatar
    I am having this problem. I also have a vector watch. I emailed vector support about it and they said they couldn't duplicate the issue. They promised to forward my email to the windows development team. Please email them and tell them you have the same problem. I am convinced it is my watch and I am going to disconnect it for a few days and see if it helps.
    03-20-2016 06:25 PM
  10. M4cc45's Avatar
    Same - I've actually switched phones because of it. I noticed in the latest release notes that they say they've done work on the notification system to make it more reliable but I've not tested yet. It's basically a device killer for me as I am reliant upon my messages (as anyone is with a smart phone) so if they're not coming through consistently then I can't use it. I used to also have the WhatsApp resuming error whereby it would try and resume for about 30 seconds then go to the desktop and then, once relaoded, it would work for a bit - again I'm not sure if that's been fixed in the latest version of the app or OS.
    03-21-2016 10:42 AM
  11. TC_808's Avatar
    So for those who are having the same notifications problem and have a paired Vector Watch, were you able to figure out if pairing with the watch was causing notifications to bottleneck? After 5 months with my 950 xl, I exchanged it with a new one last week. Some problems (restarts, resuming..., freezing) were solved and there was some improvement, but after a few days the bottleneck notifications came back!
    04-12-2016 07:26 PM

Similar Threads

  1. Not receiving build 10586.63?
    By Richard Atkinson1 in forum Windows 10 Mobile Insider Preview
    Replies: 3
    Last Post: 01-12-2016, 12:02 PM
  2. Windows 10 Not Activating.
    By Bagzton in forum Windows 10
    Replies: 4
    Last Post: 01-10-2016, 03:37 PM
  3. How do I reinstall a native app on windows 10 mobile?
    By Windows Central Question in forum Ask a Question
    Replies: 4
    Last Post: 01-09-2016, 04:39 PM
  4. people contacts not downloading adter reset
    By Boysie1 in forum General Phone Discussion
    Replies: 0
    Last Post: 01-09-2016, 07:29 AM
  5. Telephone app does not open on Lumia 1520
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 01-09-2016, 06:26 AM
LINK TO POST COPIED TO CLIPBOARD