1. Windows Central Question's Avatar
    I have a 950XL Dual SIM and for whatever reason, continuum on it will not drive my Display Dock and never activates the external screen, yet it works fine via my Wireless Display Adapter.

    1. Does anyone else have a 950XL Dual SIM actually working with their Display Dock?
    2. If so, what is your firmware & OS version combination.

    By way of clarification, i took my 950 & dock into some friendly local MS locals and proved my dock worked with their phones, but my phone would not work with any dock.

    My phone is still on:

    01078.00027.15506.02005 firmware

    Using OS Build:

    10.0.14267.1004

    I did a hard reset before the previous build and i'm still in the fast ring. WDRT reports no newer firmware for my phone.

    I did originally think the dock was faulty but now i'm leaning towards the phone firmware, so i'm wondering if other people with the same hardware & firmware combination have this issue at all?
    02-25-2016 04:44 AM
  2. Phatapteryx's Avatar
    Thanks for the suggestions - i'm now on firmware 01078.00038.16025.39005 but this still doesn't work :( With regards to the suggestion my display dock might be faulty, i had another 950 owner try and his could drive my dock fine.... Grrrrh - This is so infuriating
  3. IamJonso's Avatar
    Same thing happened to me. To fix the issue, I unplugged then re-plugged everything.

    Edit: I have the same firmware version as you, but am on OS build 10.0.10586.107
    Last edited by IamJonso; 02-25-2016 at 05:23 AM.
    02-25-2016 04:51 AM
  4. Phatapteryx's Avatar
    Thanks - I have plugged & unplugged numerous times, in every possible order with no change - eventually i was in a room that had 3 docks - none of which worked on my phone, but worked for the other two phones - the difference being my phone was dual-sim and on older firmware... guess i may have to reflash
    02-25-2016 01:13 PM
  5. NokianWP's Avatar
    Dual sim here too. Mine is working on .107.


    It automatically connects and launches after I plug it into the dock. Maybe you have a faulty display dock?
    02-25-2016 01:50 PM
  6. Phatapteryx's Avatar
    Thanks for the suggestions - i'm now on firmware 01078.00038.16025.39005 but this still doesn't work :( With regards to the suggestion my display dock might be faulty, i had another 950 owner try and his could drive my dock fine.... Grrrrh - This is so infuriating
    ven07 likes this.
    02-27-2016 06:23 PM
  7. PepperdotNet's Avatar
    Sounds like you got a phone with defective hardware.
    ven07 likes this.
    02-27-2016 10:33 PM

Similar Threads

  1. Problems with Headphone Socket [Lumia 950XL]
    By stuffedhaggis in forum Microsoft Lumia 950 XL
    Replies: 9
    Last Post: 09-19-2016, 01:23 PM
  2. How was 14267.1004 on 950xl ?
    By Ariman Amin in forum Windows 10 Mobile Insider Preview
    Replies: 83
    Last Post: 03-21-2016, 06:39 PM
  3. Why does my Lumia 730 display look like the color has been washed away?
    By Windows Central Question in forum Nokia Lumia 730 & 735
    Replies: 2
    Last Post: 02-29-2016, 05:41 AM
  4. [L950XL] I can not access setup?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-25-2016, 03:08 AM
  5. When will Windows 10 for the Lumia 625 be available in Egypt?
    By Abdelhakeem Abdallah in forum Windows 10 Mobile
    Replies: 1
    Last Post: 02-25-2016, 01:59 AM
LINK TO POST COPIED TO CLIPBOARD