03-25-2017 04:34 PM
29 12
tools
  1. Sunstorming's Avatar
    Hey everyone,

    Has anyone figured out how to get around the hotspot issue when using AT&T GoPhone? I have had two 950XL's and neither of them work for mobile data on AT&T GoPhone. I get a message stating that I don't have a data plan when attempting to tether. However, data on the phone is working fine and can connect to Netflix, Amazon, etc. I tried even changing the DNS numbers in the network adapter when connected on the PC end.

    Also, it *DOES* work as a mobile hotspot if on a different network such as Straight Talk.

    Any ideas?
    03-06-2016 10:16 AM
  2. GaborR's Avatar
    Your phone reports your carrier tethering is on. Than the carrier disables it. Exactly this behavior pushed me back to Android. There you can at least fix it:

    Non rooted phone:
    This can be fixed permanently using the following procedure (UPDATE: no root required):
    1.Enable developer mode (Go to Settings -> About phone, and click on the build number until the developer mode is enabled).
    2.Enable USB debugging under Settings -> Developer options
    3.Connect the device with a USB cable to a computer with the Android SDK platform tools installed
    4.Start an adb shell: adb shell
    5.In the adb shell, run this command: settings put global tether_dun_required 0

    I would love to know how to access such registry switch in WM10. Should be under the owner's control what the phone does with the outside world.
    03-20-2016 08:33 AM
  3. FXi2's Avatar
    Tethering is a feature which is either added for a cost or included in certain premium data plans. You can ask the provider how to go about adding it but it may increase your fees. Some plans include it so whether it costs more or not is uncertain.
    fpostrow likes this.
    03-21-2016 12:06 PM
  4. TechAbstract's Avatar
    Had same issue before. Gophone plan didn't work for me. I switched to AT&T regular non- contract monthly plan. Working good so far with tethering. Stay away from GoPhone plan.
    fpostrow likes this.
    03-21-2016 12:13 PM
  5. MezTemplar's Avatar
    I have exact same problem. I called AT&T twice and they said it's my handset even though I get "AT&T Free Msg: It looks like you want to use data but have none available." on my connected devices. I went to the store and they...
    1. Gave me a new GoPhone SIM -no change
    2. Put the SIM from the AT&T Lumia 950 demo unit in my phone -Mobile hotspot worked
    3. Put my GoPhone SIM in the Lumia 950 demo unit -Mobile hotspot worked

    So the conclusion was that there is some issue specifically with the Lumia 950 XLs (unlocked) and GoPhone SIMs. Now I either switch to AT&T or harass the people at the Microsoft Store.
    Joe920 likes this.
    03-23-2016 10:17 AM
  6. rory753's Avatar
    I have tmobile, and use tethering daily with my unlocked lumia 950 xl and surface 3. I've never had an issue maintaining a connection, and this sounds like an issue more with at&t then the 950xl.

    the only bug i see is on the computer side, when i click on the hot spot(which turns the hot spot on from my phone) in the wifi menu. it doesn't automatically show it as on, but if i go away from the wifi dialog box, it shows it connected. it doesn't affect my use, and i get my connection anyway without having to touch my phone, but its a little bit of an annoyance.
    03-25-2016 05:01 PM
  7. rory753's Avatar
    So the conclusion was that there is some issue specifically with the Lumia 950 XLs (unlocked) and GoPhone SIMs. Now I either switch to AT&T or harass the people at the Microsoft Store.
    before going straight to at&t, consider tmobile... their coverage has gotten a lot better in recent years.
    03-25-2016 05:21 PM
  8. imbushuo Wang's Avatar
    Okay I figured out how to enable it on GoPhone.

    1. Download the latest Interop Tools for Windows 10 Mobile. Find it in Settings > Extras.
    2. Open registry browser, go to: HKEY_LOCAL_MACHINE\System\ControlSet001\Services\ICSSVC\Settings
    3. Set EntitlementRequired to 0
    4. Clear DedicatedConnections (Remove any strings in it and save).
    5. Reboot your phone.
    6. It works
    daimv and ajj3085 like this.
    05-11-2016 11:34 PM
  9. admorris#AC's Avatar
    before going straight to at&t, consider tmobile... their coverage has gotten a lot better in recent years.
    There is no comparison between att and T-Mobile...T-Mobile still sucks. They are great with advertising, but their network is 3rd rate at best. Cricket Wireless unlimited everything is actually the best deal going right now by a country mile.
    groady-ho baluzy likes this.
    05-14-2016 09:26 PM
  10. PGrey's Avatar
    Originally posted by admorris#AC
    Originally Posted by rory753
    before going straight to at&t, consider tmobile... their coverage has gotten a lot better in recent years.
    There is no comparison between att and T-Mobile...T-Mobile still sucks. They are great with advertising, but their network is 3rd rate at best. Cricket Wireless unlimited everything is actually the best deal going right now by a country mile.
    I had a similar experience recently. I wouldn't go so far as to say they "suck", but they still don't compare to AT&T, if you go outside of metro. If you're mostly in-metro, they're crazy fast, at least in the greater-Seattle area.
    The sad thing was, I went not that far from their headquarters last weekend, and my attempt to tether and work while my wife was driving was a joke, and not a good one. We switched back, I'm going to be with AT&T a good while again (20 years previous), until I see pretty much a full LTE blanket on our state, at least.
    I had coverage, briefly, on roaming, until I hit 200MB, and that was it, nothing the CS people could do for me, even though I was "in theory" inside of their map data, their reply was something about "new towers" and maybe it wasn't quite accurate. Frustrating.
    I REALLY liked their feature set, for the brief time, being able to run speed tests to find good locates, my daughter could stream music whenever, all good stuff, if you're metro, or maybe farther out east...

    Cool Reg find on the tethering, that's appreciated. I may get a TMo prepaid SIM for Canada still, and this tip could come in handy.
    barotropic likes this.
    05-15-2016 01:37 AM
  11. rory753's Avatar
    There is no comparison between att and T-Mobile...T-Mobile still sucks...Cricket Wireless unlimited everything is actually the best deal going right now by a country mile.
    I'm not saying tmobile is better then at&t. but it has gotten much better in recent years with their expansion of the band 12 network. I'm in washington state, and within most cities, i get good coverage. then, when i go to canada or mexico, i have good coverage their as well, without having to worry about fooling with my plan.

    What burned me about at&t is the elimination of their unlimited plan, and then charging people for the ability to tether a phone to a tablet/pc. yes, they have the sharing plan, but there should be no clauses or anything surrounding tethering. just enable the ability to do it. So yes, i take slightly worse coverage for the 5% of time I'm out of the City for better services when I'm in the City 95% of the time.
    05-16-2016 12:06 PM
  12. rory753's Avatar
    ...
    The sad thing was, I went not that far from their headquarters last weekend, and my attempt to tether and work while my wife was driving was a joke, and not a good one. We switched back, I'm going to be with AT&T a good while again (20 years previous), until I see pretty much a full LTE blanket on our state, at least.
    ...
    this is why at one point I had a pay as you go verizon lumia 2520 tablet to supplement my tmobile phone. with that, i could set it up as a hotspot and have better coverage then what even AT&T offers. It's somewhat convoluted, but it worked. I've since gotten rid of the 2520 since it wasn't going to be update the way i expected, but i may sometime get another tablet that can share data. i am interested HP's envy note 8, but i don't like that its locked only to verizon.
    05-16-2016 12:16 PM
  13. PGrey's Avatar
    Yeah, I drive to Wenatchee at LOT during the winter, for skiing, and often I'm working away while my wife's driving. This was never a problem with AT&T, but recently on our trip over, as soon as I got halfway up I-90 to Snoq. Pass, my signal got intermittent, at-best. This is what, maybe 25-30mi from TMo headquarters?
    Anyway, that continued, with some intermittent *complete* loss of service along 90 until we turned in 97, when service disappeared completely. I switched to roaming, which got me a 2-3g-ish signal for a chunk of 97 (AT&T roaming). Then we started back the next day, and oops, I'd used my 200MB, I couldn't even call TMo until I was back just about onto I-90 (had to literally be about 1/2mi away, maybe even 1/4).
    I asked about resetting this somehow, but no-way, no-how, I was just "stuck" until the next billing period, REALLY?

    Then, on Saturday we were in Wenatchee and I was thinking about pedaling back over Blewett (bring my bike along), to get some solid climbing miles. It was warm, and my wife was desperately trying to find weather on her phone, and it took her 12-15 tries. I called TMo, and they said the network was saturated, and we should drop back to 4G, and oops, well, if our phone didn't support it because of their provisioning, well they could sell us a phone that did, that was their solution, again, REALLY? On LTE, I tested it, and we were getting about 0.08-0.12/0.03-0.12, over several tests, coverging maybe 15-20 minutes (my wife was a bit ticked, since we'd never had a problem like this before switching, and Wenatchee isn't exactly tiny, it had a TMo store, literally about 1mi from where I was testing).
    I get that mistakes are made, but I intentionally walked the route with the person about the plan, before we switched, and she swore up and down that her "latest" coverage map showed we'd be 95% set, with only a couple of brief drops into roaming, maybe for 5mi or so. I was ultra-specific as we added little towns to the route, and she checked her "updated" map, that I couldn't see. It really chaffed me when, in reality, I had coverage on *maybe* 50% of the route, and that's being generous.
    The other part that was particularly irritating was the 1/4-1/2mi to I-90 thing, I got back in the car along 90 to ride home, and sure enough, we should've had coverage, and that was without the "special" map.

    I agree, the TMo deal for Canada is a huge win, plus the streaming for the family, but I can't get excited about having to have a second plan, just for most of our winter weekends. Now ATT has the "okay" Canada deal, it will have to suffice for the time being.

    How did you do the Verizon thing? I'd do a second plan, if I could buy something where the plan didn't expire for say a year, the month-month thing is just a bad deal for us. Some months, we'd use most of the data, and others, not-so-much, it'd be a big throw-away. It's hard to pay for a *second* plan, to supplement ours, at a monthly cost. If I could buy a big block of data, and use it over some months, I'd be fine with that kind of supplementation.
    I really feel like TMo ought ot figure out how to make the roaming "just work" though, if they really expect to keep customers that are operating in/out of metro areas...
    05-16-2016 02:28 PM
  14. rory753's Avatar
    interesting. my experience with tmobile is I don't have full lte service from around the east side of lake kachess to around cle elum. in cle elum, i start picking up full lte(specifically at pioneer coffee). traveling over blewett pass, i don't have coverage, but i do get lte coverage in leavenworth and wenatchee. I also get coverage in ellensburg, mattawa, quincy, othello, and some other places. where i don't get coverage is kalaloch, or omak. but i'm rarely over that way anyway, so i'm not too worried about it. sometimes its nice to unplug.

    verizon use to offer(this is when the lumia 2520 came out, so what, 2 years ago?) a pay as you go plan. no contract, just basically month to month. I looked at hot spots, but the 2520 was virtually the same price as a hot spot, so i got that. they probably still offer something, but i'm not sure what it is. if you wanted a windows device with verizon capabilities built in, hp is offering their 8" tablet and their 12" tablet that has verizon lte. i'm not sure how good their build quality is, but it's an option. if you really hate yourself, you could simply get a 2520 off ebay for cheap, and then use that. personally, i liked the tablet, but it's windows rt, and a dead end OS.
    05-17-2016 10:52 AM
  15. addisonmedia's Avatar
    05-18-2016 01:12 PM
  16. slickfddi's Avatar
    This works. [InteropToolsApp_0.0.173.0_arm, Windows 10 v.10586.545 on AT&T "GoPhone" Lumia 640]. Load ALL the dependencies FIRST via the web based App Manager that's enabled via the "For Developers", then install InteropToolsApp.
    08-23-2016 08:28 AM
  17. rcranium's Avatar
    This works. [InteropToolsApp_0.0.173.0_arm, Windows 10 v.10586.545 on AT&T "GoPhone" Lumia 640]. Load ALL the dependencies FIRST via the web based App Manager that's enabled via the "For Developers", then install InteropToolsApp.
    I've loaded everything and interop won't install.
    08-30-2016 03:57 PM
  18. daimv's Avatar
    Originally posted by rcranium
    I've loaded everything and interop won't install.
    Check your settings -> extras menu
    08-30-2016 05:01 PM
  19. rcranium's Avatar
    Check your settings -> extras menu
    I already did. It's not there. It's not installing. I downloaded the additional dependency files and put them in the same directory. No joy.
    08-30-2016 05:05 PM
  20. JaimitoFrog's Avatar
    I've loaded everything and interop won't install.
    Save the file on a desktop, then email it as attachment. I then open the attachment on the phone.

    It worked for my unlocked 950XL on ATT GoPhone plan. I followed the instructions here step by step.
    interop tools for windows 10 mobile - WAREWIRE!
    09-14-2016 12:19 PM
  21. daimv's Avatar
    Apparently the new version no longer installs under settings, so just like a normal app. The dependencies have to be installed like another app, before interop tools. Also after installing the apo it might take a little while to show up.
    09-14-2016 07:13 PM
  22. Tonyn9503's Avatar
    Okay I figured out how to enable it on GoPhone.

    1. Download the latest Interop Tools for Windows 10 Mobile. Find it in Settings > Extras.
    2. Open registry browser, go to: HKEY_LOCAL_MACHINE\System\ControlSet001\Services\ICSSVC\Settings
    3. Set EntitlementRequired to 0
    4. Clear DedicatedConnections (Remove any strings in it and save).
    5. Reboot your phone.
    6. It works
    I did this and yes it did work. But, only for the first time. It stopped working; I checked on the settings and info was back on the two settings. I took it out and it came back on after I rebooted phone. Any suggestions?
    Joe920 likes this.
    02-26-2017 12:27 AM
  23. raiderfan247365's Avatar
    I've had ATT go phone for years and have never had a problem using mobile hotspot on any Windows Phone. Let me reminisce on the phones I've had real quick: HTC HD7, HTC Titan, Lumia 900, Lumia 820, Lumia 925, Lumia 1320, Lumia 1520 and now the 950 XL. Aahh, good times.
    02-26-2017 12:47 AM
  24. Joe920's Avatar
    I did this and yes it did work. But, only for the first time. It stopped working; I checked on the settings and info was back on the two settings. I took it out and it came back on after I rebooted phone. Any suggestions?
    Thanks for trying. It looks like the moment GoPhone's backend detects the Lumia 950XL it changes an account setting to 'don't tether'. It seems that this setting sticks at least for a bit, because I get the same message when trying to use my newish iPhone 6S+ on the same account. Bad ATT, bad!
    02-28-2017 12:39 PM
  25. raiderfan247365's Avatar
    Originally posted by Joe920
    Originally Posted by Tonyn9503
    I did this and yes it did work. But, only for the first time. It stopped working; I checked on the settings and info was back on the two settings. I took it out and it came back on after I rebooted phone. Any suggestions?
    Thanks for trying. It looks like the moment GoPhone's backend detects the Lumia 950XL it changes an account setting to 'don't tether'. It seems that this setting sticks at least for a bit, because I get the same message when trying to use my newish iPhone 6S+ on the same account. Bad ATT, bad!
    Do we know for sure that the problem is the GoPhone plan? I have a GoPhone plan and a Lumia 950 XL and have no issues using mobile hotspot.
    03-01-2017 06:56 PM
29 12

Similar Threads

  1. Replies: 3
    Last Post: 04-04-2016, 12:58 PM
  2. Instagram for Windows 10 Mobile reportedly revealed as iOS port
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 03-06-2016, 10:11 AM
  3. New Universal Instagram app for Windows demoed on video
    By ttsoldier in forum Windows 10 Mobile
    Replies: 0
    Last Post: 03-06-2016, 07:18 AM
  4. I've unfriended someone on FB, but their name still shows up in the sidebar?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 03-05-2016, 09:10 PM
  5. On my 521, I deleted the phone icon. Can someone help please.......?
    By Windows Central Question in forum Nokia Lumia 521
    Replies: 1
    Last Post: 03-05-2016, 09:04 PM
LINK TO POST COPIED TO CLIPBOARD