08-25-2016 09:42 PM
33 12
tools
  1. jjMustang's Avatar
    I updated my firmware OTA yesterday (July 26, 2016) and I'm also running the Anniversary update. My battery life today has been great! I haven't put the phone on a charger at all, and I'm still at 56% after 11 hours. I'm usually at 30% at this point. Has anyone else noticed an improvement? What is your typical battery life? I'm still trying to figure out if I have an app that's causing excessive drain, or if it's perhaps poor cell signal, or if it's the phone and/or OS.
    07-27-2016 04:49 PM
  2. zei20t's Avatar
    im getting better battery life also, especially playing music via BT from an SD card with a heap of music. for 40-60 mins of playing, it would munch 10% of battery. now, maybe 5% used by the time i get to work.
    jjMustang and Mesbah like this.
    07-27-2016 06:49 PM
  3. PJL99's Avatar
    I agree -- much better battery life. And the phone charges very quickly.
    Mesbah likes this.
    07-28-2016 01:20 PM
  4. PGrey's Avatar
    I'd say I'm about the same with the new FW, all the way since around .318, when it improved dramatically. for me.
    I maybe saw a slight bump with the FW update, but to be honest, I'm not sure I could measure the difference between .318 and the old FW, and RS1, and the new FW.
    My battery life is great though now, to be clear, compared to builds like .107, 218, etc. I'd say it's improved at least 50% since those, maybe a bit more.
    v535 and Mesbah like this.
    07-28-2016 01:30 PM
  5. PGrey's Avatar
    I agree -- much better battery life. And the phone charges very quickly.
    I think the charging indication is still buggy, to say the least.
    For example, I was maybe around 65% this AM, and put it down, and checked back maybe 30 minutes later, and I was at 72%.
    Then, about 10 minutes later, I was all the way at 100%. Clearly either I had an amazing boost (charging via a 1.5A Qi charging plate, so maybe getting 1.2A, if I had to guess), or something was wrong with one of the measurements, I sort of doubt it charged that last 28% in 10 minutes, call me "skeptical" ;-]

    -pete
    v535 and banjaboo like this.
    07-28-2016 01:33 PM
  6. realwarder's Avatar
    It is better but could still be much better.
    Mesbah likes this.
    07-29-2016 08:14 AM
  7. LarsCor's Avatar
    It looks like it improved, yes. Updated to anniversary day before yesterday. Normally, after day of use, battery is below 20%. Now it was in the 30-40 something.
    07-29-2016 08:22 AM
  8. hawwie_4's Avatar
    I'm on the latest firmware version but not anniversary yet and I think my battery life has actually gotten worse. I used to listen to music on my way to work and only lose 1% battery now I lose about 5% and my commute and usage has stayed the same. Any suggestions?
    07-31-2016 11:36 PM
  9. PGrey's Avatar
    Yeah, I was thinking of re-posting as well, and after two days, now, I feel like I have enough evidence.
    Since moving to the 14393.5 (from 14393.0, and previously Threshold 494), I've noticed a significantly increased battery drain as well.
    Same apps, before and after, same settings almost nothing set for background processing, except phone, text, alarms, lock screen, and maybe one other app. I don't even have mail set to sync, I manually kick this when I want to.
    Yet I'm draining 2-3 times as fast now, I literally lost 17% today, in 4 hours, of 5 texts and one short call, of maybe a couple of minutes. Before, this would've been more like maybe 5%, if that...

    Oh yeah, and it shows 63% of my drain having come from those 5 texts, all SMS, not even any pics or such, seems a bit crazy. Not that I really think the battery->app measurement is really that accurate, but it seems pretty far off in left-field, currently...
    08-01-2016 12:55 AM
  10. hawwie_4's Avatar
    I just unplugged my phone and did some browsing and I'm down to 90%- it's been 10 minutes
    Mesbah likes this.
    08-01-2016 09:31 AM
  11. hawwie_4's Avatar
    Also my mail doesn't sync unless I manually push it and I am set to sync as items arrive
    Mesbah likes this.
    08-01-2016 09:32 AM
  12. PGrey's Avatar
    I found something strange yesterday.

    Both Cortana and Windows Default Lock Screen were set to NOT run in the background, on the "Background apps" settings screen.
    However, if I went to battery usage, and set it for the last 6 hours, when I never used it, first thing today, those two accounted for about 75% of the processing, under the battery usage, *if* I set it to the 6 hour interval.
    Huh? Didn't make much sense, until I clicked on them, from THAT interface (some new items, such as System Managed, not just on/off), and noticed both were set to "System Managed".
    So, apparently there's now a 2nd interface that manages background processing, not just the background settings, screen. If you see a high-drain app, go to the actual drain screen and look at your top offenders, I bet they're set to "System Managed".
    I don't have any data to back this up yet, in fact I'm just recharging my phone this AM, so we'll see over the next couple of days, if this fixes it.
    Hawwie_4, if you and others are seeing the same, try the above. I can post some screenshots if it'd help?
    Edit: Settings (just the larger umbrella) was using almost all the rest of it, in the "foreground" even though the machine was asleep. I double-checked, and same deal, it was set to "no background" in the regular Background screen, but from the Battery Usage screen you can see it's set to "System Managed".

    What a mess, I couldn't figure out how to set the tri-state battery settings, unless an app was already in the "draining" list. It sure looks like an oversight, that it should show this "System Managed" setting in the regular Background Apps Settings screen.
    hawwie_4 and Mesbah like this.
    08-01-2016 12:07 PM
  13. hawwie_4's Avatar
    Screenshots would be helpful, thanks. I think my drain has something to do with my outlook mail because none of my accounts are syncing correctly on their own, I have to manually sync every account to get new mail when it should do that automatically
    Mesbah likes this.
    08-01-2016 01:26 PM
  14. PGrey's Avatar
    Sure, first one is the standard "background apps" screen.
    The second one, showing the "managed by system" options, is from the "battery use" settings route.

    The third, shows the trinary selection mode, also from the battery use settings mode route.

    wp_ss_20160801_0001-1-.jpgwp_ss_20160801_0002-1-.jpgwp_ss_20160801_0003-1-.jpg
    08-01-2016 03:26 PM
  15. hawwie_4's Avatar
    What build are you using? My screens don't look like that..
    08-01-2016 06:35 PM
  16. PGrey's Avatar
    What build are you using? My screens don't look like that..
    14393.5. Current Redstone Pre-Release. Yeah, a few things have changed, and perf has sure smoothed out.
    Battery has taken a turn though, somehow my messaging just used 24%, even though I never used the app during that timeframe, hmm...

    I bet it'll be 14393.10 tomorrow, just sayin', my Win10 Desktop RS1 Release Preview already picked up update #1 ;-0
    I hope if it comes tomorrow, it'll help fix this, and my BT issue (other thread).
    08-02-2016 12:51 AM
  17. Hildr's Avatar
    Well, since I've not illimited wifi access to do upgrade, I'm stuck at the pre release 10586.456 version and my battery is just burning as hell. No SD card, no SIM, all background app set to off and something like less than 10 app installed (messenger, facebook, whatsapp, windows central, mytube) and the phone lose easily 20% per hour xD
    So for now, I just shut it down and wait for the anniversary update. You guys give me good hope. I just need to wait they put the anniversary update on the device recovery tool since I didn't figure how to update my phone with a metered connection.

    (Yeah, I did 2 reset wit same results, and battery was "ok" before)
    08-02-2016 06:20 AM
  18. PGrey's Avatar
    I have 4 background apps (phone, messaging, alarms&clock, calendar), where I had a few more on 8.1 (definitely mail too, maybe a couple of others.

    I'm not so sure about the battery drain on the RS update, 494 (last Threshold) was quite a bit better for me. I seem to be draining about 2-3% an hour, last night via messenger (texts), but I never actually got or sent a single text in the 6 hour window that it logged.
    On 494, I got maybe 2-4% for the same period, and messenger was basically zero, if I wasn't getting/sending messages. It's definitely NOT an efficient app, it drains like crazy if I send a handful of SMS texts, but that was when I was USING it, not when it was idle, this new "drain when not in use" isn't so great, it's definitely having a negative effect on things...
    08-02-2016 12:15 PM
  19. Hildr's Avatar
    Meanwhile with the L1520 on windows 8... 0.3 to 0.8%/h discharge rate when iddle. But WM10 have some feature that prevent me to go back -_-
    08-02-2016 01:56 PM
  20. PGrey's Avatar
    Yeah, even if I could go back to 8.x (obviously not with the 950XL), I wouldn't.
    I might consider reverting to 494, last Threshold though, I had a lot less problems on that build.

    I REALLY like the smoothness and a couple of the features on the Anniversary update, but so far I'm not impressed with the (relative) in-stability and battery life...
    08-02-2016 05:09 PM
  21. hawwie_4's Avatar
    How would I go about getting that Threshold 494 build?
    08-02-2016 05:33 PM
  22. PGrey's Avatar
    If you were on the Release Preview (or even just the regular updates for most capable phones in the US), you probably already have 494, assuming your phone hasn't gone to the Anniversary build (or it can't, because it's too old).

    If you're already upgraded to Redstone (Anniversary), then I really don't know. There are probably ROMs over on XDA or similar, but you have to be really careful, when it comes to just grabbing these, for a whole variety of reasons (if you don't know why, then they're probably not a good bet, there are complexities AND other risks).
    08-02-2016 05:57 PM
  23. hawwie_4's Avatar
    I am already on 494- i thought it was a preview build.. also I am using an unlocked dual sim 950 XL on AT&T in the US
    08-02-2016 10:33 PM
  24. CellularMan's Avatar
    did not notice much if any battery improvement. Missing my 1520 on 8.1 days... phone would last 2 days which is impossible now with the 950xl
    banjaboo likes this.
    08-05-2016 08:30 AM
  25. PGrey's Avatar
    My 950XL took a GIANT turn for the worse yesterday (last night).

    It seemed to be draining faster, mostly the "Start" screen and my "Account" settings yesterday. Then, last night, I had an 86->8% drain, in about 7 hours, something I'd never seen before, and with the battery-saver feature ON.
    All the processing for the 6 hour window is listed as foreground, although the phone was in standby, the whole time, so anything processing should've been background only.
    Clearly, the battery-meter is pretty hosed in 14393.5, and there's something really wrong with some of the background-settings too, and probably some key apps, possibly the Start screen, and the Accounts apps, from the looks of it....
    08-06-2016 12:21 PM
33 12

Similar Threads

  1. Windows 10 update error 0x80070005
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 07-28-2016, 01:07 AM
  2. Windows 10 Anniversary Update to add Project Centennial apps to Store, including Electron apps
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-27-2016, 04:42 PM
  3. Upcoming Evernote app for Windows 10 PC won't be universal; Evernote Touch leaving store Aug. 2
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-27-2016, 04:11 PM
  4. Plex for Windows 10 PC gets a bunch of bugs squashed in latest update
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-27-2016, 03:30 PM
  5. What happens if you're an Insider after the Windows 10 Anniversary Update
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-27-2016, 03:11 PM
LINK TO POST COPIED TO CLIPBOARD