1. developeryama's Avatar
    I installed the new update last night - Now every time I try opening my Edge browser, it crashes. Has anyone experienced this as well? Any workarounds?
    12-14-2016 06:50 PM
  2. Fenoy's Avatar
    No issues with Edge after the update. Seems to work fine.
    12-14-2016 08:04 PM
  3. B T C's Avatar
    I installed the update yesterday and I am not having this issue.
    12-14-2016 08:50 PM
  4. Player Piano's Avatar
    My alarms stopped ringing since this update. Very disappointing. The alarms vibrate but no ring.
    Rosebank likes this.
    12-15-2016 09:56 AM
  5. FredBloggs007's Avatar
    I installed the new update last night - Now every time I try opening my Edge browser, it crashes. Has anyone experienced this as well? Any workarounds?
    I am having this problem since the update. I posted a comment in the main article too. A few others have reported it but no responses to how to resolve. Help too..!
    12-15-2016 10:02 AM
  6. angel1998's Avatar
    No issues here with Edge!
    It's going well!
    Maybe you have to do a reset to fix this issue....?
    Had you made a restart on your phone since from the update? Even the restart doesn't fix(ed) the problem you will have forcely to reset your phone... ๐Ÿ™‚๐Ÿ™‚
    12-15-2016 10:18 AM
  7. developeryama's Avatar
    I tried many things but I ended up by going to the About menu and selected to reset my phone. Luckily I had backups created nightly. After the phone is reset I am given the option to restore from my backup. Also I store my apps to a SD card. The steps asked me to erase programs from the SD card in order to reinstall them. Ai clicked on Yes. Then after a little while everything was back to normal.

    These things are not very user friendly... I hope though this helps others.
    angel1998 likes this.
    12-15-2016 10:39 AM
  8. 9Redhead's Avatar
    Check to see if the alarms have any sound selected and if you can play that sound. I had the same problem and apparently my alarms didn't have any sound selected.
    12-15-2016 10:42 AM
  9. Player Piano's Avatar
    Check to see if the alarms have any sound selected and if you can play that sound. I had the same problem and apparently my alarms didn't have any sound selected.
    My alarms have a sound selected. My problem seems to be that I turn off the ringer at night. I wonder if I am having issue with quiet hours. I don't use Cortana nor quiet hours, but I wonder if some setting in there is not letting my alarm ring. When my alarm goes off my phone does vibrate, just no ring.
    12-15-2016 12:05 PM
  10. Player Piano's Avatar
    Solved my alarms problem. Just for kicks I tried to add a new alarm and then switched over to vibrate and guess what? The alarm rang. So deleted all of my old alarm entries and created new ones and all of the new ones seem to work fine now. Crazy.
    12-15-2016 01:33 PM
  11. humzahyaz's Avatar
    The sort of hoops Microsoft makes us jump through to do the literally basic things.
    Player Piano likes this.
    12-16-2016 12:51 AM
  12. developeryama's Avatar
    It is no different on Android or apple systems
    Joe920 likes this.
    12-16-2016 01:25 AM
  13. developeryama's Avatar
    Same goes with Bluetooth registered devices. I had to delete them and re-register them when I reverted to my previous build.
    12-16-2016 01:27 AM
  14. ZPITA's Avatar
    I have one of the original 950s. Have suffered with a number of problems from the beginnng, including constant overheating and shutting down. Have tried many resets. The latest update has added problems including showing short battery life and shot downs. Have already returned it to Microsoft but the result was no improvement. I guess it is a hardware issue. My main question, if I insist on a replacement, is the newest generation better or will I end up with the same issues? Any feedback appreciated.
    12-16-2016 05:13 AM
  15. ads13's Avatar
    Just do hard reset of your phone.
    12-16-2016 06:28 AM
  16. ZPITA's Avatar
    I know this is a popular cure, but have tried it and it doesn't really help.
    Player Piano likes this.
    12-16-2016 07:23 AM
  17. FredBloggs007's Avatar
    I have just done a factory reset and it's fixed the problem
    12-27-2016 12:08 PM
  18. ZPITA's Avatar
    Glad it worked for you, but not for me. It was sent to Microsoft for fixing in July. Think they only reinstalled the operating system. I have since done many soft and hard resets to have all the problems return. It is now back with Microsoft. I expect it is a hardware problem, as mine was one of the first productions. I have asked for a replacement. Let's see what happens.

    Too bad because I like the phone overall. But an unreliable phone is useless.
    12-27-2016 12:11 PM
  19. FredBloggs007's Avatar
    My problems only started with the new build early December 2016, so probably unrelated to the problem you have if you had since July 2016. However I agree the phone is quite unstable - but I think it's the OS rather than the hardware. Things keep breaking on each release - e.g. OneDrive, Edge, skype, Facebook, WhatsApp etc.
    12-28-2016 04:57 PM
  20. ZPITA's Avatar
    Let's see when they return the phone.
    12-28-2016 05:03 PM
  21. Sedp23's Avatar
    This build is murdering my battery on my idol 4s only getting 4-5 hours I've even hard reset and still the same issue. Over heating, battery draining, and high discharge rate




    Sent from Idol 4s with Windows
    12-28-2016 10:05 PM

Similar Threads

  1. Has .576 update broken the camera app?
    By Rosebank in forum Microsoft Lumia 950
    Replies: 8
    Last Post: 12-17-2016, 11:19 AM
  2. New Cumulative update today!
    By holdum333 in forum Windows 10
    Replies: 3
    Last Post: 12-17-2016, 02:22 AM
  3. Lumia 950 latest build 14393.567
    By jeetu4444 in forum Microsoft Lumia 950
    Replies: 4
    Last Post: 12-15-2016, 07:53 PM
  4. Problems in the windows 10 app store "Try again later" message?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-14-2016, 05:46 PM
  5. Windows 10 preview build 14986 heads out to Slow ring Insiders on PC
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-14-2016, 01:30 PM
LINK TO POST COPIED TO CLIPBOARD