1. neutropia's Avatar
    I'm on AT&T and I just switched from a 1520 to the 950XL and simply moved my sim card over and restored all my settings. However, I am unable to receive any texts though I can send just fine. Everything else works just fine on the phone (I haven't tested if I can receive calls yet) except for incoming texts. When I check my AT&T account it doesn't recognize my device, it simply says unknown, so I don't know if this is a factor. I've tried searching AT&T support forums for APN MMS settings but those didn't seem to fix the issue at all.

    My wife switched to a standard 950 months ago and has not had this issue. AT&T even recognizes her phone on my account.

    I've tried each SIM port, a soft reset, pulling the battery, ensuring I'm updated, and nothing works. I'm trying to avoid the hard reset if at all possible so does anyone have any ideas? Maybe I got bad APN/MMS settings from AT&T's support site?
    12-26-2016 10:32 AM
  2. miodrage's Avatar
    Hard reset, and then, setup a new phone. Ur backup pulled something from the old one, and that is blocking ur texts. Sorry bro, I think there isn't any other solution.
    neutropia likes this.
    12-26-2016 04:02 PM
  3. mggm100's Avatar
    Before doing anything drastic, consider getting a new SIM. AT&T will replace it at no charge in one of their stores.
    neutropia likes this.
    12-26-2016 04:38 PM
  4. aximtreo's Avatar
    I would also suggest that you look at the wifes settings and make sure your phone has the same settings. Then the new SIM card and lastly, hard reset and new setup.

    Hopefully option 1 works for you.
    neutropia likes this.
    12-27-2016 07:43 AM
  5. neutropia's Avatar
    I copied my wife's settings with no luck and even did the hard reset, which didn't work. So, on a whim, I shut off my cell data which also didn't help.

    But miraculously, when I turned off bluetooth, everything suddenly came flooding in randomly. I now have data and bluetooth on and no problems. This is officially the most random fix I've ever encountered in my life.... Thank you all for your help!
    aximtreo likes this.
    12-27-2016 08:03 AM
  6. miodrage's Avatar
    ROFL... that is almost as weird as waking Lazarus back from the dead. Sheesh!
    neutropia likes this.
    12-29-2016 09:53 AM
  7. dlomshek's Avatar
    When I received my new 950 xl I added a 200Gb SD card that I had been using with my Surface Pro 3. First thing I did was to remove all of the files on the SD by moving them to a folder on the Surface Pro. I then reformatted the SD while still installed on the Surface Pro. Finally I opened the 950 XL and installed the reformatted SD card. After he phone recognized the card I then copied all files that I wanted transferred to the phone. I now have a new phone with 200 Gb of memory.
    01-11-2017 01:46 PM
  8. Camaroon's Avatar
    Hey, I just started having the exact same issue yesterday. I'm on a 950 on T-Mobile. I've done most of what the OP has done, including turning off Bluetooth, but nothing has helped so far. I posted in the 950 forums about it but no response yet, and just found this thread this morning. Any other suggestions other than a hard reset? Thanks!
    01-16-2017 09:32 AM
  9. neutropia's Avatar
    I'm convinced my fix may have just been an absolute fluke. I do know my AT&T account shows my phone as a 1520 and no longer unknown. However, I can't say if this happened around the same time as my texts magically coming to life. It wouldn't hurt to try and give T-Mobile a call and see if they have any tips on their end. Also wouldn't hurt to check your SIM settings if you haven't already.

    Best of luck Camaroon!
    01-18-2017 12:34 PM
  10. Camaroon's Avatar
    Thanks so much for the reply! I kind of blanketed these forums looking for a quick fix before I hard reset, I've been dealing with a lot of stuff through text lately so it was important. But all of a sudden, the next it all just started to work. I had uninstalled Skype preview and left it off my phone for several hours, so I don't know if that did it, or if it was just a coincidence. My friend is on Verizon with a Google Pixel and he said he was having issues receiving texts the same day, so who knows. Thanks again!
    neutropia likes this.
    01-18-2017 02:33 PM
  11. neutropia's Avatar
    Glad it started randomly working like mine did! I guess we'll just chalk these issues up to a solar flare. It's the easiest thing to blame.
    01-18-2017 03:33 PM
  12. Camaroon's Avatar
    Haha, that's what my friend said. Oh well...
    01-18-2017 03:42 PM

Similar Threads

  1. Replies: 4
    Last Post: 12-30-2016, 09:58 PM
  2. can't move cursor
    By Windows Central Question in forum Ask a Question
    Replies: 4
    Last Post: 12-27-2016, 03:09 AM
  3. how can i make my lumia 640 (microdoft cricket) unlock
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 12-26-2016, 09:04 AM
  4. Why can't I install viber on my windows phone 10?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-26-2016, 05:51 AM
  5. How can I remove system reserved partition on external hard drive
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 12-25-2016, 07:03 PM
LINK TO POST COPIED TO CLIPBOARD