1. hurkanasmaci's Avatar
    Hello guys,

    I haven't been able to use Google or Youtube on my Lumia 950 XL for the last few weeks now. It either says that "can't connect to the page" or "TSL security error"
    01-12-2017 01:03 PM
  2. kbagrows's Avatar
    Just verified that both work just fine on my 950XL. May it is something with your router?
    01-12-2017 01:59 PM
  3. hurkanasmaci's Avatar
    No, I've checked the router :/ My gf is also having the same problem with her Lumia 950 XL. I can search when I use vpn but images don't show up and I still can't use Youtube.
    01-12-2017 02:36 PM
  4. anthonyng's Avatar
    Hello guys,

    I haven't been able to use Google or Youtube on my Lumia 950 XL for the last few weeks now. It either says that "can't connect to the page" or "TSL security error"
    I've seen something similar before (youtube saying can't play or whatever) and I find just giving it a moment to load something a bit more and then pressing it again or two works....

    The can't connect to page/tsl security error does seem like a router problem though.... You've tried some other wifi or your data connection?
    01-16-2017 12:03 AM
  5. jameshn's Avatar
    I've seen something similar before (youtube saying can't play or whatever) and I find just giving it a moment to load something a bit more and then pressing it again or two works....

    The can't connect to page/tsl security error does seem like a router problem though.... You've tried some other wifi or your data connection?
    I'm having the same problem with mine unable to access any google services even google drive this has been happening since a couple of week ago I'm pretty sure is not router issue because I have a Lumia 640xl and works just fine
    01-28-2017 10:52 PM
  6. najgori's Avatar
    I don't have any problems with this services on my lumia 950 xl
    01-29-2017 11:08 AM
  7. Marben Viernes's Avatar
    Hello guys,

    I haven't been able to use Google or Youtube on my Lumia 950 XL for the last few weeks now. It either says that "can't connect to the page" or "TSL security error"
    I am facing the same problem using my 535 and im sure its not a router issue since i am able to use the site using my android device. I can access the google using UC browser, but not the youtube site. It seems like google are trying to sabotage W10M by blocking all google related services
    01-29-2017 05:45 PM
  8. Zulfigar's Avatar
    Google is updating their security on their sites, Microsoft actually updated Edge on the fast ring on 15014 to fix the issues. The fix will probably hit everything else in a week or two.
    01-29-2017 07:09 PM
  9. anthonyng's Avatar
    weird why ok for some and not others? Where you guys accessing from? Canada here.
    01-29-2017 07:20 PM
  10. bigfootsvj's Avatar
    I am having this same issue on my Surface Pro 3. Just noticed this since last weekend.
    01-29-2017 10:27 PM
  11. JMBasquiat's Avatar
    Odd. Google was known to disable access to Internet Explorer on WP8.1 for their Maps mobile website in the past...
    01-30-2017 04:38 AM
  12. jameshn's Avatar
    I just found that you can use incognito mode on UC browser and you can use YouTube I hope MS solve this issue soon
    01-31-2017 06:58 AM

Similar Threads

  1. Hey Cortana doesn't work all the time
    By vhl71 in forum Cortana
    Replies: 4
    Last Post: 02-24-2017, 09:37 PM
  2. How to check an used 950 XL?
    By chris_t in forum Microsoft Lumia 950 XL
    Replies: 18
    Last Post: 01-21-2017, 11:05 AM
  3. Replies: 1
    Last Post: 01-12-2017, 11:46 PM
  4. Windows Hello gains traction with nearly 100 biometric-enabled Windows devices and accessories
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-12-2017, 12:11 PM
  5. Mega Man 9 and 10 come to Xbox One backward compatibility
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-12-2017, 11:42 AM
LINK TO POST COPIED TO CLIPBOARD