1. LucasDanielRn's Avatar
    So, I've been having this problem for a few weeks. Even trie to hard reset and see if it fixes it, but no luck. What happens is that after my 950xl screen goes off, the wifi disconnects (not sure how long to do it, but it does). This is very annoying, because I tend to loose notifications from the apps. A mvp from Brazil told me that this is normal behavior, to save battery, but that the wifi remains on a semi-connected state, so I won't loose notifications, but as I mentioned, this is not the case. Anyone also viewing this? Any fix? There are some people on reddit who also encountered it (https://www.reddit.com/r/windowsphon...hen_screen_is/), and a page on microsoft answers page: https://answers.microsoft.com/en-us/...6-976b479da097
    05-29-2017 06:00 PM
  2. ven07's Avatar
    Did you recently update? also if this wasn't the case before then it's most likely due to the update (if there was an update lol)

    Otherwise you could go for the full reset, using the recovery tool
    05-29-2017 06:43 PM
  3. LucasDanielRn's Avatar
    I did a hard reset after the last cumulative update (15063.332), but already had this before. What is strange to me is that it seems to be an internal configuration of the device, one that we can't access to change (also saying this because of what the mvp said). Anyways, as a last resort, I'll consider the full reset using the recovery. Thanks.
    ven07 likes this.
    05-30-2017 09:42 AM
  4. PJL99's Avatar
    Have you checked to ensure the apps are allowed to run in the background? This may have been reset. I'm running the latest released update (15063.297) and I get notifications from apps that use WiFi when the screen goes to locked (off) state. Are you using an insider build?
    ven07 likes this.
    05-30-2017 02:31 PM
  5. LucasDanielRn's Avatar
    Yeah, apps are allowed to run in the background. I'm on release preview (15063.332), but saw this behavior with the prior build too. Like I said, it takes a little bit of time (perhaps 10, 15 minutes or more) for this to happen. If I don't get any notifications on this period, the wifi will go off. Do you think you could observe this behavior PJL99? As a side note, on the last couple of days, it got better, but still happens.
    05-31-2017 10:03 AM
  6. PJL99's Avatar
    Yeah, apps are allowed to run in the background. I'm on release preview (15063.332), but saw this behavior with the prior build too. Like I said, it takes a little bit of time (perhaps 10, 15 minutes or more) for this to happen. If I don't get any notifications on this period, the wifi will go off. Do you think you could observe this behavior PJL99? As a side note, on the last couple of days, it got better, but still happens.
    When the phone sleeps (locked with the screen off) it still issues all notifications as expected indicating that the WiFi is connected as necessary, regardless of the time it has been sleeping (a few minutes to many hours).
    06-01-2017 12:05 AM
  7. Rick Austinson's Avatar
    Does this happen on multiple networks? Or is it isolated to a single, specific wireless network?
    06-09-2017 10:45 AM
  8. Parrot94's Avatar
    Hi everyone!

    I just joined the forum since this was the only thread I could find here about this issue I have on my Lumia 950.

    Just as OP said, when at home my Wi-Fi connection drops every like 10-15 minutes under lock screen. Right now I was writing this reply from my PC, double-tapped the screen and saw the Wi-Fi icon reappear on the status bar after a couple of seconds.
    This doesn't seem to happen in my office, but I have less time to check my phone during work hours so I may just be missing it.

    The only relevant difference I found between the two networks is that my home only has 2.4 GHz, while in my office there's 5 GHz.

    I tried to hard reset through Settings and to troubleshoot the issue with Bluetooth both enabled and disabled (Lumia 950 came out with serious Wi-Fi issues, having it dropping connection even during usage when Bluetooth devices were connected - this problem has been solved though), but nothing changed.

    Any idea? Has OP managed to solve his problem somehow?

    Thank you
    07-21-2017 02:39 PM

Similar Threads

  1. how to speed up cortana?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 05-29-2017, 06:41 PM
  2. How to buy and read e-books in Windows 10 Mobile Creators Update
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-29-2017, 02:10 PM
  3. Is there a way to one way sync in OneDrive?
    By webosdropout in forum OneDrive
    Replies: 1
    Last Post: 05-29-2017, 01:00 PM
  4. Free upgrade of Simple Choice plan from 2.5 to 4GB high speed?
    By HoosierDaddy in forum Carrier Discussion Lounge
    Replies: 0
    Last Post: 05-29-2017, 12:29 PM
  5. Everything you need to know about Alcantara
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-29-2017, 12:10 PM
LINK TO POST COPIED TO CLIPBOARD