1. Girac's Avatar
    I picked up an unlocked 950XL, when I take my sim out of my 930 and put it in the 950XL it shows No service. Under the Sim settings the Cell network shows Active networks: No network found. and Enhanced 4G LTE services is unregistered.
    How can I get this to have service, New Sim, call to ATT, or is the phone fuxored?

    TIA
    10-22-2018 05:49 PM
  2. midnightfrolic's Avatar
    try borrowing a friend's SIM?
    10-22-2018 10:18 PM
  3. miodrage's Avatar
    Maybe the phone is not unlocked.
    10-23-2018 01:38 PM
  4. Old_Mil's Avatar
    Assuming that there isn't something wrong with its cell radii, the next most likely explanation is that the phone isn't unlocked.
    10-23-2018 02:39 PM
  5. nate0's Avatar
    @Girac
    Have you done a hard reset yet with the sim card in it? I would start there.

    Also if it were sim locked you would have been prompted to enter the network unlock code after booting it up with the sim card in. I am unaware of any sim locked Lumia 950 XL models, but there were so many variants released that it's possible a carrier variant over seas in EU or some where else was put out.
    fin11 likes this.
    10-24-2018 09:11 AM

Similar Threads

  1. Hi im new here
    By queylotrie in forum New to the Forums? Introduce Yourself Here!
    Replies: 5
    Last Post: Yesterday, 05:07 PM
  2. ASUS' new Zen AiO 27 includes a wireless charger in its base
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-22-2018, 01:30 PM
  3. Never get stranded in an emergency with the $80 Anker Roav Jump Starter Pro
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-22-2018, 01:00 PM
  4. Chrome may soon embrace Snapdragon laptops with native ARM version
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-22-2018, 12:00 PM
  5. Replies: 0
    Last Post: 10-22-2018, 11:36 AM
LINK TO POST COPIED TO CLIPBOARD