1. anon(5383410)'s Avatar
    I'm well aware that these aren't flip phones and especially with some of the beefier hardware (ie. 950) it takes a while to get the phone to boot if you let it die completely. Until this point that "while" has usually been a few minutes. I let my battery completely die for the first time since owning my 950 and it's been plugged into the wall for about 30 minutes and still won't boot. I just get the empty battery icon.

    Anyone else had this issue?
    Last edited by offbeatbop; 12-11-2015 at 02:58 AM.
    12-10-2015 06:16 PM
  2. anon(5383410)'s Avatar
    Update: Plugging the USB cable into my PC seems to have initiated a charge. It's weird that it wouldn't charge the wall outlet.
    12-10-2015 09:03 PM
  3. anon(5383410)'s Avatar
    Now it appears the only way the battery will charge is by connecting it to a PC. I've tried several wall outlets and it just won't charge. This is bizarre. All I did was allow my battery to completely drain. Hopefully AT&T has an extra battery they can pop in but I haven't seen spare batteries for sale anywhere yet. Or since half their employees don't even know what it is let alone try to sell it hopefully they'll have a spare (or 10) on site that they can swap the battery from.

    Lesson #1 DO NOT let your battery completely drain.
    12-11-2015 02:58 AM
  4. p6889k's Avatar
    I had similar thing happen to me yesterday. Phone was running hot all day, battery got drained, putting it on a charger after it died didn't help. I removed the battery, put it back in and the phone started normally. The battery was showing 50% charged. My guess is it was charging, just for some reason wasn't able turn on.
    12-11-2015 07:22 AM
  5. anon(5383410)'s Avatar
    I had similar thing happen to me yesterday. Phone was running hot all day, battery got drained, putting it on a charger after it died didn't help. I removed the battery, put it back in and the phone started normally. The battery was showing 50% charged. My guess is it was charging, just for some reason wasn't able turn on.
    Interesting. I tried popping the battery out last night and still couldn't get it to charge. What was interesting is that the Usb type c cable that came with my phone with my cheapo car charger it was able to charge too. Only wall outlets are giving me issues.

    I'm going to try a soft reset and battery removal when I get home. Fingers crossed.
    12-11-2015 12:17 PM
  6. freypal's Avatar
    Any joy? I've not let my 950 run flat yet...
    12-11-2015 04:52 PM
  7. anon(5383410)'s Avatar
    Any joy? I've not let my 950 run flat yet...
    Not yet I'll report back when I get home and pull the battery/soft reset. Right now it's plugged into the cr charger and charging very slowly.
    12-11-2015 05:17 PM
  8. anon(5383410)'s Avatar
    update: Just got home. Did a soft reset, popped out the battery for a few seconds and popped it back in and it appears to be charging normally with the wall charger again. So again, a word to the wise. DO NOT let your battery drain completely.
    12-11-2015 06:56 PM
  9. anon(5383410)'s Avatar
    Still having issues. The wall charger just sporadically decides to stop working. I'm really not sure what to do now. I'll try getting a new wall charger to see if it's just the walla chargers itself, but it's odd that a brand new charger would just stop working because I tried plugging it in while my battery was totally drained.

    It continues to charge fine when I plug it into my PC and even car charger. Bizarre.
    12-14-2015 09:40 PM
  10. duncan0622's Avatar
    I remembered same issue back in WP8 day. Your phone is actually charging but screen is still black because your phone need specific amount of juice to power up the screen. But sometimes soft reset can pump to power up the screen .

    However, I can't explain how a slower charger (USB or car) ironically can power up the screen instantly.
    12-14-2015 09:54 PM
  11. VineRider's Avatar
    I had the same issue as the OP, had to plug into my surface to get the charge started. Weird behavior.
    12-14-2015 10:14 PM
  12. freypal's Avatar
    Anyone else had an issue with this? Id be interested to know if its a common issue like it was with the Lumia 800. haven't let mine run flat yet for fear of this... or another question;

    Have people been able to run the 950 flat and had no issues with it charging back up?
    12-19-2015 12:26 PM
  13. seventeenapg's Avatar
    I have the same issue. I accidentally let it run flat and couldn't get it to charge again. It would vibrate and restart then vibrate and restart again. This would continue. The only way I got it to charge was to plug in to my surface pro.
    12-20-2015 05:15 PM
  14. anon(5383410)'s Avatar
    Just to keep the post updated and bump it in case this really is a common issue, I'm stil having problems. The original wall charger the phone came with simply won't work anymore. I have to either plug it into my pc or run a usb-c cable into a usb wall adapter. I'm just going to spring for one of those Quick charge usb wall adapters and use that with the usb-c cable. I didn't do anything to possibly damage the wall charger. In fact it was tucked away in a drawer. All I did was allow my battery to go flat, and when I whipped out the 'ol wall charger it wouldn't work and hasn't since.
    12-20-2015 06:40 PM
  15. Jonnie LasVegas's Avatar
    Wow, crazy behavior! My 950 has done MANY weird things but not this one (fingers crossed). I have accidentally let my battery completely die twice, but had no problem when I plugged it into my wall charger. Thanks for keeping us updated though!
    12-22-2015 08:04 PM

Similar Threads

  1. My phone has text to voice activated, how do I switch it off?
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 06-27-2016, 10:16 AM
  2. WM10 Battery Drain on 1520
    By GazooAz in forum Nokia Lumia 1520
    Replies: 33
    Last Post: 03-29-2016, 01:12 PM
  3. Duplicate contacts (this is seriously still an issue)
    By eddieDOTexe in forum Windows 10 Mobile
    Replies: 3
    Last Post: 12-11-2015, 10:54 PM
  4. Microsoft Band 1 - GPS Issue?
    By yaleen in forum Microsoft Band & Band 2
    Replies: 2
    Last Post: 12-11-2015, 10:45 AM
  5. Photo app crashes when watching .png image.
    By WinCoffee in forum Ask a Question
    Replies: 0
    Last Post: 12-10-2015, 04:15 PM
LINK TO POST COPIED TO CLIPBOARD