1. AHMED STOKON's Avatar
    I have a lumia 950 and i use the out of the box Microsoft charger
    But IT takes agrees to charge up to 100%
    From 17 % to 76% as iam writing this now it takes more than 90min
    Wi-Fi is disabled and location is disabled
    And the phone doesn't even get warm at all
    Is this normal ?
    01-29-2016 06:56 AM
  2. Chintan Gohel's Avatar
    I have a lumia 950 and i use the out of the box Microsoft charger
    But IT takes agrees to charge up to 100%
    From 17 % to 76% as iam writing this now it takes more than 90min
    Wi-Fi is disabled and location is disabled
    And the phone doesn't even get warm at all
    Is this normal ?
    Try this app by Arthur Semenov called Battery. It will give you the charging rate so you can monitor how fast your phone is charging
    01-29-2016 07:10 AM
  3. AHMED STOKON's Avatar
    It takes 130 min to go full charge
    01-29-2016 07:24 AM
  4. dashrendar's Avatar
    Not normal. In your case, it should have taken about 35 minutes.

    Microsoft's charger supplies 3A input. With the phones 3000mAH battery, it should take no longer than one hour to charge the phone up completely. Maybe a little longer since the last 10% (between 90-100%), the charge is slowed down a bit.
    01-29-2016 07:27 AM
  5. AHMED STOKON's Avatar
    Not normal. In your case, it should have taken about 35 minutes.

    Microsoft's charger supplies 3A input. With the phones 3000mAH battery, it should take no longer than one hour to charge the phone up completely. Maybe a little longer since the last 10% (between 90-100%), the charge is slowed down a bit.
    So what is the problem here?
    01-29-2016 10:30 AM
  6. dajma00's Avatar
    Try upgrading your firmware. Mine charges full within 30 minutes. That's one of the best feature of this phone.
    AHMED STOKON likes this.
    01-29-2016 11:17 AM
  7. ashram's Avatar
    So what is the problem here?
    It's the phone or the charger for sure.... from under 10% i get a full charge in less than an hour (never timed the exact amount)

    I'd say, 1st check the port on the phone and the charger, to make sure there is nothing that could stop a decent connection from happening (lint, gunk, etc) and if you know anyone else with a 950 or recent nexus, see if you could use their stock charger. if all fails, warranty claim!
    AHMED STOKON and InsGadget like this.
    01-29-2016 11:44 AM
  8. EMitchell's Avatar
    You mentioned your wifi and location are disabled, is your phone actively trying to do something, like download updates? If high levels of activities are going on, it might slow down the charge time. Have you allowed your phone to get all the app updates, etc., first? Since it's having to do it over a cell connection, this might take longer than if it were over a wifi connection.
    AHMED STOKON likes this.
    01-29-2016 04:47 PM
  9. AHMED STOKON's Avatar
    i have the latest firmware of course
    01-30-2016 06:52 AM
  10. AHMED STOKON's Avatar
    fast charging works sometimes and sometimes it's not working
    same charger same Device
    so i guess it's a matter of luck with me
    because sometimes i plug it and the phone and it's charge really fast also it get warm ( as the numbers you guys mentioned up later )
    and the other day is not working and it charges slow as hell and not getting warm at all
    so that's very strange here
    01-30-2016 06:56 AM
  11. Chijioke Zionny's Avatar
    01-30-2016 07:17 AM
  12. AHMED STOKON's Avatar
    Good
    thx but it's not working always
    01-30-2016 04:20 PM
  13. InsGadget's Avatar
    You have a bad charger or phone it sounds like. Mine works every time, and it definitely gets pretty hot while charging.
    01-31-2016 09:30 AM
  14. Charles Brown8's Avatar
    fast charging works sometimes and sometimes it's not working
    same charger same Device
    so i guess it's a matter of luck with me
    because sometimes i plug it and the phone and it's charge really fast also it get warm ( as the numbers you guys mentioned up later )
    and the other day is not working and it charges slow as hell and not getting warm at all
    so that's very strange here
    Sounds like a flakey cable connection.. If it's still under warranty I would not waste time trying to fix it.. Best to just exchange it and be done with it.. Just my opinion but I'm not going to spend that much money on a new phone and waste time trying to fix it.. Especially charging the phone which should just "work" period out of the box.
    AHMED STOKON likes this.
    01-31-2016 10:09 AM
  15. ektosknot's Avatar
    I also have this behavior. Sometimes fast, sometimes normal. It all started when I used the phone longer periods while charging. I am pretty sure this is a software issue and has nothing to do with the hardware. Anyway, when this happens take it out of plug and after a minute plug it back. It will charge faster.
    03-30-2016 06:12 AM

Similar Threads

  1. Replies: 1
    Last Post: 01-29-2016, 05:17 AM
  2. Why am I not able to update to next preview build on my Lumia 730?
    By Windows Central Question in forum Nokia Lumia 730 & 735
    Replies: 1
    Last Post: 01-29-2016, 02:14 AM
  3. Does Continuum work with touch screen monitors?
    By mkenyon2 in forum Continuum
    Replies: 1
    Last Post: 01-28-2016, 05:10 PM
  4. Potential work around for the email live tile issue of unread counts....
    By peashooter14 in forum Microsoft Lumia 950 XL
    Replies: 2
    Last Post: 01-28-2016, 01:32 PM
  5. Replies: 1
    Last Post: 01-28-2016, 12:54 PM
LINK TO POST COPIED TO CLIPBOARD