1. eomes's Avatar
    Hello everyone.

    So I bought myself a 950 last Thursday and from the beginning I've noticed some problems with the WiFi connectivity. Turning it off and leaving it on 4G would cure all the problems described below.

    At first I thought it may have been due to the vast amount of updating apps but after all of that was done (struggled with various errors there too, though).

    Now here is what's been happening ever since. When I pick up the phone to do some browsing, it's usually fine at first, but a minute later it would seem that the phone loses the WiFi connection. Edge would say this:

    https://onedrive.live.com/redir?resi...nt=photo%2cpng

    Windows Central app says this every time I open it (even though the newest articles are loaded):

    https://onedrive.live.com/redir?resi...nt=photo%2cpng

    The Store is the worst. It says it's "Acquiring License" for a minute and only then it starts downloading the app which stops usually right away or half way through. Only on rare occasions does it fully download the app.

    https://onedrive.live.com/redir?resi...nt=photo%2cpng

    All this has been driving me crazy. It does not seem to be the problem a lot of people have been complaining about the phone losing the signal whatsoever and disconnecting from the network completely with no way of reconnecting without a reboot. That's not the case for me as the phone usually picks up the WiFi signal once again and quite soon.

    The same has been happening at my work so it's definitely phone's fault since my previous L925 used to work on both networks with no problems at all.

    By the way, I am on Build 10586.29 (not part of the Insider program).

    Has anyone had this or a similar issue?
    02-09-2016 01:23 PM
  2. YKinase's Avatar
    Not sure if this is your problem, but there is a persistent problem with the WiFi/Bluetooth combo that seems to lose the ability to detect a 5GHz wifi signal. There's a 24 page thread on this in the Microsoft Community. Sadly, there has been no acknowledgement from MS that this is a problem to my knowledge. The community moderators have not commented in 2 months.

    The thread can be found here: http://answers.microsoft.com/en-us/m...b-59e6475e570c
    02-09-2016 01:29 PM
  3. eomes's Avatar
    Thanks for your reply.

    I have skimmed through the first page of the thread and the symptoms of my 950 are a bit different from those mentioned there. I keep my BT off most of the time and there does not seem to be any relation to that.

    Will keep reading though.
    02-09-2016 02:15 PM
  4. eomes's Avatar
    Any other ideas or experiences, guys?
    02-10-2016 11:59 AM
  5. fly_branch's Avatar
    Send it back. I am sending back my fourth one.
    04-25-2016 09:18 PM

Similar Threads

  1. Turn off then on - lose 20% battery!
    By bells0 in forum Microsoft Lumia 950 XL
    Replies: 5
    Last Post: 08-01-2017, 07:57 AM
  2. Lumi 950 - Sound notifications only work intermittently
    By rayray_999 in forum Microsoft Lumia 950
    Replies: 1
    Last Post: 02-11-2016, 07:59 AM
  3. Replies: 1
    Last Post: 02-09-2016, 12:32 PM
  4. Microsoft Lumia 650 could be priced at 200 in Ireland
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-09-2016, 11:20 AM
  5. How do I fix a bricked Lumia 920?
    By JB Labs in forum Nokia Lumia 920
    Replies: 0
    Last Post: 02-09-2016, 11:05 AM
LINK TO POST COPIED TO CLIPBOARD