1. earl_z's Avatar
    Ever since my phone was updated to build 10.0.10586.218 it has been nothing short of a headache. My frustration level is almost to the point where I want to ditch my Lumia 950.

    The most recent build has bugs. I'm searching this forum to see if there are any workaround beyond a full reset.

    * Windows Hello stops working
    * Apps won't load and close immediately
    * Apps freeze up randomly
    * Phone stops charging and battery drains faster

    A reboot temporarily fixes these issues. This is by far the worst experience I've had with this phone. Has anyone else experienced these issues?
    Last edited by earl_z; 05-02-2016 at 04:14 PM.
    05-02-2016 03:59 PM
  2. xandros9's Avatar
    Full reset is the way to go sadly.
    sahib lopez likes this.
    05-02-2016 06:23 PM
  3. GrayW0lf's Avatar
    Just be sure to use the contacts+messages backup app to grab your SMS/MMS before you hard reset. The normal restore process has not been working 100% reliably lately.
    05-02-2016 06:26 PM
  4. earl_z's Avatar
    That's what I thought. This is the second time I've had to do a reset because of problems with an update from Microsoft. It's a major pain because I use my phone for work, which means I have to redo RSA SecurID, email accounts, Office 365, Azure authenticator, etc. Frigging headache. I wish Microsoft would fix these issues. I never had these issues with my Nokia 920. The 950 is a decent phone but is far from reliable and I wouldn't recommend it to anyone.
    05-02-2016 06:32 PM
  5. GizmoEV's Avatar
    Try the Prerelease build of the Insider preview. It has improved the stability of my Wife's 950XL dual SIM and my daughters 950 Dual SIM phones.
    05-02-2016 07:33 PM
  6. atrociousonpc's Avatar
    I tried something different this time. Instead of doing a hard reset, i allowed the battery to drain until there was nothing left and the phone died, then charged it back up. Phone works great now!
    GrayW0lf likes this.
    05-03-2016 08:58 AM
  7. Jazmac's Avatar
    Faulty device?
    05-03-2016 11:57 PM
  8. Andrew Fratkin's Avatar
    I tried something different this time. Instead of doing a hard reset, i allowed the battery to drain until there was nothing left and the phone died, then charged it back up. Phone works great now!
    In the future you should be able to accomplish the same by doing a soft reset (holding power and volume down buttons simultaneously until phone vibrates) or powering off and removing battery.
    05-04-2016 08:36 AM
  9. Krystianpants's Avatar
    Before attempting a reset get on insider and get the production preview build. These are usually ones that will be coming out to production eventually and they fix a lot of stuff. There will also be a newer one coming out soon as well. .218 is already old.

    And don't expect things to be smooth right away. Typically you have to give it a day before it stabilizes. It's weird but this has been consistent for me. The only one that hasn't produced this issue is the latest fast ring build. So maybe they are working on the install process in redstone. But it can really give an inaccurate perception of a new build.
    GizmoEV likes this.
    05-04-2016 10:26 AM
  10. atrociousonpc's Avatar
    In the future you should be able to accomplish the same by doing a soft reset (holding power and volume down buttons simultaneously until phone vibrates) or powering off and removing battery.
    Its weird because I did that. It's usually the first thing I do. I tried the soft reset, and even tried the battery pull. Maybe it's a placebo effect but draining the battery worked.
    05-05-2016 07:34 AM
  11. earl_z's Avatar
    Okay, this is probably not going to make any sense to anyone, but I fixed the issues without doing a reset of the phone or fully drain the battery. Now it works great. No more random reboots, Windows Hello works great, and it charges!

    What did I do? I changed the lock screen wallpaper. Before the last update I had the default Windows sample image set as my lock screen. I changed it to Bing and noticed that Windows Hello started to work right away. I also noticed that I could charge the phone without rebooting. Since then I've changed it to a Flixster wallpaper and is still working great.

    I'm not sure why changing the lock screen wallpaper fixed the issues with my phone. I'm wondering if anyone else has had this same experience.
    xzb6np likes this.
    05-09-2016 12:39 PM

Similar Threads

  1. Best case for the Lumia 950?
    By Windows Central Question in forum Microsoft Lumia 950
    Replies: 8
    Last Post: 07-05-2016, 07:56 AM
  2. Average battery life after windows 10 update
    By pankajupadhyay05 in forum Nokia Lumia 830
    Replies: 8
    Last Post: 05-27-2016, 11:10 PM
  3. Replies: 2
    Last Post: 05-03-2016, 11:41 AM
  4. Can Project Centennial apps run on Windows 10 Mobile (and other questions answered)
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 05-02-2016, 04:17 PM
  5. Replies: 0
    Last Post: 05-02-2016, 02:34 PM
LINK TO POST COPIED TO CLIPBOARD