1. ByeVanno's Avatar
    Okay i have a problem where I feel it shouldn't be this sluggy my 950 feels like a snail and all of a sudden it began to get hot and battery life was terrible idk what to do atm. Is anybody else having problems like this I mean I know this isn't powered by the sd810 but no way my phone should feel so sluggish get warm so quickly(it doesn't get hot unless im using it while on the charger) ive tried hard resets and idk what to do. Anybody have anything to help?
    05-12-2016 03:56 PM
  2. WayCool's Avatar
    OS Version ?

    See the battery threads.... Plus if you did a hard reset how long has it been ? If recent it will likely take a while to finish all the tasks from a hard reset.. unless you didn't restore from backup.
    05-12-2016 04:42 PM
  3. ByeVanno's Avatar
    Originally posted by WayCool
    OS Version ?

    See the battery threads.... Plus if you did a hard reset how long has it been ? If recent it will likely take a while to finish all the tasks from a hard reset.. unless you didn't restore from backup.
    .318 I did a hard reset then got the newest update so since tuesday. But my battery suddenly got horrible so I did a hard reset to fix things but nothing changed
    05-12-2016 05:11 PM
  4. northernpipeman's Avatar
    I don't want to patronize, and I apologise if it sounds like it - this has always been an issue on the L950, so hopefully other people might pick up the thread as well.

    How did you run the hard reset, was it through the phones own reset option, or the recovery tool? It sounds like you have some wild process running in the background (broken app updating, or a hidden background task). But as ByeVanno says, a recovery can take a few days to properly install and it can knacker the battery and run hot when its doing this.
    05-13-2016 01:56 AM

Similar Threads

  1. Lumia 650 GPS problem? Need help!
    By Dano91 in forum Microsoft Lumia 650
    Replies: 16
    Last Post: 02-13-2017, 02:49 PM
  2. Opinions of AT&T Branded 1520 running Production Branch W10M
    By Andrew Fratkin in forum Nokia Lumia 1520
    Replies: 0
    Last Post: 05-12-2016, 07:17 PM
  3. I have a Lumina 640 - At&t, I cannot send Plain text.
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 05-12-2016, 06:04 PM
  4. Pick up Sony's 128GB microSD card for just $33 at Amazon
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-12-2016, 01:11 PM
  5. Watches to pair and WORK with Windows Phone/950???
    By hokap in forum Microsoft Lumia 950
    Replies: 0
    Last Post: 05-12-2016, 01:00 PM
LINK TO POST COPIED TO CLIPBOARD